aboutsummaryrefslogtreecommitdiff
path: root/net/dhid
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>2000-07-05 12:37:06 +0000
committerThomas Gellekum <tg@FreeBSD.org>2000-07-05 12:37:06 +0000
commit546041ba3113a4a58d8f3e7e7cb90e78fcb38ea8 (patch)
tree7b9cd553a62be7a9bd52800d334be8b703eb93a1 /net/dhid
parent01ab6da99c55af36e516b7f8016373124c4039cf (diff)
downloadports-546041ba3113a4a58d8f3e7e7cb90e78fcb38ea8.tar.gz
ports-546041ba3113a4a58d8f3e7e7cb90e78fcb38ea8.zip
Notes
Diffstat (limited to 'net/dhid')
-rw-r--r--net/dhid/Makefile4
-rw-r--r--net/dhid/files/dhid.sh20
2 files changed, 21 insertions, 3 deletions
diff --git a/net/dhid/Makefile b/net/dhid/Makefile
index 622c66866d7b..e01835a2e849 100644
--- a/net/dhid/Makefile
+++ b/net/dhid/Makefile
@@ -26,9 +26,7 @@ do-install:
post-install:
@if [ ! -f ${PREFIX}/etc/rc.d/dhid.sh ]; then \
${ECHO} "===> Installing ${PREFIX}/etc/rc.d/dhid.sh startup file."; \
- ${ECHO} "#!/bin/sh" > ${PREFIX}/etc/rc.d/dhid.sh; \
- ${ECHO} "[ -x \"${PREFIX}/sbin/dhid\" -a -f \"${PREFIX}/etc/dhid.conf\" ] && ${PREFIX}/sbin/dhid > /dev/null && ${ECHO} -n ' dhid'" >> ${PREFIX}/etc/rc.d/dhid.sh; \
- ${CHMOD} 751 ${PREFIX}/etc/rc.d/dhid.sh; \
+ ${INSTALL_SCRIPT} -m 751 ${FILESDIR}/dhid.sh ${PREFIX}/etc/rc.d/dhid.sh; \
fi;
@${ECHO} "--------------------------------------------------------------------------"
@${ECHO} "Before dhid can run, you will need to register with a DHIS provider."
diff --git a/net/dhid/files/dhid.sh b/net/dhid/files/dhid.sh
new file mode 100644
index 000000000000..510f4ab70d16
--- /dev/null
+++ b/net/dhid/files/dhid.sh
@@ -0,0 +1,20 @@
+#!/bin/sh
+
+if ! PREFIX=$(expr $0 : "\(/.*\)/etc/rc\.d/$(basename $0)\$"); then
+ echo "$0: Cannot determine the PREFIX" >&2
+ exit 1
+fi
+
+case "$1" in
+start)
+ [ -x "${PREFIX}/sbin/dhid" -a -f "${PREFIX}/etc/dhid.conf" ] && ${PREFIX}/sbin/dhid > /dev/null && echo -n ' dhid'
+ ;;
+stop)
+ killall dhid && echo -n ' dhid'
+ ;;
+*)
+ echo "Usage: `basename $0` {start|stop}" >&2
+ ;;
+esac
+
+exit 0