aboutsummaryrefslogtreecommitdiff
path: root/net/dictd
diff options
context:
space:
mode:
authorClive Lin <clive@FreeBSD.org>2004-08-30 07:48:27 +0000
committerClive Lin <clive@FreeBSD.org>2004-08-30 07:48:27 +0000
commit36842f7eccd7589c1ac958b5579e8fef46bec476 (patch)
tree99e94759addc3cdd9d1aa139281bb87e2225297c /net/dictd
parent23889fbf045be2ab033b7379d80d8c62d9a151f0 (diff)
downloadports-36842f7eccd7589c1ac958b5579e8fef46bec476.tar.gz
ports-36842f7eccd7589c1ac958b5579e8fef46bec476.zip
Really support rc.subr on RELENG_4.
Pointy hat to: myself
Notes
Notes: svn path=/head/; revision=117631
Diffstat (limited to 'net/dictd')
-rw-r--r--net/dictd/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/net/dictd/Makefile b/net/dictd/Makefile
index e61b4b8f6285..9454cef29cf7 100644
--- a/net/dictd/Makefile
+++ b/net/dictd/Makefile
@@ -28,6 +28,9 @@ CONFIGURE_ARGS= --with-etcdir=${PREFIX}/etc --with-cflags="${CFLAGS}" \
--without-local-zlib
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+
+RC_SCRIPTS_SUB= PREFIX=${PREFIX} RC_SUBR=${RC_SUBR}
+
USE_GMAKE= yes
ALL_TARGET= dictd dictzip
@@ -50,7 +53,7 @@ post-install:
.endfor
@${SED} "s|%%PREFIX%%|${PREFIX}|g" < ${FILESDIR}/${PORTNAME}.conf > ${PREFIX}/etc/${PORTNAME}.conf.sample
@[ -f ${PREFIX}/etc/${PORTNAME}.conf ] || ${CP} ${PREFIX}/etc/${PORTNAME}.conf.sample ${PREFIX}/etc/${PORTNAME}.conf
- @${SED} "s|%%PREFIX%%|${PREFIX}|g" < ${FILESDIR}/${PORTNAME}.sh > ${PREFIX}/etc/rc.d/${PORTNAME}.sh
+ @${SED} ${RC_SCRIPTS_SUB:S/$/!g/:S/^/ -e s!%%/:S/=/%%!/} ${FILESDIR}/${PORTNAME}.sh > ${PREFIX}/etc/rc.d/${PORTNAME}.sh
@${CHMOD} +x ${PREFIX}/etc/rc.d/${PORTNAME}.sh
@${SED} "s|%%PREFIX%%|${PREFIX}|g" < ${PKGMESSAGE}