aboutsummaryrefslogtreecommitdiff
path: root/net/dlint/Makefile
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>1998-12-23 17:57:50 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>1998-12-23 17:57:50 +0000
commitfd6b63bd867168d4c33ff142b3fbe4ae0ba7970c (patch)
tree2c558dfd061db472a3715cd53cafaacd1a9aee4f /net/dlint/Makefile
parent0416cf4f666c39196ed7501a4cd21d9e69e85223 (diff)
Notes
Diffstat (limited to 'net/dlint/Makefile')
-rw-r--r--net/dlint/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/net/dlint/Makefile b/net/dlint/Makefile
new file mode 100644
index 000000000000..b0b6471d51d4
--- /dev/null
+++ b/net/dlint/Makefile
@@ -0,0 +1,34 @@
+# ex:ts=8
+# Ports collection makefile for: dlint
+# Version required: 1.3.2
+# Date created: Wed Dec 23, 1998
+# Whom: David O'Brien (obrien@NUXI.com)
+#
+# $Id: Makefile,v 1.2 1997/01/25 18:08:40 obrien Exp $
+#
+
+DISTNAME= dlint1.3.2
+PKGNAME= dlint-1.3.2
+CATEGORIES= net
+MASTER_SITES= http://www.domtools.com/pub/
+
+MAINTAINER= obrien@FreeBSD.org
+
+NO_BUILD= yes
+MAN8= dlint.8
+
+do-configure:
+ @${MV} ${WRKSRC}/dlint ${WRKSRC}/dlint.orig
+ @${SED} -e 's:/usr/local/bin:${PREFIX}/sbin:g' \
+ ${WRKSRC}/dlint.orig >${WRKSRC}/dlint
+ @${SED} -e 's:DLINT 1:DLINT 8:g' ${WRKSRC}/dlint.1 >${WRKSRC}/dlint.8
+
+do-install:
+ cd ${WRKSRC} ; ${INSTALL_SCRIPT} dlint digparse ${PREFIX}/sbin
+ ${INSTALL_MAN} ${WRKSRC}/dlint.8 ${PREFIX}/man/man8
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/dlint
+ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/dlint
+.endif
+
+.include <bsd.port.mk>