aboutsummaryrefslogtreecommitdiff
path: root/net/dpdk/Makefile
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2020-06-16 23:53:16 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2020-06-16 23:53:16 +0000
commit14d9f00be082b4a55e6ae0b306ee45fbdeb8635e (patch)
treecd297caddffb2f4d61ba0d2be0b4a7a5d5f0d38c /net/dpdk/Makefile
parent61eba97f8dc63baef1cef202f0cd16eb05f554ff (diff)
downloadports-14d9f00be082b4a55e6ae0b306ee45fbdeb8635e.tar.gz
ports-14d9f00be082b4a55e6ae0b306ee45fbdeb8635e.zip
Notes
Diffstat (limited to 'net/dpdk/Makefile')
-rw-r--r--net/dpdk/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/net/dpdk/Makefile b/net/dpdk/Makefile
index dcda6ec63207..15a70ef099af 100644
--- a/net/dpdk/Makefile
+++ b/net/dpdk/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= dpdk
-DISTVERSION= 19.11
-PORTREVISION= 2
+DISTVERSION= 19.11.2
CATEGORIES= net
MASTER_SITES= http://fast.dpdk.org/rel/
@@ -15,8 +14,10 @@ ONLY_FOR_ARCHS= amd64
ONLY_FOR_ARCHS_REASON= Only works on 64-bit x86 hardware
LIB_DEPENDS= libjansson.so:devel/jansson
+BUILD_DEPENDS= objdump:devel/binutils
-USES= meson kmod shebangfix tar:xz
+USES= meson kmod pkgconfig shebangfix tar:xz python:3.5+
+WRKSRC= ${WRKDIR}/${PORTNAME}-stable-${PORTVERSION}
MESON_ARGS= -Dmachine=default -Ddefault_library=shared
USE_LDCONFIG= yes
SHEBANG_FILES= usertools/dpdk-pmdinfo.py \
@@ -42,6 +43,5 @@ DEBUG_MESON_ON= --buildtype=debug
DEBUG_MESON_OFF= --buildtype=release
TESTS_MESON_TRUE= tests
TOOLS_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyelftools>=0:devel/py-pyelftools@${PY_FLAVOR}
-TOOLS_USES= python:3.5+
.include <bsd.port.mk>