aboutsummaryrefslogtreecommitdiff
path: root/net/echoping/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2013-03-05 17:07:43 +0000
committerMartin Wilke <miwi@FreeBSD.org>2013-03-05 17:07:43 +0000
commitfb3520254ab73be0aad04c3a63b781750cf26b5b (patch)
tree268d74f9d8738f78b0c895672044611aa6343387 /net/echoping/Makefile
parent4706739618b79681811e5b336a54032908638160 (diff)
downloadports-fb3520254ab73be0aad04c3a63b781750cf26b5b.tar.gz
ports-fb3520254ab73be0aad04c3a63b781750cf26b5b.zip
Notes
Diffstat (limited to 'net/echoping/Makefile')
-rw-r--r--net/echoping/Makefile29
1 files changed, 13 insertions, 16 deletions
diff --git a/net/echoping/Makefile b/net/echoping/Makefile
index 8ecd2a0011c7..1fd3251878ec 100644
--- a/net/echoping/Makefile
+++ b/net/echoping/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: echoping
-# Date created: 13 April 1997
-# Whom: peter
-#
+# Created by: peter
# $FreeBSD$
-#
PORTNAME= echoping
PORTVERSION= 6.0.0
@@ -20,22 +16,19 @@ LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt \
USE_OPENSSL= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-http --enable-icp --enable-smtp --with-ssl \
- --enable-ttcp --enable-tos --with-libidn=${LOCALBASE}
+ --enable-ttcp --enable-tos --with-libidn=${LOCALBASE} \
+ --enable-plugin="${PING_PLUGINS}"
PING_PLUGINS= dns random whois
MAN1= echoping.1 echoping_dns.1 echoping_random.1 echoping_whois.1
-OPTIONS= LDAP "Enable LDAP plug-in" on \
- PGSQL "Enable PostgreSQL plug-in" off
+OPTIONS_DEFINE= LDAP PGSQL
+OPTIONS_DEFAULT= LDAP
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "ia64" || ${ARCH} == "powerpc"
-BROKEN= Does not link on ia64 or powerpc
-.endif
+.include <bsd.port.options.mk>
-.if defined(WITH_LDAP)
+.if ${PORT_OPTIONS:MLDAP}
USE_OPENLDAP= yes
MAN1+= echoping_ldap.1
PING_PLUGINS+= ldap
@@ -44,7 +37,7 @@ PLIST_SUB= WITH_LDAP=""
PLIST_SUB= WITH_LDAP="@comment "
.endif
-.if defined(WITH_PGSQL)
+.if ${PORT_OPTIONS:MPGSQL}
USE_PGSQL= yes
MAN1+= echoping_postgresql.1
PING_PLUGINS+= postgresql
@@ -53,7 +46,11 @@ PLIST_SUB+= WITH_PGSQL=""
PLIST_SUB+= WITH_PGSQL="@comment "
.endif
-CONFIGURE_ARGS+=--enable-plugin="${PING_PLUGINS}"
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "ia64" || ${ARCH} == "powerpc"
+BROKEN= Does not link on ia64 or powerpc
+.endif
post-patch:
@${FIND} ${WRKSRC} -name configure | ${XARGS} ${REINPLACE_CMD} -e 's|echo aout|echo elf|'