aboutsummaryrefslogtreecommitdiff
path: root/net/ekiga/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2006-04-06 13:04:59 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2006-04-06 13:04:59 +0000
commitf788274c3242cac161dafb04972cf5e7f54de8fc (patch)
tree7784c35f0b12c0e4c94b01b6273bb9003a4c67ee /net/ekiga/Makefile
parent334c286de9ffda977d63b1ac39b3bd0d02c364d1 (diff)
downloadports-f788274c3242cac161dafb04972cf5e7f54de8fc.tar.gz
ports-f788274c3242cac161dafb04972cf5e7f54de8fc.zip
Notes
Diffstat (limited to 'net/ekiga/Makefile')
-rw-r--r--net/ekiga/Makefile47
1 files changed, 15 insertions, 32 deletions
diff --git a/net/ekiga/Makefile b/net/ekiga/Makefile
index 65c934081d4d..446da3f48eea 100644
--- a/net/ekiga/Makefile
+++ b/net/ekiga/Makefile
@@ -5,49 +5,32 @@
# $FreeBSD$
#
-PORTNAME= gnomemeeting
-PORTVERSION= 1.2.1
+PORTNAME= ekiga
+PORTVERSION= 2.0.1
CATEGORIES= net gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:R}
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/2.0
-MAINTAINER= netchild@FreeBSD.org
-COMMENT= GNOME H323 Video Conferencing program, similar to NetMeeting
+MAINTAINER= jbq@caraldi.com
+COMMENT= VoIP phone for Gnome
-LIB_DEPENDS= h323_r:${PORTSDIR}/net/openh323 \
- howl:${PORTSDIR}/net/howl
+LIB_DEPENDS= opal__r.2:${PORTSDIR}/net/opal \
+ avahi-core.4:${PORTSDIR}/net/avahi \
+ ebook-1.2.5:${PORTSDIR}/databases/evolution-data-server
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GNOME= libgnomeui libbonobo gnomeprefix gnomehack evolutiondataserver \
- intlhack
-USE_OPENLDAP= yes
-GCONF_SCHEMAS= gnomemeeting.schemas
-USE_SDL= yes
-USE_BISON= yes
-# Clear configure target so we stop getting binaries prefixed with i386-portbld-freebsd46
-CONFIGURE_TARGET=
+USE_SDL= sdl
+USE_GNOME= libgnomeui libbonobo gnomeprefix gnomehack gnomelibs gnomedocutils
USE_AUTOTOOLS= libtool:15
-CONFIGURE_ENV= OSTYPE=${OPSYS} \
- CXXFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${PREFIX}/lib -L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
- SDL_CONFIG=${LOCALBASE}/bin/sdl11-config \
- CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
- PTLIBDIR=${PREFIX}
+LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+CONFIGURE_ENV= SDL_CONFIG=${LOCALBASE}/bin/sdl11-config LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --with-pwlib-dir=${LOCALBASE} \
- --with-openh323-dir=${LOCALBASE} \
- --with-ldap-dir=${LOCALBASE}
+ --with-opal-dir=${LOCALBASE}
-MAN1= gnomemeeting.1
-
-post-patch:
- ${REINPLACE_CMD} -e 's:-lh323_FreeBSD_x86_r_s:-lh323_r:g; \
- s:-lpt_FreeBSD_x86_r_s:-lpt_r:g; \
- s:-lh323_FreeBSD_x86_r:-lh323_r:g; \
- s:-lpt_FreeBSD_x86_r:-lpt_r:g; \
- s: -DSTATIC_LIBS_USED::g' \
- ${WRKSRC}/configure
+GCONF_SCHEMAS= ekiga.schemas
+MAN1= ekiga.1
.include <bsd.port.mk>