aboutsummaryrefslogtreecommitdiff
path: root/net/ekiga/Makefile
diff options
context:
space:
mode:
authorSam Lawrance <lawrance@FreeBSD.org>2005-12-17 09:51:15 +0000
committerSam Lawrance <lawrance@FreeBSD.org>2005-12-17 09:51:15 +0000
commitd7697402794452e8d9e9981a3ba0b269c21e731c (patch)
tree92f9cdc727db389701569d06a116522043c49d6c /net/ekiga/Makefile
parent6489ac1ff441f19487044ab43d225101c39f11f2 (diff)
downloadports-d7697402794452e8d9e9981a3ba0b269c21e731c.tar.gz
ports-d7697402794452e8d9e9981a3ba0b269c21e731c.zip
Notes
Diffstat (limited to 'net/ekiga/Makefile')
-rw-r--r--net/ekiga/Makefile20
1 files changed, 12 insertions, 8 deletions
diff --git a/net/ekiga/Makefile b/net/ekiga/Makefile
index edef926d0643..8caed373d57b 100644
--- a/net/ekiga/Makefile
+++ b/net/ekiga/Makefile
@@ -33,22 +33,26 @@ CONFIGURE_TARGET=
GNU_CONFIGURE= YES
CONFIGURE_ENV= OSTYPE=${OPSYS} \
LIBS="-L${PREFIX}/lib -L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
- PTLIBDIR=${WRKDIRPREFIX}${.CURDIR}/../../devel/pwlib/work/pwlib \
- OPENH323DIR=${WRKDIRPREFIX}${.CURDIR}/../openh323/work/openh323 \
+ PTLIBDIR=${PWLIBDIR} \
+ OPENH323DIR=${OPENH323DIR} \
SDL_CONFIG=${LOCALBASE}/bin/sdl11-config \
CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}"
-CONFIGURE_ARGS= --with-ptlib-includes=${WRKDIRPREFIX}${.CURDIR}/../../devel/pwlib/work/pwlib/include/ptlib \
- --with-ptlib-libs=${WRKDIRPREFIX}${.CURDIR}/../../devel/pwlib/work/pwlib/lib \
- --with-openh323-includes=${WRKDIRPREFIX}${.CURDIR}/../openh323/work/openh323/include \
- --with-openh323-libs=${WRKDIRPREFIX}${.CURDIR}/../openh323/work/openh323/lib \
- --with-ldap-includes=${LOCALBASE}/include \
- --with-openldap-libs=${LOCALBASE}/lib
+CONFIGURE_ARGS= --with-ptlib-includes=${PWLIBDIR}/include/ptlib \
+ --with-ptlib-libs=${PWLIBDIR}/lib \
+ --with-openh323-includes=${OPENH323DIR}/include \
+ --with-openh323-libs=${OPENH323DIR}/lib \
+ --with-ldap-includes=${LOCALBASE}/include \
+ --with-openldap-libs=${LOCALBASE}/lib
+
GCONF_SCHEMAS= gnomemeeting.schemas
MAN1= gnomemeeting.1
.include <bsd.port.pre.mk>
+PWLIBDIR!= cd ${PORTSDIR}/devel/pwlib && make -V WRKSRC
+OPENH323DIR!= cd ${PORTSDIR}/net/openh323 && make -V WRKSRC
+
.if ${ARCH} != "i386"
BROKEN= "Configure fails on !i386"
.endif