aboutsummaryrefslogtreecommitdiff
path: root/net/ekiga
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2005-02-01 18:55:00 +0000
committerKoop Mast <kwm@FreeBSD.org>2005-02-01 18:55:00 +0000
commita2ed2060e3a3ca5f44e38f632eb03bde6cb829c3 (patch)
tree6033b83b379026e6a0f32daae76809d6dd39bfda /net/ekiga
parent49073b1bd0be7275f06e951f6052364f23dda81e (diff)
downloadports-a2ed2060e3a3ca5f44e38f632eb03bde6cb829c3.tar.gz
ports-a2ed2060e3a3ca5f44e38f632eb03bde6cb829c3.zip
Notes
Diffstat (limited to 'net/ekiga')
-rw-r--r--net/ekiga/Makefile31
-rw-r--r--net/ekiga/files/patch-src_sound_handling.cpp11
-rw-r--r--net/ekiga/pkg-plist21
3 files changed, 38 insertions, 25 deletions
diff --git a/net/ekiga/Makefile b/net/ekiga/Makefile
index 0a3b656f8f82..91c33eef31c3 100644
--- a/net/ekiga/Makefile
+++ b/net/ekiga/Makefile
@@ -9,44 +9,49 @@ PORTNAME= gnomemeeting
PORTVERSION= 0.98.5
PORTREVISION= 4
CATEGORIES= net gnome
-MASTER_SITES= ftp://ftp.gnome.org/pub/GNOME/sources/gnomemeeting/0.98/ \
- # http://www.gnomemeeting.org/downloads/0.98.0/sources/
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.98
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= kwm@FreeBSD.org
COMMENT= GNOME H323 Video Conferencing program, similar to NetMeeting
-BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/net/openh323:build
-
-BROKEN= "Does not build"
-EXPIRATION_DATE=2005-02-18
-DEPRECATED= ${BROKEN}
+BUILD_DEPENDS= ${NONEXISTENT}:${PORTSDIR}/net/openh323:build
# note, we do not want to clean openh323, otherwise it has to build
# it all over again which can take several hours.
-NOCLEANDEPENDS= yes
+NOCLEANDEPENDS= yes
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOME= libgnomeui libbonobo gnomeprefix gnomehack
+USE_REINPLACE= yes
USE_OPENLDAP= yes
USE_BISON= yes
# Clear configure target so we stop getting binaries prefixed with i386-portbld-freebsd46
CONFIGURE_TARGET=
GNU_CONFIGURE= YES
-CONFIGURE_ENV= OSTYPE=${OPSYS} \
+CONFIGURE_ENV= OSTYPE=${OPSYS} \
LIBS="-L${PREFIX}/lib -L${LOCALBASE}/lib" \
PTLIBDIR=${WRKDIRPREFIX}${.CURDIR}/../../devel/pwlib/work/pwlib \
OPENH323DIR=${WRKDIRPREFIX}${.CURDIR}/../openh323/work/openh323 \
SDL_CONFIG=${LOCALBASE}/bin/sdl11-config \
CPPFLAGS="-I${LOCALBASE}/include"
-CONFIGURE_ARGS= --with-ptlib-includes=${WRKDIRPREFIX}${.CURDIR}/../../devel/pwlib/work/pwlib/include/ptlib \
+CONFIGURE_ARGS= --with-ptlib-includes=${WRKDIRPREFIX}${.CURDIR}/../../devel/pwlib/work/pwlib/include/ptlib \
--with-ptlib-libs=${WRKDIRPREFIX}${.CURDIR}/../../devel/pwlib/work/pwlib/lib \
--with-openh323-includes=${WRKDIRPREFIX}${.CURDIR}/../openh323/work/openh323/include \
--with-openh323-libs=${WRKDIRPREFIX}${.CURDIR}/../openh323/work/openh323/lib \
--with-ldap-includes=${LOCALBASE}/include \
--with-openldap-libs=${LOCALBASE}/lib
-
+GCONF_SCHEMAS= gnomemeeting.schemas
MAN1= gnomemeeting.1
-.include <bsd.port.mk>
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ ${REINPLACE_CMD} -E -e 's=-D[[:punct:][:alnum:]]+_DISABLE_DEPRECATED==g' \
+ ${WRKSRC}/src/Makefile.am \
+ ${WRKSRC}/src/Makefile.in
+
+.include <bsd.port.post.mk>
diff --git a/net/ekiga/files/patch-src_sound_handling.cpp b/net/ekiga/files/patch-src_sound_handling.cpp
new file mode 100644
index 000000000000..8af2fe631bbc
--- /dev/null
+++ b/net/ekiga/files/patch-src_sound_handling.cpp
@@ -0,0 +1,11 @@
+--- src/sound_handling.cpp.orig Thu Jan 27 14:47:01 2005
++++ src/sound_handling.cpp Thu Jan 27 14:57:07 2005
+@@ -466,7 +466,7 @@
+ dialog =
+ gtk_dialog_new_with_buttons ("Audio test running...",
+ GTK_WINDOW (gw->druid_window),
+- (enum GtkDialogFlags) (GTK_DIALOG_DESTROY_WITH_PARENT),
++ (GtkDialogFlags) (GTK_DIALOG_DESTROY_WITH_PARENT),
+ GTK_STOCK_OK,
+ GTK_RESPONSE_ACCEPT,
+ NULL);
diff --git a/net/ekiga/pkg-plist b/net/ekiga/pkg-plist
index 914786a58cba..b0c86c53ac98 100644
--- a/net/ekiga/pkg-plist
+++ b/net/ekiga/pkg-plist
@@ -1,9 +1,15 @@
-share/gnome/pixmaps/gnomemeeting-logo-icon.png
-share/gnome/pixmaps/gnomemeeting-logo.png
-share/gnome/pixmaps/gnomemeeting-splash.png
bin/gnomemeeting
bin/gnomemeeting-config-tool
+etc/sound/events/gnomemeeting.soundlist
libdata/bonobo/servers/gnomemeeting.server
+share/gnome/applications/gnomemeeting.desktop
+share/gnome/gnomemeeting/xdap/ils_nm_mod.xml
+share/gnome/gnomemeeting/xdap/ils_nm_reg.xml
+share/gnome/gnomemeeting/xdap/ils_nm_unreg.xml
+share/gnome/pixmaps/gnomemeeting-logo-icon.png
+share/gnome/pixmaps/gnomemeeting-logo.png
+share/gnome/pixmaps/gnomemeeting-splash.png
+share/gnome/sounds/gnomemeeting/gnomemeeting.wav
share/locale/am/LC_MESSAGES/gnomemeeting.mo
share/locale/az/LC_MESSAGES/gnomemeeting.mo
share/locale/be/LC_MESSAGES/gnomemeeting.mo
@@ -45,15 +51,6 @@ share/locale/vi/LC_MESSAGES/gnomemeeting.mo
share/locale/wa/LC_MESSAGES/gnomemeeting.mo
share/locale/zh_CN/LC_MESSAGES/gnomemeeting.mo
share/locale/zh_TW/LC_MESSAGES/gnomemeeting.mo
-share/gnome/sounds/gnomemeeting/gnomemeeting.wav
-etc/sound/events/gnomemeeting.soundlist
-share/gnome/gnomemeeting/xdap/ils_nm_reg.xml
-share/gnome/gnomemeeting/xdap/ils_nm_unreg.xml
-share/gnome/gnomemeeting/xdap/ils_nm_mod.xml
-share/gnome/applications/gnomemeeting.desktop
-@unexec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-uninstall-rule %D/etc/gconf/schemas/gnomemeeting.schemas > /dev/null || /usr/bin/true
-etc/gconf/schemas/gnomemeeting.schemas
-@exec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-install-rule %D/etc/gconf/schemas/gnomemeeting.schemas > /dev/null || /usr/bin/true
@dirrm share/gnome/sounds/gnomemeeting
@dirrm share/gnome/gnomemeeting/xdap
@dirrm share/gnome/gnomemeeting