aboutsummaryrefslogtreecommitdiff
path: root/net/ekiga
diff options
context:
space:
mode:
authorRoger Hardiman <roger@FreeBSD.org>2003-09-05 12:35:42 +0000
committerRoger Hardiman <roger@FreeBSD.org>2003-09-05 12:35:42 +0000
commitda3081c17f08c328a8692320f029190176e41530 (patch)
treef1ed43aa8fcbbf902b708894ca30ccbf358554ee /net/ekiga
parentbdf5c70aa17deea56b725db7faadc42f0c169dca (diff)
downloadports-da3081c17f08c328a8692320f029190176e41530.tar.gz
ports-da3081c17f08c328a8692320f029190176e41530.zip
Notes
Diffstat (limited to 'net/ekiga')
-rw-r--r--net/ekiga/Makefile1
-rw-r--r--net/ekiga/files/patch-endpoint37
2 files changed, 38 insertions, 0 deletions
diff --git a/net/ekiga/Makefile b/net/ekiga/Makefile
index d0a9c427f092..0938e75687f3 100644
--- a/net/ekiga/Makefile
+++ b/net/ekiga/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gnomemeeting
PORTVERSION= 0.98.4
+PORTREVISION= 1
CATEGORIES= net gnome
MASTER_SITES= http://www.gnomemeeting.org/downloads/0.98.0/sources/ \
ftp://ftp.gnome.org/pub/GNOME/sources/gnomemeeting/0.98/
diff --git a/net/ekiga/files/patch-endpoint b/net/ekiga/files/patch-endpoint
new file mode 100644
index 000000000000..c906400224db
--- /dev/null
+++ b/net/ekiga/files/patch-endpoint
@@ -0,0 +1,37 @@
+*** src/endpoint.cpp.orig Thu Jul 31 17:26:36 2003
+--- src/endpoint.cpp Fri Sep 5 11:40:58 2003
+*************** GMH323EndPoint::GMH323EndPoint ()
+*** 176,183 ****
+
+ /* Use IPv6 address family by default if available. */
+ #ifdef P_HAS_IPV6
+! if (PIPSocket::IsIpAddressFamilyV6Supported())
+! PIPSocket::SetDefaultIpAddressFamilyV6();
+ #endif
+
+ rtp_port_range =
+--- 176,185 ----
+
+ /* Use IPv6 address family by default if available. */
+ #ifdef P_HAS_IPV6
+! // ENABLING THIS CAUSES PWLIB TO GIVE AN ASSERTION WHEN THERE IS AN
+! // INCOMING CALL
+! // if (PIPSocket::IsIpAddressFamilyV6Supported())
+! // PIPSocket::SetDefaultIpAddressFamilyV6();
+ #endif
+
+ rtp_port_range =
+*************** GMH323EndPoint::TranslateTCPAddress(PIPS
+*** 682,687 ****
+--- 684,694 ----
+
+ && !((remoteAddr.Byte1() == 172)
+ && ((remoteAddr.Byte2() >= 16)&&(remoteAddr.Byte2()<=31)))
++
++ && !((remoteAddr.Byte1() == 127)
++ &&(remoteAddr.Byte2()== 0)
++ &&(remoteAddr.Byte3()==0)
++ &&(remoteAddr.Byte4()==1))
+
+ && !(remoteAddr.Byte1() == 10)) {
+