aboutsummaryrefslogtreecommitdiff
path: root/net/empty
diff options
context:
space:
mode:
authorVsevolod Stakhov <vsevolod@FreeBSD.org>2005-09-19 10:41:34 +0000
committerVsevolod Stakhov <vsevolod@FreeBSD.org>2005-09-19 10:41:34 +0000
commit7c2a5c31da63e049616d479457b7fb573b0bc401 (patch)
treee097c47b30c353e483d56473463059af7396ca34 /net/empty
parent2fc3a82370f852b7feec5595eab1475e7553a26b (diff)
downloadports-7c2a5c31da63e049616d479457b7fb573b0bc401.tar.gz
ports-7c2a5c31da63e049616d479457b7fb573b0bc401.zip
Notes
Diffstat (limited to 'net/empty')
-rw-r--r--net/empty/Makefile25
-rw-r--r--net/empty/distinfo2
-rw-r--r--net/empty/files/patch-Makefile14
-rw-r--r--net/empty/pkg-descr8
4 files changed, 49 insertions, 0 deletions
diff --git a/net/empty/Makefile b/net/empty/Makefile
new file mode 100644
index 000000000000..ea78e4bfcb95
--- /dev/null
+++ b/net/empty/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: empty
+# Date created: 17 September 2005
+# Whom: Mikhail Zakharov <zmey20000@yahoo.com>
+#
+# $FreeBSD$
+
+PORTNAME= empty
+PORTVERSION= 0.6.0b
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= zmey20000@yahoo.com
+COMMENT= Expect-like tool for pure shell
+
+MAN1= empty.1
+
+PLIST_FILES= bin/empty
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/empty ${PREFIX}/bin/empty
+ ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${MAN1PREFIX}/man/man1/
+
+.include <bsd.port.mk>
diff --git a/net/empty/distinfo b/net/empty/distinfo
new file mode 100644
index 000000000000..fbab0f9450bc
--- /dev/null
+++ b/net/empty/distinfo
@@ -0,0 +1,2 @@
+MD5 (empty-0.6.0b.tgz) = 3c151388372b83c60f1f18d3210cb28d
+SIZE (empty-0.6.0b.tgz) = 8951
diff --git a/net/empty/files/patch-Makefile b/net/empty/files/patch-Makefile
new file mode 100644
index 000000000000..f36fdab48200
--- /dev/null
+++ b/net/empty/files/patch-Makefile
@@ -0,0 +1,14 @@
+--- Makefile.orig Mon Sep 19 14:32:32 2005
++++ Makefile Mon Sep 19 14:33:23 2005
+@@ -3,8 +3,10 @@
+ # make to build for *BSD or Linux
+ #
+
++CC ?= gcc
++
+ all:
+- gcc -lutil -o empty empty.c
++ ${CC} ${CFLAGS} -lutil -o empty empty.c
+
+ FreeBSD: all
+ NetBSD: all
diff --git a/net/empty/pkg-descr b/net/empty/pkg-descr
new file mode 100644
index 000000000000..bfe11f91e911
--- /dev/null
+++ b/net/empty/pkg-descr
@@ -0,0 +1,8 @@
+empty - run applications under pseudo-terminal (PTY) sessions and replace
+TCL/Expect with a simple tool and use your favorite shell (sh, bash, csh,
+tcsh,Xksh, zsh, etc)
+
+WWW: http://empty.sourceforge.net/
+
+- Mikhail Zakharov
+zmey20000@yahoo.com