aboutsummaryrefslogtreecommitdiff
path: root/net/ethereal/Makefile
diff options
context:
space:
mode:
authorBill Fumerola <billf@FreeBSD.org>2001-07-25 07:32:52 +0000
committerBill Fumerola <billf@FreeBSD.org>2001-07-25 07:32:52 +0000
commit7231b8fbbc1631b989fb4bae5ded0ed17809fa52 (patch)
treea10a3f312c9f26675f31edde5ce940d4ec9e543a /net/ethereal/Makefile
parentebc29a4584412bfcdabd83a45be560ca97e15221 (diff)
Notes
Diffstat (limited to 'net/ethereal/Makefile')
-rw-r--r--net/ethereal/Makefile15
1 files changed, 14 insertions, 1 deletions
diff --git a/net/ethereal/Makefile b/net/ethereal/Makefile
index 77c624ab1932..63df9220f70e 100644
--- a/net/ethereal/Makefile
+++ b/net/ethereal/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= ethereal
-PORTVERSION= 0.8.16
+PORTVERSION= 0.8.19
CATEGORIES= net ipv6
MASTER_SITES= ftp://ftp.ethereal.com/pub/ethereal/ \
ftp://gd.tuwien.ac.at/infosys/security/ethereal/ \
@@ -15,13 +15,26 @@ MASTER_SITES= ftp://ftp.ethereal.com/pub/ethereal/ \
MAINTAINER= billf@FreeBSD.org
+.if defined(WITH_SNMP)
+LIB_DEPENDS= snmp.4:${PORTSDIR}/net/net-snmp
+.endif
+
USE_X_PREFIX= yes
USE_GTK= yes
USE_LIBTOOL= yes
LIBTOOLFILES= configure epan/configure wiretap/configure
+.if defined(WITH_SNMP)
+CONFIGURE_ARGS+= --enable-snmp=yes
+.if exists(/usr/include/openssl/crypto.h)
+CONFIGURE_ARGS+= --with-ssl=/usr
+.endif
+.else
CONFIGURE_ARGS+= --enable-snmp=no
+.endif
PLIST_SUB= PORTVERSION=${PORTVERSION}
+USE_GMAKE= yes
+
MAN1= ethereal.1 tethereal.1 editcap.1
pre-install: