aboutsummaryrefslogtreecommitdiff
path: root/net/ethereal
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-08-14 00:33:57 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-08-14 00:33:57 +0000
commit6b0314e72aca6ef587ba9aa4036cd9ee0f175292 (patch)
treee8ca4392c1d8ace1cd48bf3dbe453da93727408f /net/ethereal
parent08363af9ca9e3ca0a53cb3be0b06cb0850dbeb98 (diff)
downloadports-6b0314e72aca6ef587ba9aa4036cd9ee0f175292.tar.gz
ports-6b0314e72aca6ef587ba9aa4036cd9ee0f175292.zip
Notes
Diffstat (limited to 'net/ethereal')
-rw-r--r--net/ethereal/Makefile8
-rw-r--r--net/ethereal/distinfo4
-rw-r--r--net/ethereal/files/patch-configure16
-rw-r--r--net/ethereal/pkg-plist3
4 files changed, 16 insertions, 15 deletions
diff --git a/net/ethereal/Makefile b/net/ethereal/Makefile
index ca4659130709..7901c158de2c 100644
--- a/net/ethereal/Makefile
+++ b/net/ethereal/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= ethereal
-PORTVERSION= 0.10.5
-PORTREVISION= 1
+PORTVERSION= 0.10.6
CATEGORIES= net ipv6
MASTER_SITES= ftp://ftp.ethereal.com/pub/ethereal/all-versions/ \
ftp://gd.tuwien.ac.at/infosys/security/ethereal/all-versions/ \
@@ -24,7 +23,7 @@ WANT_GNOME= yes
CONFIGURE_ARGS+= --program-transform-name=""
INSTALLS_SHLIB= yes
-.for x in editcap idl2eth mergecap text2pcap
+.for x in capinfo editcap idl2eth mergecap text2pcap
.if defined(LITE)
PLIST_SUB+= ${x:U}="@comment $x not installed"
CONFIGURE_ARGS+= --enable-$x=no
@@ -59,8 +58,7 @@ CONFIGURE_ARGS+= --enable-ethereal=no \
.endif
USE_LIBTOOL_VER=15
-LIBTOOLFILES= configure wiretap/configure doc/configure \
- plugins/gryphon/configure
+LIBTOOLFILES= configure wiretap/configure
PLIST_SUB+= PORTVERSION=${PORTVERSION}
.if ${OSVERSION} >= 400014 && !defined(WITHOUT_IPV6)
diff --git a/net/ethereal/distinfo b/net/ethereal/distinfo
index 8ffbfc2becc3..e32c5907e968 100644
--- a/net/ethereal/distinfo
+++ b/net/ethereal/distinfo
@@ -1,2 +1,2 @@
-MD5 (ethereal-0.10.5.tar.bz2) = 26d5672935ac8bd0793fcd2ad0b4833f
-SIZE (ethereal-0.10.5.tar.bz2) = 4984584
+MD5 (ethereal-0.10.6.tar.bz2) = 722a2529c3a19b5b81c825bca444baea
+SIZE (ethereal-0.10.6.tar.bz2) = 5046796
diff --git a/net/ethereal/files/patch-configure b/net/ethereal/files/patch-configure
index c9f169180061..da831bbcb12a 100644
--- a/net/ethereal/files/patch-configure
+++ b/net/ethereal/files/patch-configure
@@ -1,7 +1,7 @@
---- configure.orig Wed Jul 7 18:26:59 2004
-+++ configure Tue Jul 20 19:11:24 2004
-@@ -15937,7 +15937,7 @@
- KRB5_LIBS="-lkrb5 -lasn1 -lcrypto -lroken -lcrypt -lresolv"
+--- configure.orig Thu Aug 12 22:04:27 2004
++++ configure Fri Aug 13 18:40:18 2004
+@@ -15934,7 +15934,7 @@
+ KRB5_LIBS="-lkrb5 -lasn1 $SSL_LIBS -lroken -lcrypt -lresolv"
ethereal_save_LDFLAGS="$LDFLAGS"
LDFLAGS="$LDFLAGS -L$krb5_dir/lib"
- ac_krb5_version=`grep -i heimdal $krb5_dir/include/krb5.h | head -n 1 | sed 's/^.*heimdal.*$/HEIMDAL/i'`
@@ -9,7 +9,7 @@
else
# Extract the first word of "krb5-config", so it can be a program name with args.
set dummy krb5-config; ac_word=$2
-@@ -15980,10 +15980,10 @@
+@@ -15977,10 +15977,10 @@
if test -x "$KRB5_CONFIG"
then
@@ -17,8 +17,8 @@
+ KRB5_FLAGS=`"$KRB5_CONFIG" --cflags | sed -e 's/@INCLUDE_des@//g'`
CFLAGS="$CFLAGS $KRB5_FLAGS"
CPPFLAGS="$CPPFLAGS $KRB5_FLAGS"
-- KRB5_LIBS=`"$KRB5_CONFIG" --libs`
-+ KRB5_LIBS=`"$KRB5_CONFIG" --libs | sed -e 's/@INCLUDE_des@//g'`
+- KRB5_LIBS=`"$KRB5_CONFIG" --libs | sed 's/-lcrypto//'`
++ KRB5_LIBS=`"$KRB5_CONFIG" --libs | sed 's/-lcrypto//' | sed -e 's/@INCLUDE_des@//g'`
+ KRB5_LIBS="$KRB5_LIBS $SSL_LIBS"
# Looks like krb5-config is lacking -lresolv on some systems
echo "$as_me:$LINENO: checking whether library list looks OK" >&5
- echo $ECHO_N "checking whether library list looks OK... $ECHO_C" >&6
diff --git a/net/ethereal/pkg-plist b/net/ethereal/pkg-plist
index 77bf9a45f524..91204fa4255d 100644
--- a/net/ethereal/pkg-plist
+++ b/net/ethereal/pkg-plist
@@ -1,3 +1,4 @@
+%%CAPINFO%%
bin/dftest
%%EDITCAP%%
%%ETHEREAL%%
@@ -18,6 +19,7 @@ lib/ethereal/plugins/%%PORTVERSION%%/irda.so
lib/ethereal/plugins/%%PORTVERSION%%/lwres.so
lib/ethereal/plugins/%%PORTVERSION%%/megaco.so
lib/ethereal/plugins/%%PORTVERSION%%/mgcp.so
+lib/ethereal/plugins/%%PORTVERSION%%/opsi.so
lib/ethereal/plugins/%%PORTVERSION%%/pcli.so
lib/ethereal/plugins/%%PORTVERSION%%/rdm.so
lib/ethereal/plugins/%%PORTVERSION%%/rlm.so
@@ -31,6 +33,7 @@ lib/libwiretap.a
lib/libwiretap.so
lib/libwiretap.so.0
share/ethereal/AUTHORS-SHORT
+share/ethereal/capinfo.html
share/ethereal/diameter/dictionary.dtd
share/ethereal/diameter/dictionary.xml
share/ethereal/diameter/mobileipv4.xml