aboutsummaryrefslogtreecommitdiff
path: root/net/flowgrep/Makefile
diff options
context:
space:
mode:
authorSam Lawrance <lawrance@FreeBSD.org>2005-06-29 14:32:03 +0000
committerSam Lawrance <lawrance@FreeBSD.org>2005-06-29 14:32:03 +0000
commit9b986e19b4515468cd0c8f01d95c57d90de49169 (patch)
tree6612c52b8030b922761c7bea8f1ea7ac0bba748f /net/flowgrep/Makefile
parent11134ebd3d621962812a5b5160c72a0762da7704 (diff)
downloadports-9b986e19b4515468cd0c8f01d95c57d90de49169.tar.gz
ports-9b986e19b4515468cd0c8f01d95c57d90de49169.zip
Notes
Diffstat (limited to 'net/flowgrep/Makefile')
-rw-r--r--net/flowgrep/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/net/flowgrep/Makefile b/net/flowgrep/Makefile
new file mode 100644
index 000000000000..305fd4c81c25
--- /dev/null
+++ b/net/flowgrep/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: flowgrep
+# Date created: 22 Jun 2005
+# Whom: Corey Smith
+#
+# $FreeBSD$
+#
+
+PORTNAME= flowgrep
+PORTVERSION= 0.8a
+CATEGORIES= net security
+MASTER_SITES= http://www.monkey.org/~jose/software/flowgrep/
+DISTNAME= flowgrep-${PORTVERSION}
+
+MAINTAINER= corsmith@gmail.com
+COMMENT= TCP stream/UDP/IP payload 'grep' utility
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/nidsmodule.so:${PORTSDIR}/net/pynids
+
+USE_PYTHON= YES
+
+NO_BUILD= YES
+
+PLIST_FILES= sbin/flowgrep
+
+MAN8= flowgrep.8
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/flowgrep.py ${PREFIX}/sbin/flowgrep
+ ${INSTALL_MAN} ${WRKSRC}/flowgrep.8 ${PREFIX}/man/man8/flowgrep.8
+
+.include <bsd.port.mk>