aboutsummaryrefslogtreecommitdiff
path: root/net/flowscan/Makefile
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-03-14 01:14:44 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-03-14 01:14:44 +0000
commitaf7cead469757c1a594b4e5b1503f74afbdb1722 (patch)
tree5dd3350c42cb1d1af4a22d28e9b5fa86df559f6d /net/flowscan/Makefile
parent5b8fe0427bc1cf2b1a46c982b8fe47eb2ec304ae (diff)
downloadports-af7cead469757c1a594b4e5b1503f74afbdb1722.tar.gz
ports-af7cead469757c1a594b4e5b1503f74afbdb1722.zip
Notes
Diffstat (limited to 'net/flowscan/Makefile')
-rw-r--r--net/flowscan/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/net/flowscan/Makefile b/net/flowscan/Makefile
new file mode 100644
index 000000000000..127ec29d9e06
--- /dev/null
+++ b/net/flowscan/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: flowscan
+# Date created: Di 13 Mär 2001 08:23:55 CET
+# Whom: andreas@freebsd.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= flowscan
+PORTVERSION= 1.006
+CATEGORIES= net
+MASTER_SITES= http://net.doit.wisc.edu/~plonka/FlowScan/
+
+MAINTAINER= andreas@freebsd.org
+
+BUILD_DEPENDS= ksh:${PORTSDIR}/shells/pdksh \
+ rrdtool:${PORTSDIR}/net/rrdtool \
+ cflowd:${PORTSDIR}/net/cflowd \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Boulder/Stream.pm:${PORTSDIR}/converter/p5-Boulder \
+ ${LOCALBASE}/lib/perl5/site_perl/${{PERL_VER}/ConfigReader/DirectiveStyle.pm:${PORTSDIR}/devel/p5-ConfigReader \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/HTML/Table.pm:${PORTSDIR}/www/p5-HTML-Table \
+ ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Cflow.pm:${PORTSDIR}/net/p5-Cflow
+
+CFLOWD_FLOWSCAN_PATCH= yes
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS+= --prefix=${PREFIX}/var/flows
+
+pre-install:
+ ${MKDIR} -p ${PREFIX}/var/flows/bin
+
+.include <bsd.port.mk>