aboutsummaryrefslogtreecommitdiff
path: root/net/fpc-inet
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-01-16 01:01:43 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-01-16 01:01:43 +0000
commit2717e46c960589233a78eb87bb92f44a09fefae0 (patch)
treeca9dfa1a422c4227e13843e19744df8ee6cf8e3a /net/fpc-inet
parent72cf9139a9123b36587a2b8fbc8f0252afdb201c (diff)
downloadports-2717e46c960589233a78eb87bb92f44a09fefae0.tar.gz
ports-2717e46c960589233a78eb87bb92f44a09fefae0.zip
Notes
Diffstat (limited to 'net/fpc-inet')
-rw-r--r--net/fpc-inet/Makefile76
-rw-r--r--net/fpc-inet/distinfo1
-rw-r--r--net/fpc-inet/pkg-descr8
-rw-r--r--net/fpc-inet/pkg-plist4
4 files changed, 89 insertions, 0 deletions
diff --git a/net/fpc-inet/Makefile b/net/fpc-inet/Makefile
new file mode 100644
index 000000000000..a19e0fc0bcc0
--- /dev/null
+++ b/net/fpc-inet/Makefile
@@ -0,0 +1,76 @@
+# New ports collection makefile for: Free Pascal Compiler
+# Date created: 28 November 2001
+# Whom: John Merryweather Cooper et al
+#
+# $FreeBSD$
+#
+
+PORTNAME= inet
+PORTVERSION= 1.0.10
+CATEGORIES= net
+MASTER_SITES= ftp://ftp.freepascal.org/pub/fpc/dist/FreeBSD/ \
+ http://planetmirror.com/pub/fpc/dist/FreeBSD/ \
+ ftp://ftp.jp.freepascal.org/mirror/fpc/dist/FreeBSD/ \
+ ftp://freepascal.stack.nl/pub/fpc/dist/FreeBSD/ \
+ ftp://ftp.no.freepascal.org/pub/fpc/dist/FreeBSD/ \
+ ftp://ftp.us.freepascal.org/pub/fpc/dist/FreeBSD/ \
+ ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= freepascal
+PKGNAMEPREFIX= fpc-
+DISTNAME= fpc-${PORTVERSION}.ELF
+EXTRACT_SUFX= .tar
+
+MAINTAINER= coop9211@uidaho.edu
+COMMENT= Free Pascal routines for internet programming
+
+.include <bsd.port.pre.mk>
+
+BUILD_DEPENDS= ppc386:${PORTSDIR}/lang/fpc
+RUN_DEPENDS= ${BUILD_DEPENDS}
+.if ${OSVERSION} >= 500000
+LIB_DEPENDS= c.4:${PORTSDIR}/misc/compat4x
+.endif
+.if ${OSVERSION} < 470000
+EXTRACT_DEPENDS= gtar:${PORTSDIR}/archivers/gtar
+TAR= ${LOCALBASE}/bin/gtar
+.endif
+USE_GMAKE= yes
+USE_REINPLACE= yes
+ONLY_FOR_ARCHS= i386
+
+PLIST_SUB+= PORTVERSION=${PORTVERSION}
+
+MAKE_ENV+= PATH=${LOCALBASE}/bin:$$PATH \
+ FPC=${LOCALBASE}/bin/ppc386 \
+ INSTALL_BASEDIR=${PREFIX}/lib/fpc/${PORTVERSION} \
+ INSTALL_BINDIR=${PREFIX}/bin \
+ GCCLIBDIR=/usr/lib \
+ RELEASE=1
+
+do-extract:
+# unpack distribution
+ @${MKDIR} ${WRKSRC}
+ @${TAR} xf ${DISTDIR}/${DISTNAME}.tar --directory ${WRKSRC}
+# unpack sources distribution
+ @${MKDIR} ${WRKSRC}/sources
+ @${TAR} xf ${WRKSRC}/sources.tar --directory ${WRKSRC}/sources
+# further extract base sources
+#
+# inet sources
+ @${TAR} zxf ${WRKSRC}/sources/unitsinetsrc.tar.gz \
+ --directory ${WRKSRC}
+
+post-patch:
+# change to alter amount of optimization
+ @${FIND} ${WRKSRC}/share/src/fpc-${PORTVERSION} -name \
+ "Makefile*" | ${XARGS} ${REINPLACE_CMD} 's|-OG2p3|-OG2p1|g'
+
+do-build:
+ cd ${WRKSRC}/share/src/fpc-${PORTVERSION}/packages/base/inet && \
+ ${GMAKE} ${MAKE_ENV} all
+
+do-install:
+ cd ${WRKSRC}/share/src/fpc-${PORTVERSION}/packages/base/inet && \
+ ${GMAKE} ${MAKE_ENV} install
+
+.include <bsd.port.post.mk>
diff --git a/net/fpc-inet/distinfo b/net/fpc-inet/distinfo
new file mode 100644
index 000000000000..cdc32c64a7d3
--- /dev/null
+++ b/net/fpc-inet/distinfo
@@ -0,0 +1 @@
+MD5 (fpc-1.0.10.ELF.tar) = 6ad56eb115152174683499da3ece7667
diff --git a/net/fpc-inet/pkg-descr b/net/fpc-inet/pkg-descr
new file mode 100644
index 000000000000..55ac2d4eb0c5
--- /dev/null
+++ b/net/fpc-inet/pkg-descr
@@ -0,0 +1,8 @@
+Inet is part of the base packages of Free Pascal, a 32-bit
+Turbo Pascal/Delphi compatible compiler. Inet provides
+routines for internet programming.
+
+WWW: http://www.freepascal.org/
+
+--
+John Merryweather Cooper <coop9211@uidaho.edu>
diff --git a/net/fpc-inet/pkg-plist b/net/fpc-inet/pkg-plist
new file mode 100644
index 000000000000..5eae3d0222f4
--- /dev/null
+++ b/net/fpc-inet/pkg-plist
@@ -0,0 +1,4 @@
+lib/fpc/%%PORTVERSION%%/units/freebsd/inet/Package.fpc
+lib/fpc/%%PORTVERSION%%/units/freebsd/inet/inet.o
+lib/fpc/%%PORTVERSION%%/units/freebsd/inet/inet.ppu
+@dirrm lib/fpc/%%PORTVERSION%%/units/freebsd/inet