aboutsummaryrefslogtreecommitdiff
path: root/net/freebsd-tftp/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2008-01-31 10:14:59 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2008-01-31 10:14:59 +0000
commit764e348a3545249c50007a91c7ba03636b82e67f (patch)
treeaa76ab6852dd3b12d8283a35c213e9a8b6adf3dd /net/freebsd-tftp/Makefile
parentae9f81062faec0ebb006cfdf31e7e86693ef615c (diff)
downloadports-764e348a3545249c50007a91c7ba03636b82e67f.tar.gz
ports-764e348a3545249c50007a91c7ba03636b82e67f.zip
Notes
Diffstat (limited to 'net/freebsd-tftp/Makefile')
-rw-r--r--net/freebsd-tftp/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/net/freebsd-tftp/Makefile b/net/freebsd-tftp/Makefile
new file mode 100644
index 000000000000..396f8d330044
--- /dev/null
+++ b/net/freebsd-tftp/Makefile
@@ -0,0 +1,31 @@
+# Ports collection makefile for: net/freebsd-tftp
+# Whom: Edwin Groothuis <edwin@FreeBSD.org>
+# Date created: 2008-01-30
+#
+# $FreeBSD$
+#
+
+PORTNAME= freebsd-tftp
+PORTVERSION= 1.0
+CATEGORIES= net
+MASTER_SITES= http://www.mavetju.org/download/
+
+MAINTAINER= edwin@FreeBSD.org
+COMMENT= Upcoming replacement for tftp(1) and tftpd(8)
+
+PLIST_FILES= bin/tftp libexec/tftpd
+
+WRKSRC= ${WRKDIR}
+NOPACKAGE= Installs software in /usr/libexec and /usr/bin
+PREFIX= /usr
+
+MAN8= tftpd.8
+MAN1= tftp.1
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/usr.bin/tftp/tftp ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/libexec/tftpd/tftpd ${PREFIX}/libexec
+ ${INSTALL_MAN} ${WRKSRC}/usr.bin/tftp/tftp.1 ${PREFIX}/share/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/libexec/tftpd/tftpd.8 ${PREFIX}/share/man/man8
+
+.include <bsd.port.mk>