aboutsummaryrefslogtreecommitdiff
path: root/net/freenet6/files
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2014-06-27 08:26:58 +0000
committerJason E. Hale <jhale@FreeBSD.org>2014-06-27 08:26:58 +0000
commitfc65d01d20ad7434353c465b0b462b945887c983 (patch)
tree5eb76a95bbbc6969d6760305e122c2dc0ad0efa1 /net/freenet6/files
parent274eea4d0d2814b911660f9270f07332c1d10e2a (diff)
downloadports-fc65d01d20ad7434353c465b0b462b945887c983.tar.gz
ports-fc65d01d20ad7434353c465b0b462b945887c983.zip
Notes
Diffstat (limited to 'net/freenet6/files')
-rw-r--r--net/freenet6/files/patch-Makefile (renamed from net/freenet6/files/patch-Makefiles-etcdir.patch)26
-rw-r--r--net/freenet6/files/patch-conf__Makefile11
-rw-r--r--net/freenet6/files/patch-src__lib__config.c (renamed from net/freenet6/files/patch-src_lib_config.c)0
-rw-r--r--net/freenet6/files/patch-template__Makefile15
-rw-r--r--net/freenet6/files/pkg-message.in1
5 files changed, 32 insertions, 21 deletions
diff --git a/net/freenet6/files/patch-Makefiles-etcdir.patch b/net/freenet6/files/patch-Makefile
index c74ac5bd0dba..5b2733c35166 100644
--- a/net/freenet6/files/patch-Makefiles-etcdir.patch
+++ b/net/freenet6/files/patch-Makefile
@@ -1,20 +1,5 @@
---- template/Makefile.orig 2009-11-15 19:42:51.000000000 +0100
-+++ template/Makefile 2009-11-15 19:43:01.000000000 +0100
-@@ -17,8 +17,10 @@
-
- install:
- @echo "Installing templates ..."
-- @for template_var in README $(PLATFORM).sh; do \
-- cp $${template_var} $(INSTALL_TEMPL)/$${template_var}; \
-+ @for template_var in $(PLATFORM).sh; do \
-+ cp $${template_var} $(INSTALL_BIN)/gw6c-$${template_var}; \
- done
-+ @mkdir -p $(ETCDIR)
-+ @cp README $(ETCDIR)
-
- clean:
---- Makefile.orig 2009-11-15 19:50:40.000000000 +0100
-+++ Makefile 2009-11-15 19:50:57.000000000 +0100
+--- ./Makefile.orig 2009-05-19 12:51:11.000000000 -0400
++++ ./Makefile 2014-06-27 04:03:52.000000000 -0400
@@ -74,7 +74,7 @@
#
.PHONY: all platform-check check-gw6c-pal check-gw6c-config check-gw6c-messaging build-gw6c check-gw6c-install install clean cleanall
@@ -61,13 +46,14 @@
$(MAKE) -C $$dir install || exit 1; \
done
- @cp $(TARGET) $(INSTALL_BIN)
+- @cp $(TARGET) $(INSTALL_BIN)
- @cp $(BIN_DIR)/gw6c.conf.sample $(INSTALL_BIN)
- @[ -f $(INSTALL_BIN)/gw6c.conf ] || { \
- cp $(INSTALL_BIN)/gw6c.conf.sample $(INSTALL_BIN)/gw6c.conf; \
- }
-+ @mkdir -p $(ETCDIR)
-+ @cp $(BIN_DIR)/gw6c.conf.sample $(ETCDIR)
++ ${BSD_INSTALL_PROGRAM} $(TARGET) $(INSTALL_BIN)
++ @mkdir -p $(DESTDIR)$(ETCDIR)
++ ${BSD_INSTALL_DATA} $(BIN_DIR)/gw6c.conf.sample $(DESTDIR)$(ETCDIR)
# This makefile target will clean the build tree of the Gateway6 Client.
diff --git a/net/freenet6/files/patch-conf__Makefile b/net/freenet6/files/patch-conf__Makefile
new file mode 100644
index 000000000000..9c2efccfb25f
--- /dev/null
+++ b/net/freenet6/files/patch-conf__Makefile
@@ -0,0 +1,11 @@
+--- ./conf/Makefile.orig 2009-05-19 12:50:14.000000000 -0400
++++ ./conf/Makefile 2014-06-27 03:51:00.000000000 -0400
+@@ -32,7 +32,7 @@
+ -e "s+@ifname_v6udpv4@+$(PLATFORM_V6UDPV4)+" \
+ -e "s+@ifname_v6v4@+$(PLATFORM_V6V4)+" \
+ -e "s+@conf_template@+$(PLATFORM)+" \
+- -e "s+@conf_gw6_dir@+$(INSTALL_DIR)+" \
++ -e "s+@conf_gw6_dir@+$(PREFIX)+" \
+ gw6c.conf.in > $(BIN_DIR)/gw6c.conf.sample
+ @chmod 700 $(BIN_DIR)/gw6c.conf.sample
+
diff --git a/net/freenet6/files/patch-src_lib_config.c b/net/freenet6/files/patch-src__lib__config.c
index cca41389a4e8..cca41389a4e8 100644
--- a/net/freenet6/files/patch-src_lib_config.c
+++ b/net/freenet6/files/patch-src__lib__config.c
diff --git a/net/freenet6/files/patch-template__Makefile b/net/freenet6/files/patch-template__Makefile
new file mode 100644
index 000000000000..3a122fa9d7d7
--- /dev/null
+++ b/net/freenet6/files/patch-template__Makefile
@@ -0,0 +1,15 @@
+--- ./template/Makefile.orig 2008-01-09 10:09:18.000000000 -0500
++++ ./template/Makefile 2014-06-27 03:51:00.000000000 -0400
+@@ -17,8 +17,10 @@
+
+ install:
+ @echo "Installing templates ..."
+- @for template_var in README $(PLATFORM).sh; do \
+- cp $${template_var} $(INSTALL_TEMPL)/$${template_var}; \
++ @for template_var in $(PLATFORM).sh; do \
++ cp $${template_var} $(INSTALL_BIN)/gw6c-$${template_var}; \
+ done
++ @mkdir -p $(DESTDIR)$(ETCDIR)
++ ${BSD_INSTALL_DATA} README $(DESTDIR)$(ETCDIR)
+
+ clean:
diff --git a/net/freenet6/files/pkg-message.in b/net/freenet6/files/pkg-message.in
index d900c33dcbea..0dd99723b259 100644
--- a/net/freenet6/files/pkg-message.in
+++ b/net/freenet6/files/pkg-message.in
@@ -1,6 +1,5 @@
Now that the package is installed, please finish it with the following steps:
-- Copy %%PREFIX%%/etc/gw6c.conf.example to %%PREFIX%%/etc/gw6c.conf
- Check the values of %%PREFIX%%/etc/gw6c.conf. If you have registered at
the website, fill in your userid and password there.
- Add 'freenet6_enable="YES"' to your /etc/rc.conf to make it start