aboutsummaryrefslogtreecommitdiff
path: root/net/freeradius/files
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2006-02-04 19:52:39 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2006-02-04 19:52:39 +0000
commitcfd0564ceff1fb81b76937bd0d3267c6ac558d03 (patch)
tree28d176ccb7bad27cc25e3b43b558964f4b2b77ca /net/freeradius/files
parent9797596975697d07155b68fb67c8d81e6eb1abae (diff)
Notes
Diffstat (limited to 'net/freeradius/files')
-rw-r--r--net/freeradius/files/patch-4.11-fix48
-rw-r--r--net/freeradius/files/radiusd.in (renamed from net/freeradius/files/radiusd.sh)0
2 files changed, 48 insertions, 0 deletions
diff --git a/net/freeradius/files/patch-4.11-fix b/net/freeradius/files/patch-4.11-fix
new file mode 100644
index 000000000000..b58a4d5c91e4
--- /dev/null
+++ b/net/freeradius/files/patch-4.11-fix
@@ -0,0 +1,48 @@
+--- src/modules/rlm_otp/cardops/cryptocard.c.ORIG Thu Dec 8 02:30:54 2005
++++ src/modules/rlm_otp/cardops/cryptocard.c Sat Feb 4 18:30:55 2006
+@@ -20,6 +20,10 @@
+ */
+
+ #include <inttypes.h>
++#if (defined(__FreeBSD__) && __FreeBSD_version < 500000)
++#define PRIx32 "x" /* uint32_t */
++#define SCNx32 "x" /* uint32_t */
++#endif
+ #include <string.h>
+ #include <time.h>
+
+--- src/modules/rlm_otp/otp_state.c.ORIG Sat Feb 4 18:22:14 2006
++++ src/modules/rlm_otp/otp_state.c Sat Feb 4 18:33:48 2006
+@@ -28,6 +28,10 @@
+
+ #include <errno.h>
+ #include <inttypes.h>
++#if (defined(__FreeBSD__) && __FreeBSD_version < 500000)
++#define PRIx32 "x" /* uint32_t */
++#define SCNx32 "x" /* uint32_t */
++#endif
+ #include <stdio.h>
+ #include <string.h>
+ #include <sys/types.h>
+--- src/modules/rlm_otp/otp_cardops.c.ORIG Thu Dec 8 02:30:50 2005
++++ src/modules/rlm_otp/otp_cardops.c Sat Feb 4 18:37:22 2006
+@@ -30,6 +30,9 @@
+ #endif
+ #include <dlfcn.h>
+ #include <inttypes.h>
++#if (defined(__FreeBSD__) && __FreeBSD_version < 500000)
++#define INT32_MAX 0x7fffffff
++#endif
+ #include <limits.h>
+ #include <stdlib.h>
+ #include <string.h>
+--- src/modules/rlm_otp/Makefile.in.ORIG Thu Dec 8 02:30:48 2005
++++ src/modules/rlm_otp/Makefile.in Sat Feb 4 18:44:06 2006
+@@ -34,7 +34,7 @@
+ include ../rules.mak
+
+ # Not part of RLM_CFLAGS to avoid propagation to subdirs
+-CFLAGS += -Wno-unused-label -Wno-cast-qual
++CFLAGS += -Wno-cast-qual
+
+ $(STATIC_OBJS): $(HEADERS) $(CARDOPS_LTLIBS)
diff --git a/net/freeradius/files/radiusd.sh b/net/freeradius/files/radiusd.in
index 7f18ab7c40d2..7f18ab7c40d2 100644
--- a/net/freeradius/files/radiusd.sh
+++ b/net/freeradius/files/radiusd.in