aboutsummaryrefslogtreecommitdiff
path: root/net/freeradius2/Makefile
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2012-12-07 14:44:18 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2012-12-07 14:44:18 +0000
commitde70b3e29b8126f58057ce5a97ee196fc9cf5f88 (patch)
tree1c6ea05196141c9733e52b146f76c6d240b19abb /net/freeradius2/Makefile
parent7b3feb480bc92d900c8d954525e658947ff74444 (diff)
downloadports-de70b3e29b8126f58057ce5a97ee196fc9cf5f88.tar.gz
ports-de70b3e29b8126f58057ce5a97ee196fc9cf5f88.zip
Notes
Diffstat (limited to 'net/freeradius2/Makefile')
-rw-r--r--net/freeradius2/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/net/freeradius2/Makefile b/net/freeradius2/Makefile
index afcc23326262..31ae7ae5ca37 100644
--- a/net/freeradius2/Makefile
+++ b/net/freeradius2/Makefile
@@ -45,7 +45,7 @@ PLIST_SUB= PORTVERSION=${DISTVERSION}
OPTIONS_DEFINE= USER KERBEROS HEIMDAL HEIMDAL_PORT HEIMDAL_PATCH LDAP MYSQL \
PGSQL UNIXODBC FIREBIRD PERL PYTHON OCI8 RUBY DHCP \
- EXPERIMENTAL UDPFROMTO DEVELOPER
+ EXPERIMENTAL UDPFROMTO DEVELOPER EDIR
OPTIONS_DEFAULT=USER PERL PYTHON
DHCP_DESC= With DHCP support (EXPERIMENTAL)
@@ -59,6 +59,7 @@ OCI8_DESC= With Oracle support (currently experimental)
EXPERIMENTAL_DESC= Build experimental modules
UDPFROMTO_DESC= Compile in UDPFROMTO support
DEVELOPER_DESC= Enable developer options
+EDIR_DESC= Enable eDirectory support (implies LDAP)
.include <bsd.port.options.mk>
@@ -114,6 +115,13 @@ PLIST_SUB+= KRB5="@comment "
EXTRA_PATCHES+= ${FILESDIR}/extra-patch-src__modules__rlm_krb5__rlm_krb5.c
.endif
+.if ${PORT_OPTIONS:MEDIR}
+CONFIGURE_ARGS+=--with-edir
+.if empty(${PORT_OPTIONS:MLDAP})
+PORT_OPTIONS+= LDAP
+.endif
+.endif
+
.if ${PORT_OPTIONS:MLDAP}
USE_OPENLDAP= YES
CONFIGURE_ARGS+=--with-rlm_ldap