aboutsummaryrefslogtreecommitdiff
path: root/net/freeradius
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2006-02-06 14:24:47 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2006-02-06 14:24:47 +0000
commitb289fc51b03e973256d202c0664bebadd28b6025 (patch)
tree38aeaf7c9653a9e20263ea6da483917666fb9f03 /net/freeradius
parentc6c8724a7077ed83500e8dd2645bf2a051829d0c (diff)
downloadports-b289fc51b03e973256d202c0664bebadd28b6025.tar.gz
ports-b289fc51b03e973256d202c0664bebadd28b6025.zip
Notes
Diffstat (limited to 'net/freeradius')
-rw-r--r--net/freeradius/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/net/freeradius/Makefile b/net/freeradius/Makefile
index 27a86cf5c03b..5bb11838a450 100644
--- a/net/freeradius/Makefile
+++ b/net/freeradius/Makefile
@@ -38,6 +38,7 @@ CONFIGURE_ARGS= --prefix=${PREFIX} --quiet --with-logdir=${LOGDIR} \
PLIST_SUB= PORTVERSION=${PORTVERSION}
OPTIONS= KERBEROS "With Kerberos support" off \
+ HEIMDAL "With Heimdal Kerberos support" off \
LDAP "With LDAP user database" off \
MYSQL "With MySQL user database" off \
PGSQL "With PostgreSQL use database" off \
@@ -46,8 +47,17 @@ OPTIONS= KERBEROS "With Kerberos support" off \
.include <bsd.port.pre.mk>
+.if defined(WITH_HEIMDAL) && !defined(WITH_KERBEROS)
+WITH_KERBEROS= yes
+.endif
+
.ifdef(WITH_KERBEROS)
+.ifdef(WITH_HEIMDAL)
+LIB_DEPENDS+= krb5.20:${PORTSDIR}/security/heimdal
+CONFIGURE_ARGS+=--enable-heimdal-krb5
+.else
LIB_DEPENDS+= krb5.3:${PORTSDIR}/security/krb5
+.endif
CONFIGURE_ARGS+=--with-rlm-krb5-lib-dir=${LOCALBASE}/lib
CONFIGURE_ARGS+=--with-rlm-krb5-include-dir=${LOCALBASE}/include
PLIST_SUB+= KRB5=""