aboutsummaryrefslogtreecommitdiff
path: root/net/freeswitch-core-devel
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2012-05-22 19:12:47 +0000
committerChris Rees <crees@FreeBSD.org>2012-05-22 19:12:47 +0000
commite634049e1e2c2ba95c1337ee2c4f539b870240fa (patch)
treedec704474a3562520156db82e26f705562843c18 /net/freeswitch-core-devel
parent1168d661487f507d126c83e406bb71afb687ec74 (diff)
Notes
Diffstat (limited to 'net/freeswitch-core-devel')
-rw-r--r--net/freeswitch-core-devel/Makefile20
-rw-r--r--net/freeswitch-core-devel/files/pkg-install.in14
-rw-r--r--net/freeswitch-core-devel/pkg-plist1
3 files changed, 17 insertions, 18 deletions
diff --git a/net/freeswitch-core-devel/Makefile b/net/freeswitch-core-devel/Makefile
index e4f97bc069f8..50ca78284293 100644
--- a/net/freeswitch-core-devel/Makefile
+++ b/net/freeswitch-core-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= freeswitch
DISTVERSION= 1.2.rc2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= http://files.freeswitch.org/ \
http://files.freeswitch.org/downloads/libs/:2 \
@@ -89,8 +89,6 @@ GROUPS= ${FREESWITCH_GROUP}
SUB_LIST= FREESWITCH_USER=${FREESWITCH_USER} \
FREESWITCH_GROUP=${FREESWITCH_GROUP}
-BASE_PORTNAME= ${FREESWITCH_USER}
-
VARBASE= /var
ETCDIR= ${PREFIX}/etc/${PORTNAME}
WWWDIR= ${PREFIX}/www/${PORTNAME}
@@ -334,18 +332,20 @@ post-configure:
pre-install:
@${CHMOD} 664 ${WRKSRC}/libs/freetdm/conf/*
@${MKDIR} ${ETCDIR}/conf
+ @${TOUCH} ${ETCDIR}/conf/.freeswitch-core-devel
.if defined(WITH_MODFREETDM)
@${MKDIR} ${ETCDIR}/conf/autoload_configs
.endif
- @${FIND} ${PREFIX}/etc/${BASE_PORTNAME}/. -type d | ${XARGS} ${CHMOD} 770
post-install:
@${SETENV} PKG_PREFIX=${PREFIX} \
- ${SH} ${PKGINSTALL} ${BASE_PORTNAME} POST-INSTALL
- @${FIND} ${ETCDIR}/. -type d | ${XARGS} ${CHMOD} 770
- @${MKDIR} ${PREFIX}/share/${BASE_PORTNAME}/sounds
- @${CHMOD} -R 770 ${PREFIX}/share/${BASE_PORTNAME}
- @${FIND} ${ETCDIR}/. -type f | ${XARGS} ${CHMOD} 660
- @${FIND} ${WWWDIR}/. -type f | ${XARGS} ${CHMOD} 660
+ ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+ @${CHOWN} -R ${USERS}:${GROUPS} ${ETCDIR} ${DATADIR} \
+ ${PREFIX}/include/${PORTNAME} \
+ ${PREFIX}/lib/${PORTNAME}
+ @${FIND} ${ETCDIR} -type d | ${XARGS} ${CHMOD} 770
+ @${MKDIR} ${DATADIR}/sounds
+ @${CHMOD} -R 770 ${DATADIR}
+ @${FIND} ${ETCDIR} ${WWWDIR} -type f | ${XARGS} ${CHMOD} 660
.include <bsd.port.mk>
diff --git a/net/freeswitch-core-devel/files/pkg-install.in b/net/freeswitch-core-devel/files/pkg-install.in
index 94fd2debd181..8a1e177eb6b9 100644
--- a/net/freeswitch-core-devel/files/pkg-install.in
+++ b/net/freeswitch-core-devel/files/pkg-install.in
@@ -1,5 +1,5 @@
#!/bin/sh
-# $FreeBSD: /tmp/pcvs/ports/net/freeswitch-core-devel/files/pkg-install.in,v 1.1 2012-05-17 21:03:11 crees Exp $
+# $FreeBSD: /tmp/pcvs/ports/net/freeswitch-core-devel/files/pkg-install.in,v 1.2 2012-05-22 19:12:47 crees Exp $
#
if [ "$2" != "POST-INSTALL" ]; then
@@ -13,17 +13,15 @@ for dir in \
do install -d -o %%FREESWITCH_USER%% -g %%FREESWITCH_GROUP%% ${PKG_PREFIX}/$dir
done
-for dir in etc/freeswitch include/freeswitch lib/freeswitch share/freeswitch
- do chown %%FREESWITCH_USER%%:%%FREESWITCH_GROUP%% ${PKG_PREFIX}/$dir
-done
-
find ${PKG_PREFIX}/etc/freeswitch/ -type d -exec chmod 770 {} +
find ${PKG_PREFIX}/etc/freeswitch/ -type f -exec chmod 660 {} +
+/usr/sbin/chown -R %%FREESWITCH_USER%%:%%FREESWITCH_GROUP%% \
+ %%ETCDIR%% %%DATADIR%% \
+ ${PKG_PREFIX}/include/freeswitch \
+ ${PKG_PREFIX}/lib/freeswitch
chmod 775 ${PKG_PREFIX}/share/freeswitch
-@cwd /var
-
for dir in \
db/freeswitch \
freeswitch/recordings \
@@ -33,7 +31,7 @@ done
echo "This port chown -R various directories %%FREESWITCH_USER%%:%%FREESWITCH_GROUP%%"
echo "This port chmod -R 770 various directories"
-echo" This port chmod -R 660 various files"
+echo "This port chmod -R 660 various files"
echo "This is for security reasons. In the event something should"
echo "stop working, please take the time to check the following dirs:"
echo " /var/log/freeswitch /var/freeswitch"
diff --git a/net/freeswitch-core-devel/pkg-plist b/net/freeswitch-core-devel/pkg-plist
index 9004e00bb061..9639998669be 100644
--- a/net/freeswitch-core-devel/pkg-plist
+++ b/net/freeswitch-core-devel/pkg-plist
@@ -6,6 +6,7 @@ bin/fs_ivrd
bin/fsxs
bin/gentls_cert
bin/tone2wav
+%%ETCDIR%%/conf/.freeswitch-core-devel
%%MODFREETDM%%%%ETCDIR%%/conf/autoload_configs/freetdm.conf.xml.sample
%%MODFREETDM%%%%ETCDIR%%/conf/freetdm.conf.sample
%%MODFREETDM%%%%ETCDIR%%/conf/pika.conf.sample