aboutsummaryrefslogtreecommitdiff
path: root/net/frickin
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2006-12-03 22:13:07 +0000
committerMartin Wilke <miwi@FreeBSD.org>2006-12-03 22:13:07 +0000
commit6c449833f55b8278ad44a815ecf6e5745cda026a (patch)
tree6c4ad82dd0c573a488dd47a3531b3c5d8cca0472 /net/frickin
parenteda61255a992d0849dee86e2ed1ad7ae257fa0af (diff)
downloadports-6c449833f55b8278ad44a815ecf6e5745cda026a.tar.gz
ports-6c449833f55b8278ad44a815ecf6e5745cda026a.zip
Notes
Diffstat (limited to 'net/frickin')
-rw-r--r--net/frickin/Makefile44
-rw-r--r--net/frickin/distinfo3
-rw-r--r--net/frickin/files/frickin.sh.in38
-rw-r--r--net/frickin/files/pkg-message.in10
-rw-r--r--net/frickin/pkg-descr4
5 files changed, 99 insertions, 0 deletions
diff --git a/net/frickin/Makefile b/net/frickin/Makefile
new file mode 100644
index 000000000000..d700f81fdb61
--- /dev/null
+++ b/net/frickin/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: frickin
+# Date created: 2 December 2006
+# Whom: Alex Miller <asm@asm.kiev.ua>
+#
+# $FreeBSD$
+#
+
+PORTNAME= frickin
+DISTVERSION= 2.0BETA1
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= frickin
+
+MAINTAINER= asm@asm.kiev.ua
+COMMENT= Frickin PPTP Proxy
+
+USE_RC_SUBR= frickin.sh
+SUB_FILES= pkg-message
+PORTDOCS= INSTALL HISTORY
+PLIST_FILES= sbin/frickin2 etc/frickin.conf.sample
+PKGMESSAGE= ${WRKDIR}/pkg-messag
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME}2 ${PREFIX}/sbin/${PORTNAME}2
+ ${INSTALL_DATA} ${WRKSRC}/frickin.conf ${PREFIX}/etc/frickin.conf.sample
+
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+
+.for i in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+IGNORE= FreeBSD 4.xx does not have pf support
+.elif ${OSVERSION} < 600000
+IGNORE= Does not compile with old version of pf
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/frickin/distinfo b/net/frickin/distinfo
new file mode 100644
index 000000000000..ace0117b7c96
--- /dev/null
+++ b/net/frickin/distinfo
@@ -0,0 +1,3 @@
+MD5 (frickin-2.0BETA1.tar.gz) = 86c3355fedd9f9000188d909ab8974aa
+SHA256 (frickin-2.0BETA1.tar.gz) = 3bc84ae187d32f677e74c5039bab68cb4982638849a80798fe58c9b0c508ff2a
+SIZE (frickin-2.0BETA1.tar.gz) = 475441
diff --git a/net/frickin/files/frickin.sh.in b/net/frickin/files/frickin.sh.in
new file mode 100644
index 000000000000..1a9844fbf350
--- /dev/null
+++ b/net/frickin/files/frickin.sh.in
@@ -0,0 +1,38 @@
+#!/bin/sh
+#
+# Startup script for frickin PPTP proxy.
+#
+# $FreeBSD$
+#
+
+# REQUIRE: DAEMON
+
+# Define these frickin_* variables in one of these files:
+# /etc/rc.conf
+# /etc/rc.conf.local
+# /etc/rc.conf.d/frickin
+#
+# frickin_enable : bool
+# Enable the transport ("YES") or not ("NO", the default).
+# frickin_config : string
+# Path to config file
+#
+
+frickin_enable=${frickin_enable-"NO"}
+frickin_conf=${frickin_conf-""}
+
+. %%RC_SUBR%%
+
+
+name="frickin"
+rcvar=`set_rcvar`
+
+load_rc_config ${name}
+
+command="%%PREFIX%%/sbin/${name}2"
+
+if [ ! -z "${frickin_conf}" -a -f ${frickin_conf} ]; then
+ frickin_flags="-c ${frickin_conf}"
+fi
+
+run_rc_command "$1"
diff --git a/net/frickin/files/pkg-message.in b/net/frickin/files/pkg-message.in
new file mode 100644
index 000000000000..92bf3168d212
--- /dev/null
+++ b/net/frickin/files/pkg-message.in
@@ -0,0 +1,10 @@
+Please read %%DOCSDIR%%/INSTALL
+for detailed instructions how to use this port.
+
+echo frickin_enable=\"YES\" >> /etc/rc.conf
+
+and
+
+cp %%PREFIX%%/etc/frickin.conf.sample %%PREFIX%%/etc/frickin.conf
+
+Edit it for your needs before first run.
diff --git a/net/frickin/pkg-descr b/net/frickin/pkg-descr
new file mode 100644
index 000000000000..f5f8a3bc61ee
--- /dev/null
+++ b/net/frickin/pkg-descr
@@ -0,0 +1,4 @@
+Frickin PPTP Proxy is a way to NAT as many PPTP connections as you like
+through your OpenBSD PF firewall.
+
+WWW: http://frickin.sourceforge.net/