aboutsummaryrefslogtreecommitdiff
path: root/net/g2ipmsg/Makefile
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2006-12-24 14:55:14 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2006-12-24 14:55:14 +0000
commit82a896436b68c31c1062cfe4a8c6ae0919ab4f6e (patch)
tree6a05949314cbd730612517eb8648810c2453fdcc /net/g2ipmsg/Makefile
parent9efa298faec2dc053c0eaae2c9ed99a9cc907d7a (diff)
Notes
Diffstat (limited to 'net/g2ipmsg/Makefile')
-rw-r--r--net/g2ipmsg/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/net/g2ipmsg/Makefile b/net/g2ipmsg/Makefile
new file mode 100644
index 000000000000..e2d7348ab6bf
--- /dev/null
+++ b/net/g2ipmsg/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: g2ipmsg
+# Date created: 2006/12/18
+# Whom: Norikatsu Shigemura <nork@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= g2ipmsg
+PORTVERSION= 0.6
+CATEGORIES= net gnome
+MASTER_SITES= http://people.FreeBSD.org/~nork/distfiles/ \
+ ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= nork
+DIST_SUBDIR= gnome2
+
+MAINTAINER= nork@FreeBSD.org
+COMMENT= A popup style message communication tool for GNOME2
+
+USE_GETTEXT= yes
+USE_GMAKE= yes
+USE_GNOME= gnomeprefix gnomehack intlhack intltool pkgconfig \
+ libgnomeui libbonobo desktopfileutils
+USE_GSTREAMER= vorbis
+USE_ICONV= yes
+USE_XLIB= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+GCONF_SCHEMAS= g2ipmsg.schemas
+
+post-install:
+ @update-desktop-database
+
+.include <bsd.port.mk>