aboutsummaryrefslogtreecommitdiff
path: root/net/gabber
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-07-19 15:24:04 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-07-19 15:24:04 +0000
commit7cdf63f60200e4b831bc2d01aa6cf23e1b006309 (patch)
tree7f00350113f1f4e106ba348c26e0b07b0e959d41 /net/gabber
parent675043860a9de6f0f4ae4935d903a02a053e65e1 (diff)
downloadports-7cdf63f60200e4b831bc2d01aa6cf23e1b006309.tar.gz
ports-7cdf63f60200e4b831bc2d01aa6cf23e1b006309.zip
Notes
Diffstat (limited to 'net/gabber')
-rw-r--r--net/gabber/Makefile8
-rw-r--r--net/gabber/files/patch-an20
2 files changed, 19 insertions, 9 deletions
diff --git a/net/gabber/Makefile b/net/gabber/Makefile
index 2d994621dafb..09a9340d27c6 100644
--- a/net/gabber/Makefile
+++ b/net/gabber/Makefile
@@ -20,7 +20,8 @@ LIB_DEPENDS= gnomemm.9:${PORTSDIR}/x11-toolkits/gnome--
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GNOME= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomeprefix gnomehack libglade gal
USE_LIBTOOL= yes
LIBTOOLFILES= configure jabberoo/configure
CONFIGURE_ENV+= GNOME_LIBCONFIG_PATH="${LOCALBASE}/lib:${X11BASE}/lib" \
@@ -34,10 +35,7 @@ CONFIGURE_ARGS= --disable-xmms
MAN1= gabber.1
post-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in*" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
.include <bsd.port.mk>
diff --git a/net/gabber/files/patch-an b/net/gabber/files/patch-an
index 6af14251b462..441504b399ae 100644
--- a/net/gabber/files/patch-an
+++ b/net/gabber/files/patch-an
@@ -1,11 +1,23 @@
---- src/TCPTransmitter.cc.orig Sun May 12 16:02:43 2002
-+++ src/TCPTransmitter.cc Sun May 12 16:03:01 2002
+
+$FreeBSD$
+
+--- src/TCPTransmitter.cc.orig Mon Feb 18 00:29:51 2002
++++ src/TCPTransmitter.cc Fri Jul 19 16:43:01 2002
@@ -48,6 +48,8 @@
#include <fcntl.h>
#include <glib.h>
-
+
+#define TRANSMITTER_DEBUG
+
using namespace std;
-
+
#ifdef HAVE_GETHOSTBYNAME_R_GLIB_MUTEX
+@@ -1338,7 +1340,7 @@
+ }
+ }
+
+-void TCPTransmitter::setProxy(const string &ptype, const string &host, guint port, const string &user, const string &password, bool tryOther = true)
++void TCPTransmitter::setProxy(const string &ptype, const string &host, guint port, const string &user, const string &password, bool tryOther)
+ {
+ if (_state != Offline)
+ {