aboutsummaryrefslogtreecommitdiff
path: root/net/gaim
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-03-25 17:38:45 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-03-25 17:38:45 +0000
commit3ee652d35fb0ad663eb2106ae0a71887b5863891 (patch)
tree988c425d15c5fd558f1fd3c3e8f763522dfa6beb /net/gaim
parent23f1bea875c57644aba47c297d1b2428c3439d4a (diff)
downloadports-3ee652d35fb0ad663eb2106ae0a71887b5863891.tar.gz
ports-3ee652d35fb0ad663eb2106ae0a71887b5863891.zip
Notes
Diffstat (limited to 'net/gaim')
-rw-r--r--net/gaim/Makefile2
-rw-r--r--net/gaim/files/patch-src::proxy.c42
2 files changed, 24 insertions, 20 deletions
diff --git a/net/gaim/Makefile b/net/gaim/Makefile
index 573aec85bf67..3c56d2e58a0a 100644
--- a/net/gaim/Makefile
+++ b/net/gaim/Makefile
@@ -6,7 +6,7 @@
PORTNAME= gaim
PORTVERSION= 0.75
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES?= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/net/gaim/files/patch-src::proxy.c b/net/gaim/files/patch-src::proxy.c
index bbf4a19b3124..2a8ede90c94e 100644
--- a/net/gaim/files/patch-src::proxy.c
+++ b/net/gaim/files/patch-src::proxy.c
@@ -1,19 +1,23 @@
-*** src/proxy.c.orig Thu Jan 22 08:27:26 2004
---- src/proxy.c Thu Jan 22 08:28:05 2004
-***************
-*** 974,980 ****
-
- gaim_input_remove(phb->inpa);
-
-! while ((nlc != 2) && (read(source, &inputline[pos++], 1) == 1)) {
- if (inputline[pos - 1] == '\n')
- nlc++;
- else if (inputline[pos - 1] != '\r')
---- 974,980 ----
-
- gaim_input_remove(phb->inpa);
-
-! while ((pos < sizeof(inputline)-1) && (nlc != 2) && (read(source, &inputline[pos++], 1) == 1)) {
- if (inputline[pos - 1] == '\n')
- nlc++;
- else if (inputline[pos - 1] != '\r')
+--- src/proxy.c.orig Fri Jan 9 23:04:56 2004
++++ src/proxy.c Thu Mar 25 12:37:20 2004
+@@ -388,7 +388,11 @@
+ int rc, err;
+ GSList *hosts = NULL;
+ struct sockaddr *addr = NULL;
++#if HAVE_GETADDRINFO
++ size_t addrlen;
++#else
+ socklen_t addrlen;
++#endif
+
+ gaim_debug(GAIM_DEBUG_INFO, "dns", "Host '%s' resolved\n", req->host);
+ gaim_input_remove(req->inpa);
+@@ -974,7 +978,7 @@
+
+ gaim_input_remove(phb->inpa);
+
+- while ((nlc != 2) && (read(source, &inputline[pos++], 1) == 1)) {
++ while ((pos < sizeof(inputline)-1) && (nlc != 2) && (read(source, &inputline[pos++], 1) == 1)) {
+ if (inputline[pos - 1] == '\n')
+ nlc++;
+ else if (inputline[pos - 1] != '\r')