aboutsummaryrefslogtreecommitdiff
path: root/net/gaim
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-02-27 20:21:58 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-02-27 20:21:58 +0000
commit5c2f7eb4df614575906af81f9410fbca99ba3203 (patch)
treef199851115f55f4b4eb628d3034205cefc8b9f76 /net/gaim
parent66f55d03e606f76cb79440ae3b9be75689cd0114 (diff)
downloadports-5c2f7eb4df614575906af81f9410fbca99ba3203.tar.gz
ports-5c2f7eb4df614575906af81f9410fbca99ba3203.zip
Notes
Diffstat (limited to 'net/gaim')
-rw-r--r--net/gaim/Makefile2
-rw-r--r--net/gaim/files/patch-src_plugin.h20
2 files changed, 21 insertions, 1 deletions
diff --git a/net/gaim/Makefile b/net/gaim/Makefile
index 100c251b7e0e..573aec85bf67 100644
--- a/net/gaim/Makefile
+++ b/net/gaim/Makefile
@@ -6,7 +6,7 @@
PORTNAME= gaim
PORTVERSION= 0.75
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES?= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/net/gaim/files/patch-src_plugin.h b/net/gaim/files/patch-src_plugin.h
new file mode 100644
index 000000000000..520ce2ba991f
--- /dev/null
+++ b/net/gaim/files/patch-src_plugin.h
@@ -0,0 +1,20 @@
+--- src/plugin.h.orig Fri Feb 27 15:18:51 2004
++++ src/plugin.h Fri Feb 27 15:19:15 2004
+@@ -117,7 +117,7 @@
+ /**
+ * Handles the initialization of modules.
+ */
+-#if !defined(GAIM_PLUGINS) || defined(STATIC)
++#if !defined(GAIM_PLUGINS) || defined(GAIM_STATIC_PRPL)
+ # define GAIM_INIT_PLUGIN(pluginname, initfunc, plugininfo) \
+ gboolean gaim_init_##pluginname##_plugin(void) { \
+ GaimPlugin *plugin = gaim_plugin_new(TRUE, NULL); \
+@@ -125,7 +125,7 @@
+ initfunc((plugin)); \
+ return gaim_plugin_register(plugin); \
+ }
+-#else /* GAIM_PLUGINS && !STATIC */
++#else /* GAIM_PLUGINS && !GAIM_STATIC_PRPL */
+ # define GAIM_INIT_PLUGIN(pluginname, initfunc, plugininfo) \
+ G_MODULE_EXPORT gboolean gaim_init_plugin(GaimPlugin *plugin) { \
+ plugin->info = &(plugininfo); \