aboutsummaryrefslogtreecommitdiff
path: root/net/gatekeeper
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2008-03-01 07:26:20 +0000
committerRong-En Fan <rafan@FreeBSD.org>2008-03-01 07:26:20 +0000
commita50bdf7656041aa0c6a346e6e2ab2137e6756c0c (patch)
treec7280478a9e0ab11465be9c803de37cb40a54529 /net/gatekeeper
parent59148f4e81638fdc9520227a72436fefefab65fd (diff)
downloadports-a50bdf7656041aa0c6a346e6e2ab2137e6756c0c.tar.gz
ports-a50bdf7656041aa0c6a346e6e2ab2137e6756c0c.zip
Notes
Diffstat (limited to 'net/gatekeeper')
-rw-r--r--net/gatekeeper/Makefile2
-rw-r--r--net/gatekeeper/files/patch-Routing-cxx12
-rw-r--r--net/gatekeeper/files/patch-addpasswd-cxx11
-rw-r--r--net/gatekeeper/files/patch-capctrl-cxx22
-rw-r--r--net/gatekeeper/files/patch-clirw-cxx21
-rw-r--r--net/gatekeeper/files/patch-main-cxx14
6 files changed, 81 insertions, 1 deletions
diff --git a/net/gatekeeper/Makefile b/net/gatekeeper/Makefile
index 04e3a68dfc50..c890f8b1fb52 100644
--- a/net/gatekeeper/Makefile
+++ b/net/gatekeeper/Makefile
@@ -8,7 +8,7 @@
PORTNAME= gatekeeper
#PORTVERSION= 2.2.4
DISTVERSION= 2.2.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= openh323gk
diff --git a/net/gatekeeper/files/patch-Routing-cxx b/net/gatekeeper/files/patch-Routing-cxx
new file mode 100644
index 000000000000..900c61657b21
--- /dev/null
+++ b/net/gatekeeper/files/patch-Routing-cxx
@@ -0,0 +1,12 @@
+diff -ruN gatekeeper.old/work/gnugk-2.2.4/Routing.cxx gatekeeper/work/gnugk-2.2.4/Routing.cxx
+--- Routing.cxx.old 2006-05-24 14:04:42.000000000 -0400
++++ Routing.cxx 2008-01-05 22:25:51.000000000 -0500
+@@ -966,7 +966,7 @@
+ for (PINDEX i = 0; i < kv.GetSize(); i++) {
+ const PString &val = kv.GetDataAt(i);
+
+- m_prefixes[i].m_prefix = kv.GetKeyAt(i);
++ m_prefixes[i].m_prefix = string((const char*)(kv.GetKeyAt(i)));
+
+ const PINDEX sepIndex = val.Find(':');
+ if (sepIndex == P_MAX_INDEX) {
diff --git a/net/gatekeeper/files/patch-addpasswd-cxx b/net/gatekeeper/files/patch-addpasswd-cxx
new file mode 100644
index 000000000000..131f015321a8
--- /dev/null
+++ b/net/gatekeeper/files/patch-addpasswd-cxx
@@ -0,0 +1,11 @@
+diff -ruN addpasswd.cxx.old addpasswd.cxx
+--- addpasswd.cxx.old 2006-04-14 09:56:19.000000000 -0400
++++ addpasswd.cxx 2008-01-05 21:55:43.000000000 -0500
+@@ -16,6 +16,7 @@
+
+ #include <algorithm>
+ #include <ptlib.h>
++#include <ptlib/pprocess.h>
+ #include <ptclib/cypher.h>
+
+ class Client : public PProcess
diff --git a/net/gatekeeper/files/patch-capctrl-cxx b/net/gatekeeper/files/patch-capctrl-cxx
new file mode 100644
index 000000000000..59301779557e
--- /dev/null
+++ b/net/gatekeeper/files/patch-capctrl-cxx
@@ -0,0 +1,22 @@
+--- capctrl.cxx 2006-01-27 07:59:49.000000000 -0500
++++ capctrl.cxx 2006-12-13 10:34:22.000000000 -0500
+@@ -173,8 +173,8 @@
+
+ cliCallVolumes.resize(cliCallVolumes.size() + 1);
+ cliRule = cliCallVolumes.end() - 1;
+- cliRule->first = cli;
+- cliRule->second.m_sourceCLI = cli;
++ cliRule->first = string((const char*)cli);
++ cliRule->second.m_sourceCLI = string((const char*)cli);
+ newCLIRule = true;
+
+ rule = &(cliRule->second);
+@@ -201,7 +201,7 @@
+
+ unsigned tno = 0;
+ if (tokens.GetSize() >= 2)
+- rule->m_prefix = tokens[tno++];
++ rule->m_prefix = string((const char*)(tokens[tno++]));
+ rule->m_maxVolume = tokens[tno++].AsUnsigned();
+
+ if (newIpRule)
diff --git a/net/gatekeeper/files/patch-clirw-cxx b/net/gatekeeper/files/patch-clirw-cxx
new file mode 100644
index 000000000000..83dfb35c8f34
--- /dev/null
+++ b/net/gatekeeper/files/patch-clirw-cxx
@@ -0,0 +1,21 @@
+--- clirw.cxx 2006-02-20 05:03:23.000000000 -0500
++++ clirw.cxx 2006-12-06 11:35:37.000000000 -0500
+@@ -408,7 +408,7 @@
+ if (rule->m_screeningType == RewriteRule::NoScreening) {
+ rule->m_cli.resize(clis.GetSize());
+ for (PINDEX j = 0; j < clis.GetSize(); j++)
+- rule->m_cli[j] = clis[j];
++ rule->m_cli[j] = (string)((const char *)(clis[j]));
+ } else
+ rule->m_cli.clear();
+
+@@ -667,6 +667,9 @@
+ ++rule;
+ }
+
++ if (rule == ipRule.second.end())
++ return;
++
+ bool isTerminal = false;
+ if (authData && authData->m_call) {
+ endptr callee = authData->m_call->GetCalledParty();
diff --git a/net/gatekeeper/files/patch-main-cxx b/net/gatekeeper/files/patch-main-cxx
new file mode 100644
index 000000000000..3361bc8a5c94
--- /dev/null
+++ b/net/gatekeeper/files/patch-main-cxx
@@ -0,0 +1,14 @@
+diff -ruN main.cxx.old main.cxx
+--- main.cxx.old 2004-04-17 07:43:43.000000000 -0400
++++ main.cxx 2008-01-05 21:37:07.000000000 -0500
+@@ -18,6 +18,10 @@
+
+
+ #include <ptlib.h>
++/* the following were expected to be included within ptlib.h
++ but in case they weren't include them explicitly here. */
++#include <ptlib/pprocess.h>
++
+ #include "gk.h"
+
+ PCREATE_PROCESS(Gatekeeper)