aboutsummaryrefslogtreecommitdiff
path: root/net/gatekeeper
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2005-06-30 18:11:28 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2005-06-30 18:11:28 +0000
commit52de4a5dcf252f173e0fa87a1eb202ca965714fd (patch)
treec43167548ff4e192d0495fdabf9ddbc9d30bfcd0 /net/gatekeeper
parent3e8732e462139491ef424667bdceb42ebb67b1fb (diff)
downloadports-52de4a5dcf252f173e0fa87a1eb202ca965714fd.tar.gz
ports-52de4a5dcf252f173e0fa87a1eb202ca965714fd.zip
Notes
Diffstat (limited to 'net/gatekeeper')
-rw-r--r--net/gatekeeper/Makefile2
-rw-r--r--net/gatekeeper/files/patch-Toolkit.cxx31
2 files changed, 32 insertions, 1 deletions
diff --git a/net/gatekeeper/Makefile b/net/gatekeeper/Makefile
index 4359c25f38c8..b2fa412e02ea 100644
--- a/net/gatekeeper/Makefile
+++ b/net/gatekeeper/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gatekeeper
PORTVERSION= 2.2.2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= openh323gk
diff --git a/net/gatekeeper/files/patch-Toolkit.cxx b/net/gatekeeper/files/patch-Toolkit.cxx
new file mode 100644
index 000000000000..bf964603e589
--- /dev/null
+++ b/net/gatekeeper/files/patch-Toolkit.cxx
@@ -0,0 +1,31 @@
+--- Toolkit.cxx.orig Thu Jun 30 12:09:18 2005
++++ Toolkit.cxx Thu Jun 30 12:10:07 2005
+@@ -783,18 +783,19 @@
+ m_Config = new PConfig(m_ConfigFilePath, m_ConfigDefaultSection);
+ }
+
+- if (!m_extConfigFilePath)
++ if (!m_extConfigFilePath) {
+ PFile::Remove(m_extConfigFilePath);
+
+- // generate a unique name
+- do {
+- m_extConfigFilePath = tmpdir + PDIR_SEPARATOR + "gnugk.ini-" + PString(PString::Unsigned, rand()%10000);
+- PTRACE(5, "GK\tTrying file name "<< m_extConfigFilePath << " for external config");
+- } while (PFile::Exists(m_extConfigFilePath));
++ // generate a unique name
++ do {
++ m_extConfigFilePath = tmpdir + PDIR_SEPARATOR + "gnugk.ini-" + PString(PString::Unsigned, rand()%10000);
++ PTRACE(5, "GK\tTrying file name "<< m_extConfigFilePath << " for external config");
++ } while (PFile::Exists(m_extConfigFilePath));
+
+- m_Config = new GatekeeperConfig(
+- m_extConfigFilePath, m_ConfigDefaultSection, m_Config
+- );
++ m_Config = new GatekeeperConfig(
++ m_extConfigFilePath, m_ConfigDefaultSection, m_Config
++ );
++ }
+ }
+
+ void Toolkit::ReloadSQLConfig()