aboutsummaryrefslogtreecommitdiff
path: root/net/gatekeeper
diff options
context:
space:
mode:
authorRoger Hardiman <roger@FreeBSD.org>2001-01-03 13:51:54 +0000
committerRoger Hardiman <roger@FreeBSD.org>2001-01-03 13:51:54 +0000
commit23c803ac540afb41150bd3ee4cc6cdbac1ab7097 (patch)
tree9e213db82e46ff5cc99ee1247a91a0d94ccd2d67 /net/gatekeeper
parent4356313d1c8d76436bcbc4c96be2ab1cfdf1548b (diff)
downloadports-23c803ac540afb41150bd3ee4cc6cdbac1ab7097.tar.gz
ports-23c803ac540afb41150bd3ee4cc6cdbac1ab7097.zip
Notes
Diffstat (limited to 'net/gatekeeper')
-rw-r--r--net/gatekeeper/Makefile8
-rw-r--r--net/gatekeeper/distinfo2
-rw-r--r--net/gatekeeper/files/patch-aa30
3 files changed, 5 insertions, 35 deletions
diff --git a/net/gatekeeper/Makefile b/net/gatekeeper/Makefile
index f37f4f11ba3f..397d6ec10ca8 100644
--- a/net/gatekeeper/Makefile
+++ b/net/gatekeeper/Makefile
@@ -6,17 +6,17 @@
#
PORTNAME= gatekeeper
-PORTVERSION= 0.12
-PORTREVISION= 1
+PORTVERSION= 0.14a
CATEGORIES= net
MASTER_SITES= http://www.willamowius.de/download/
-DISTNAME= gk012
+DISTNAME= gk014a
+EXTRACT_SUFX= .tgz
MAINTAINER= roger@FreeBSD.org
BUILD_DEPENDS= /nonexistent:${PORTSDIR}/net/openh323:build
-WRKSRC= ${WRKDIR}/gk
+WRKSRC= ${WRKDIR}/openh323gk
NOCLEANDEPENDS= yes
diff --git a/net/gatekeeper/distinfo b/net/gatekeeper/distinfo
index d38946266a65..5a9d546c24df 100644
--- a/net/gatekeeper/distinfo
+++ b/net/gatekeeper/distinfo
@@ -1 +1 @@
-MD5 (gk012.tar.gz) = efa4b378efcd9408494851349ecb190f
+MD5 (gk014a.tgz) = 886aa8d6a0b3c2ef7d9e0911ceff4ae1
diff --git a/net/gatekeeper/files/patch-aa b/net/gatekeeper/files/patch-aa
deleted file mode 100644
index 49b97934993f..000000000000
--- a/net/gatekeeper/files/patch-aa
+++ /dev/null
@@ -1,30 +0,0 @@
---- SignalConnection.cxx.orig Sat Aug 19 05:48:21 2000
-+++ SignalConnection.cxx Sat Aug 19 05:52:48 2000
-@@ -292,10 +292,10 @@
- PTRACE(4, "GK\tMessage type : " << (int)m_q931.GetMessageType());
- PTRACE(5, ANSI::BYEL << "Q931: " << m_q931 << ANSI::OFF << endl);
-
-- if(m_q931.HasField(GkQ931::UserUserField)) {
-+ if(m_q931.HasIE(GkQ931::UserUserIE)) {
- H225_H323_UserInformation signal;
-
-- PPER_Stream q = m_q931.GetField(GkQ931::UserUserField);
-+ PPER_Stream q = m_q931.GetIE(GkQ931::UserUserIE);
- if ( ! signal.Decode(q) ) {
- PTRACE(4, "GK\tERROR DECODING Q931.UserInformation!");
- return false;
-@@ -354,11 +354,11 @@
- signal.Encode(sb);
- sb.CompleteEncoding();
-
-- m_q931.SetField(GkQ931::UserUserField, sb);
-+ m_q931.SetIE(GkQ931::UserUserIE, sb);
- }
-
-- if (m_q931.HasField(GkQ931::CalledPartyNumberField)) {
-- PBYTEArray n_array = m_q931.GetField(GkQ931::CalledPartyNumberField);
-+ if (m_q931.HasIE(GkQ931::CalledPartyNumberIE)) {
-+ PBYTEArray n_array = m_q931.GetIE(GkQ931::CalledPartyNumberIE);
- const char* n_bytes = (const char*) (n_array.GetPointer());
- PString n_string(n_bytes+1, n_array.GetSize()-1);
- if(Toolkit::Instance()->RewritePString(n_string))