aboutsummaryrefslogtreecommitdiff
path: root/net/gdrive/Makefile
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2016-12-21 15:40:12 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2016-12-21 15:40:12 +0000
commitdbfc5d0e63d490432845fc4cea88b76f8370aef7 (patch)
tree7f1c34dcf99cfb55f725ca565991bb04782c6195 /net/gdrive/Makefile
parentc87ffc1aa24a8225dfb1da3b3da70d0bcc20189c (diff)
Notes
Diffstat (limited to 'net/gdrive/Makefile')
-rw-r--r--net/gdrive/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/net/gdrive/Makefile b/net/gdrive/Makefile
new file mode 100644
index 000000000000..d2089588f8cb
--- /dev/null
+++ b/net/gdrive/Makefile
@@ -0,0 +1,27 @@
+# Created by: Dmitri Goutnik <dg@syrec.org>
+# $FreeBSD$
+
+PORTNAME= gdrive
+PORTVERSION= 2.1.0
+CATEGORIES= net
+
+MAINTAINER= dg@syrec.org
+COMMENT= Google Drive CLI Client
+
+LICENSE= MIT
+
+USES= go
+GO_PKGNAME= github.com/${GH_ACCOUNT}/${PORTNAME}
+USE_GITHUB= yes
+GH_ACCOUNT= prasmussen
+
+OPTIONS_DEFINE= DOCS
+
+PLIST_FILES= bin/gdrive
+PORTDOCS= README.md
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>