aboutsummaryrefslogtreecommitdiff
path: root/net/geotrace/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-04-19 10:58:10 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-04-19 10:58:10 +0000
commitb5fe9fd0334922208b87a72e042734edc123e268 (patch)
tree523fb9eea75c5567c544092771366d7734990e28 /net/geotrace/Makefile
parentfdd13a819c067d54d0b9c4f763c032a54f8f764f (diff)
Notes
Diffstat (limited to 'net/geotrace/Makefile')
-rw-r--r--net/geotrace/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/net/geotrace/Makefile b/net/geotrace/Makefile
new file mode 100644
index 000000000000..706b6f92e9d1
--- /dev/null
+++ b/net/geotrace/Makefile
@@ -0,0 +1,29 @@
+# ex:ts=8
+# New ports collection makefile for: geotrace
+# Date created: Apr 19, 2001
+# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= geotrace
+PORTVERSION= 0.0.4
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ijliao@FreeBSD.org
+
+LIB_DEPENDS= gdk_pixbuf.2:${PORTSDIR}/graphics/gdk-pixbuf
+
+USE_GTK= yes
+
+post-patch:
+ @${PERL} -pi -e "s,%%PREFIX%%,${PREFIX},g" ${WRKSRC}/prefs.h
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/geotrace ${PREFIX}/bin
+ @${MKDIR} ${PREFIX}/etc/maps
+ ${CP} -R ${WRKSRC}/maps/ ${PREFIX}/etc/maps
+
+.include <bsd.port.mk>