aboutsummaryrefslogtreecommitdiff
path: root/net/gkrellmqst/Makefile
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-07-03 00:10:17 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-07-03 00:10:17 +0000
commit58b5f093779ad350772a4a48969522f6ce4dbacb (patch)
treeb1d09a0fa0b61644b6c227826c57aaaf5406bd82 /net/gkrellmqst/Makefile
parent9ce245f00e4fbed0ee179c1d2feee84051111609 (diff)
downloadports-58b5f093779ad350772a4a48969522f6ce4dbacb.tar.gz
ports-58b5f093779ad350772a4a48969522f6ce4dbacb.zip
Notes
Diffstat (limited to 'net/gkrellmqst/Makefile')
-rw-r--r--net/gkrellmqst/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/net/gkrellmqst/Makefile b/net/gkrellmqst/Makefile
new file mode 100644
index 000000000000..2051e6aed692
--- /dev/null
+++ b/net/gkrellmqst/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: gkrellmqst
+# Date Created: Thu Jun 28 01:54:57 EDT 2001
+# Whom: Patrick Li <pat@databits.net>
+# With help from: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gkrellmqst
+PORTVERSION= 0.3.p5
+CATEGORIES= net games
+MASTER_SITES= http://tadpol.org/unxware/
+DISTNAME= gkrellm_qst-${PORTVERSION:S/.p/pre_/}
+
+MAINTAINER= pat@databits.net
+
+BUILD_DEPENDS= ${X11BASE}/include/gkrellm/gkrellm.h:${PORTSDIR}/sysutils/gkrellm
+RUN_DEPENDS= gkrellm:${PORTSDIR}/sysutils/gkrellm \
+ qstat:${PORTSDIR}/games/qstat
+
+WRKSRC= ${WRKDIR}/${PORTNAME:S/mq/m_q/}
+USE_X_PREFIX= yes
+USE_IMLIB= yes
+MAKE_ENV= PTHREAD_LIBS="${PTHREAD_LIBS}" \
+ PTHREAD_CFLAGS="${PTHREAD_CFLAGS}"
+ALL_TARGET= qst.so
+EXTRA_PATCHES= ${WRKDIR}/patch-qst.c
+
+pre-patch:
+ @${SED} -e "s!%%LOCALBASE%%!${LOCALBASE}!" \
+ -e "s!%%X11BASE%%!${X11BASE}!" \
+ ${FILESDIR}/template-patch-qst.c > \
+ ${WRKDIR}/patch-qst.c
+
+.include <bsd.port.mk>