aboutsummaryrefslogtreecommitdiff
path: root/net/glib-networking
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-03-08 10:51:34 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-03-08 10:51:34 +0000
commit7887c684adab042fed1bfcba2e91589ecd17c4a8 (patch)
tree961839899dce7f75292a08c079f548973bdbd40d /net/glib-networking
parent85544f2c01be814e0af1ebee1076012e7ed60bb0 (diff)
downloadports-7887c684adab042fed1bfcba2e91589ecd17c4a8.tar.gz
ports-7887c684adab042fed1bfcba2e91589ecd17c4a8.zip
Notes
Diffstat (limited to 'net/glib-networking')
-rw-r--r--net/glib-networking/Makefile25
-rw-r--r--net/glib-networking/distinfo4
-rw-r--r--net/glib-networking/files/patch-tls_gnutls_gtlsconnection-gnutls.c11
-rw-r--r--net/glib-networking/pkg-descr8
-rw-r--r--net/glib-networking/pkg-plist22
5 files changed, 46 insertions, 24 deletions
diff --git a/net/glib-networking/Makefile b/net/glib-networking/Makefile
index 1e16d045597a..9b14850a958a 100644
--- a/net/glib-networking/Makefile
+++ b/net/glib-networking/Makefile
@@ -1,14 +1,9 @@
-# New ports collection makefile for: glib-networking
-# Date Created: 06 Jan 2011
-# Whom: Koop Mast <kwm@FreeBSD.org>
-#
+# Created by: Koop Mast <kwm@FreeBSD.org>
# $FreeBSD$
-# $MCom: ports/net/glib-networking/Makefile,v 1.12 2011/08/11 09:10:32 kwm Exp $
-#
+# $MCom: ports/net/glib-networking/Makefile,v 1.20 2012/12/10 11:17:13 kwm Exp $
PORTNAME= glib-networking
-PORTVERSION= 2.28.7
-PORTREVISION= 5
+PORTVERSION= 2.34.2
CATEGORIES= net
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -18,23 +13,21 @@ COMMENT= Network-related giomodules for glib
BUILD_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss \
gsettings-desktop-schemas>=0:${PORTSDIR}/devel/gsettings-desktop-schemas
-LIB_DEPENDS= gnutls.26:${PORTSDIR}/security/gnutls \
- gcrypt.18:${PORTSDIR}/security/libgcrypt \
- dbus-1.3:${PORTSDIR}/devel/dbus \
- proxy.1:${PORTSDIR}/net/libproxy
+LIB_DEPENDS= gnutls:${PORTSDIR}/security/gnutls \
+ gcrypt:${PORTSDIR}/security/libgcrypt \
+ dbus-1:${PORTSDIR}/devel/dbus \
+ proxy:${PORTSDIR}/net/libproxy
RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss \
gsettings-desktop-schemas>=0:${PORTSDIR}/devel/gsettings-desktop-schemas
-USE_BZIP2= yes
+USE_XZ= yes
GNU_CONFIGURE= yes
-USE_GNOME= gnomehack pkgconfig glib20 intltool
+USE_GNOME= gnomehack glib20 intltool
USE_GETTEXT= yes
USE_GMAKE= yes
MAKE_JOBS_SAFE= yes
CONFIGURE_ARGS= --with-ca-certificates=${LOCALBASE}/share/certs/ca-root-nss.crt
CPPFLAGS+= -I${LOCALBASE}/include
-CONFIGURE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
- PTHREAD_LIBS="${PTHREAD_LIBS}"
LDFLAGS+= -L${LOCALBASE}/lib
post-patch:
diff --git a/net/glib-networking/distinfo b/net/glib-networking/distinfo
index 9e274437856a..c1f8b8ccd4e6 100644
--- a/net/glib-networking/distinfo
+++ b/net/glib-networking/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gnome2/glib-networking-2.28.7.tar.bz2) = 98bedfbd530c4b1b53c91025fe82290bafd289d249e4eb549c3b90d23a76021c
-SIZE (gnome2/glib-networking-2.28.7.tar.bz2) = 319260
+SHA256 (gnome2/glib-networking-2.34.2.tar.xz) = 00a92ec7b31f03a2fc1eeff568c0f1664e109b3add8c7042d2d420953f49dfde
+SIZE (gnome2/glib-networking-2.34.2.tar.xz) = 346828
diff --git a/net/glib-networking/files/patch-tls_gnutls_gtlsconnection-gnutls.c b/net/glib-networking/files/patch-tls_gnutls_gtlsconnection-gnutls.c
new file mode 100644
index 000000000000..728e24401f33
--- /dev/null
+++ b/net/glib-networking/files/patch-tls_gnutls_gtlsconnection-gnutls.c
@@ -0,0 +1,11 @@
+--- tls/gnutls/gtlsconnection-gnutls.c.orig 2012-12-09 01:05:02.000000000 +0000
++++ tls/gnutls/gtlsconnection-gnutls.c 2012-12-09 01:14:46.000000000 +0000
+@@ -752,7 +752,7 @@
+ if (error)
+ {
+ g_set_error (error, G_TLS_ERROR, G_TLS_ERROR_MISC,
+- errmsg, gnutls_strerror (status));
++ "%s, %s", errmsg, gnutls_strerror (status));
+ }
+ return status;
+ }
diff --git a/net/glib-networking/pkg-descr b/net/glib-networking/pkg-descr
index aa77e641a5ce..550492c7bcdb 100644
--- a/net/glib-networking/pkg-descr
+++ b/net/glib-networking/pkg-descr
@@ -1,10 +1,10 @@
Network-related giomodules for glib.
-Glib-networking contains the implementations of certain GLib networking
+Glib-networking contains the implementations of certain GLib networking
features that cannot be implemented directly in GLib itself because of their
dependencies.
-Currently it contains a GNUTLS-based implementation of GTlsBackend,
-a libproxy-based implementation of GProxyResolver, and a GNOME GProxyResolver
-that uses the proxy information from the GSettings schemas in
+Currently it contains a GNUTLS-based implementation of GTlsBackend,
+a libproxy-based implementation of GProxyResolver, and a GNOME GProxyResolver
+that uses the proxy information from the GSettings schemas in
gsettings-desktop-schemas.
diff --git a/net/glib-networking/pkg-plist b/net/glib-networking/pkg-plist
index 568a160a6e8f..37fc07295423 100644
--- a/net/glib-networking/pkg-plist
+++ b/net/glib-networking/pkg-plist
@@ -9,10 +9,13 @@ lib/gio/modules/libgiolibproxy.la
lib/gio/modules/libgiolibproxy.so
libexec/glib-pacrunner
share/dbus-1/services/org.gtk.GLib.PACRunner.service
+share/locale/ar/LC_MESSAGES/glib-networking.mo
share/locale/as/LC_MESSAGES/glib-networking.mo
+share/locale/be/LC_MESSAGES/glib-networking.mo
share/locale/bg/LC_MESSAGES/glib-networking.mo
share/locale/bn_IN/LC_MESSAGES/glib-networking.mo
share/locale/ca/LC_MESSAGES/glib-networking.mo
+share/locale/ca@valencia/LC_MESSAGES/glib-networking.mo
share/locale/cs/LC_MESSAGES/glib-networking.mo
share/locale/da/LC_MESSAGES/glib-networking.mo
share/locale/de/LC_MESSAGES/glib-networking.mo
@@ -23,6 +26,8 @@ share/locale/eo/LC_MESSAGES/glib-networking.mo
share/locale/es/LC_MESSAGES/glib-networking.mo
share/locale/et/LC_MESSAGES/glib-networking.mo
share/locale/eu/LC_MESSAGES/glib-networking.mo
+share/locale/fa/LC_MESSAGES/glib-networking.mo
+share/locale/fi/LC_MESSAGES/glib-networking.mo
share/locale/fr/LC_MESSAGES/glib-networking.mo
share/locale/gl/LC_MESSAGES/glib-networking.mo
share/locale/gu/LC_MESSAGES/glib-networking.mo
@@ -32,9 +37,12 @@ share/locale/hu/LC_MESSAGES/glib-networking.mo
share/locale/id/LC_MESSAGES/glib-networking.mo
share/locale/it/LC_MESSAGES/glib-networking.mo
share/locale/ja/LC_MESSAGES/glib-networking.mo
+share/locale/km/LC_MESSAGES/glib-networking.mo
share/locale/kn/LC_MESSAGES/glib-networking.mo
share/locale/ko/LC_MESSAGES/glib-networking.mo
+share/locale/lt/LC_MESSAGES/glib-networking.mo
share/locale/lv/LC_MESSAGES/glib-networking.mo
+share/locale/ml/LC_MESSAGES/glib-networking.mo
share/locale/mr/LC_MESSAGES/glib-networking.mo
share/locale/nb/LC_MESSAGES/glib-networking.mo
share/locale/nl/LC_MESSAGES/glib-networking.mo
@@ -45,10 +53,14 @@ share/locale/pt/LC_MESSAGES/glib-networking.mo
share/locale/pt_BR/LC_MESSAGES/glib-networking.mo
share/locale/ro/LC_MESSAGES/glib-networking.mo
share/locale/ru/LC_MESSAGES/glib-networking.mo
+share/locale/sk/LC_MESSAGES/glib-networking.mo
share/locale/sl/LC_MESSAGES/glib-networking.mo
share/locale/sr/LC_MESSAGES/glib-networking.mo
share/locale/sr@latin/LC_MESSAGES/glib-networking.mo
share/locale/sv/LC_MESSAGES/glib-networking.mo
+share/locale/ta/LC_MESSAGES/glib-networking.mo
+share/locale/te/LC_MESSAGES/glib-networking.mo
+share/locale/th/LC_MESSAGES/glib-networking.mo
share/locale/tr/LC_MESSAGES/glib-networking.mo
share/locale/ug/LC_MESSAGES/glib-networking.mo
share/locale/uk/LC_MESSAGES/glib-networking.mo
@@ -56,17 +68,23 @@ share/locale/vi/LC_MESSAGES/glib-networking.mo
share/locale/zh_CN/LC_MESSAGES/glib-networking.mo
share/locale/zh_HK/LC_MESSAGES/glib-networking.mo
share/locale/zh_TW/LC_MESSAGES/glib-networking.mo
-@exec %D/bin/gio-querymodules %D/lib/gio/modules 2>/dev/null || /usr/bin/true
-@unexec %D/bin/gio-querymodules %D/lib/gio/modules 2>/dev/null || /usr/bin/true
@dirrmtry share/locale/zh_HK/LC_MESSAGES
@dirrmtry share/locale/zh_HK
@dirrmtry share/locale/ug/LC_MESSAGES
@dirrmtry share/locale/ug
+@dirrmtry share/locale/te/LC_MESSAGES
+@dirrmtry share/locale/te
@dirrmtry share/locale/sr@latin/LC_MESSAGES
@dirrmtry share/locale/sr@latin
@dirrmtry share/locale/mr/LC_MESSAGES
@dirrmtry share/locale/mr
+@dirrmtry share/locale/km/LC_MESSAGES
+@dirrmtry share/locale/km
+@dirrmtry share/locale/ca@valencia/LC_MESSAGES
+@dirrmtry share/locale/ca@valencia
@dirrmtry share/locale/bn_IN/LC_MESSAGES
@dirrmtry share/locale/bn_IN
@dirrmtry share/locale/as/LC_MESSAGES
@dirrmtry share/locale/as
+@exec %D/bin/gio-querymodules %D/lib/gio/modules 2>/dev/null || /usr/bin/true
+@unexec %D/bin/gio-querymodules %D/lib/gio/modules 2>/dev/null || /usr/bin/true