aboutsummaryrefslogtreecommitdiff
path: root/net/gnet2/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-02-23 17:34:03 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-02-23 17:34:03 +0000
commit5f6b9c279aeef3071790ef36bc004023e7f19c47 (patch)
tree622be56a04abbba9ab6fb9cfbcde68c20135d2eb /net/gnet2/Makefile
parent336624212209b9700954136993f315d0afa28a2e (diff)
downloadports-5f6b9c279aeef3071790ef36bc004023e7f19c47.tar.gz
ports-5f6b9c279aeef3071790ef36bc004023e7f19c47.zip
Notes
Diffstat (limited to 'net/gnet2/Makefile')
-rw-r--r--net/gnet2/Makefile43
1 files changed, 32 insertions, 11 deletions
diff --git a/net/gnet2/Makefile b/net/gnet2/Makefile
index ad79ea436ec5..2024201195d6 100644
--- a/net/gnet2/Makefile
+++ b/net/gnet2/Makefile
@@ -1,24 +1,29 @@
-# New ports collection makefile for: gnet
-# Date created: 16 February 2000
-# Whom: Yukihiro Nakai <nakai@FreeBSD.org>
+# New ports collection makefile for: gnet-glib2
+# Date created: 15 February 2003
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= gnet
-PORTVERSION= 1.1.4
+PORTVERSION= 1.1.8
CATEGORIES= net
MASTER_SITES= http://www.gnetlibrary.org/src/
-MAINTAINER= nakai@FreeBSD.org
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= A simple network library built upon Glib
+LIB_DEPENDS= glib-2.0.200:${PORTSDIR}/devel/glib20
+
+LATEST_LINK= gnet-glib2
USE_REINPLACE= yes
USE_GNOMENG= yes
-USE_GNOME= gnomehack glib12
+USE_GNOME= gnomehack
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
+CONFIGURE_ARGS= --enable-glib2
-MAN1= gnet-config.1
+MAN1= gnet-glib2-config.1
post-patch:
# fix pthreads detection
@@ -30,14 +35,30 @@ post-patch:
# don't install gnet-config script with odd name. We will install it ourselves
@${REINPLACE_CMD} -E -e 's|^(install-exec-am:).+$$|\1|' \
${WRKSRC}/Makefile.in
-# install gnet-config.1 man (not another name). Revise at EVERY port update
- @${REINPLACE_CMD} -e 's|\$$\$$inst|\$$\$$file|g' \
+# don't install any of the config files. We will do it ourselves.
+ @${REINPLACE_CMD} -E -e 's|^(install-data-am:).+$$|\1|' \
+ ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -E -e 's|^[[:space:]]+install-pkgconfigDATA$$||' \
+ ${WRKSRC}/Makefile.in
+# don't install the manpage. We will do it ourselves.
+ @${REINPLACE_CMD} -E -e 's|^(install-data-am:).+$$|\1 install-data-local|' \
${WRKSRC}/doc/Makefile.in
# install configincludedir correctly
- @${REINPLACE_CMD} -E -e 's|^(configincludedir).+$$|\1=\$$\(pkgincludedir\)|' \
+ @${REINPLACE_CMD} -E -e 's|^(configincludedir).+$$|\1=\$$\(pkgincludedir\)-glib2|' \
${WRKSRC}/Makefile.in
post-install:
- @${INSTALL_SCRIPT} ${WRKSRC}/gnet-config ${PREFIX}/bin
+ @${MKDIR} -p ${PREFIX}/bin
+ @${INSTALL_SCRIPT} ${WRKSRC}/gnet-config ${PREFIX}/bin/gnet-glib2-config
+ @${MKDIR} -p ${PREFIX}/share/aclocal
+ @${INSTALL_DATA} ${WRKSRC}/gnet.m4 ${PREFIX}/share/aclocal/gnet-glib2.m4
+ @${INSTALL_DATA} ${WRKSRC}/gnetconfig.h \
+ ${PREFIX}/include/gnet-glib2
+ @${MKDIR} -p ${PREFIX}/libdata/pkgconfig
+ @${INSTALL_DATA} ${WRKSRC}/gnet.pc \
+ ${PREFIX}/libdata/pkgconfig/gnet-glib2.pc
+ @${MKDIR} -p ${PREFIX}/man/man1
+ @${INSTALL_DATA} ${WRKSRC}/doc/gnet-config.1 \
+ ${PREFIX}/man/man1/gnet-glib2-config.1
.include <bsd.port.mk>