aboutsummaryrefslogtreecommitdiff
path: root/net/gnet2/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-07-12 05:30:42 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-07-12 05:30:42 +0000
commit4a17c6bd5aacdd0e069d51a4a254b7a288fd1b1a (patch)
tree86fb60fd1cc7d7d33c38d863412ea497bdb38440 /net/gnet2/Makefile
parent24efcd3354d3f8acf8b216214738673038070078 (diff)
Add gnet2 after a repo copy from gnet-glib2. gnet2 is the stable Glib-2
based version of the simple network library, GNet.
Notes
Notes: svn path=/head/; revision=84732
Diffstat (limited to 'net/gnet2/Makefile')
-rw-r--r--net/gnet2/Makefile42
1 files changed, 3 insertions, 39 deletions
diff --git a/net/gnet2/Makefile b/net/gnet2/Makefile
index 27d281518fc4..cec5e7435ebf 100644
--- a/net/gnet2/Makefile
+++ b/net/gnet2/Makefile
@@ -1,4 +1,4 @@
-# New ports collection makefile for: gnet-glib2
+# New ports collection makefile for: gnet2
# Date created: 15 February 2003
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
@@ -6,10 +6,10 @@
#
PORTNAME= gnet
-PORTVERSION= 1.1.9
+PORTVERSION= 2.0.3
CATEGORIES= net
MASTER_SITES= http://www.gnetlibrary.org/src/
-PKGNAMESUFFIX= -glib2
+PKGNAMESUFFIX= 2
MAINTAINER= gnome@FreeBSD.org
COMMENT= A simple network library built upon Glib-2
@@ -18,41 +18,5 @@ USE_REINPLACE= yes
USE_GNOME= gnomehack glib20
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
-CONFIGURE_ARGS= --enable-glib2
-
-MAN1= gnet-glib2-config.1
-
-post-patch:
-# remove "release" information from lib name
- @${REINPLACE_CMD} -E -e 's|-release[ ]+\$$\(LT_RELEASE\)||g' \
- ${WRKSRC}/src/Makefile.in
-# don't install gnet-config script with odd name. We will install it ourselves
- @${REINPLACE_CMD} -E -e 's|^(install-exec-am:).+$$|\1|' \
- ${WRKSRC}/Makefile.in
-# don't install any of the config files. We will do it ourselves.
- @${REINPLACE_CMD} -E -e 's|^(install-data-am:).+$$|\1|' \
- ${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} -E -e 's|^[[:space:]]+install-pkgconfigDATA$$||' \
- ${WRKSRC}/Makefile.in
-# don't install the manpage. We will do it ourselves.
- @${REINPLACE_CMD} -E -e 's|^(install-data-am:).+$$|\1 install-data-local|' \
- ${WRKSRC}/doc/Makefile.in
-# install configincludedir correctly
- @${REINPLACE_CMD} -E -e 's|^(configincludedir).+$$|\1=\$$\(pkgincludedir\)-glib2|' \
- ${WRKSRC}/Makefile.in
-
-post-install:
- @${MKDIR} ${PREFIX}/bin
- @${INSTALL_SCRIPT} ${WRKSRC}/gnet-config ${PREFIX}/bin/gnet-glib2-config
- @${MKDIR} ${PREFIX}/share/aclocal
- @${INSTALL_DATA} ${WRKSRC}/gnet.m4 ${PREFIX}/share/aclocal/gnet-glib2.m4
- @${INSTALL_DATA} ${WRKSRC}/gnetconfig.h \
- ${PREFIX}/include/gnet-glib2
- @${MKDIR} ${PREFIX}/libdata/pkgconfig
- @${INSTALL_DATA} ${WRKSRC}/gnet.pc \
- ${PREFIX}/libdata/pkgconfig/gnet-glib2.pc
- @${MKDIR} ${PREFIX}/man/man1
- @${INSTALL_DATA} ${WRKSRC}/doc/gnet-config.1 \
- ${PREFIX}/man/man1/gnet-glib2-config.1
.include <bsd.port.mk>