aboutsummaryrefslogtreecommitdiff
path: root/net/gnetcat
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-01-12 22:00:06 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-01-12 22:00:06 +0000
commit321e5c8279c8e920834baf4707e96f58923eafd9 (patch)
tree1163a0af61287d474aa5bab655bcbdbc321ff5d7 /net/gnetcat
parent40736142ce7ad3bd32a05a2f92dccacd2d25d2e6 (diff)
downloadports-321e5c8279c8e920834baf4707e96f58923eafd9.tar.gz
ports-321e5c8279c8e920834baf4707e96f58923eafd9.zip
Add gnetcat, a GPL'ed reimplementation of netcat.
PR: ports/61262 Submitted by: Liam Foy <liamfoy@sepulcrum.org>
Notes
Notes: svn path=/head/; revision=98023
Diffstat (limited to 'net/gnetcat')
-rw-r--r--net/gnetcat/Makefile29
-rw-r--r--net/gnetcat/distinfo1
-rw-r--r--net/gnetcat/files/patch-src-udphelper.c17
-rw-r--r--net/gnetcat/pkg-descr11
-rw-r--r--net/gnetcat/pkg-plist2
5 files changed, 60 insertions, 0 deletions
diff --git a/net/gnetcat/Makefile b/net/gnetcat/Makefile
new file mode 100644
index 000000000000..bf0fd56a4581
--- /dev/null
+++ b/net/gnetcat/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: gnetcat
+# Date created: 10 January 2004
+# Whom: liamfoy@sepulcrum.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnetcat
+PORTVERSION= 0.7.1
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= netcat
+DISTNAME= netcat-0.7.1
+
+MAINTAINER= liamfoy@sepulcrum.org
+COMMENT= GPL'ed re-write of the well known networking tool netcat
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+
+MAN1= gnetcat.1
+MANCOMPRESSED= no
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/netcat ${PREFIX}/bin/gnetcat
+ ${INSTALL_MAN} ${WRKSRC}/doc/netcat.1 ${PREFIX}/man/man1/gnetcat.1
+ ${INSTALL_DATA} ${WRKSRC}/doc/netcat.info ${PREFIX}/info/gnetcat.info
+
+.include <bsd.port.mk>
diff --git a/net/gnetcat/distinfo b/net/gnetcat/distinfo
new file mode 100644
index 000000000000..49d3b19aca6a
--- /dev/null
+++ b/net/gnetcat/distinfo
@@ -0,0 +1 @@
+MD5 (netcat-0.7.1.tar.bz2) = 0a29eff1736ddb5effd0b1ec1f6fe0ef
diff --git a/net/gnetcat/files/patch-src-udphelper.c b/net/gnetcat/files/patch-src-udphelper.c
new file mode 100644
index 000000000000..5adbf9d0cb37
--- /dev/null
+++ b/net/gnetcat/files/patch-src-udphelper.c
@@ -0,0 +1,17 @@
+--- src/udphelper.c.orig Mon Jan 12 19:18:26 2004
++++ src/udphelper.c Mon Jan 12 19:19:22 2004
+@@ -45,10 +45,10 @@
+ #endif
+
+ #if !defined(SIOCGLIFADDR) || !defined(SIOCGLIFFLAGS)
+-/* FIXME The following warning occurs on FreeBSD:
+- udphelper.c:48: warning: `SIOCGLIFADDR' redefined
+- /usr/include/sys/sockio.h:78: warning: this is the location of the previous definition
+- */
++/* Temp fix - suggested by author */
++#if defined(SIOCGLIFADDR)
++#undef SIOCGLIFADDR
++#endif
+ # define SIOCGLIFADDR SIOCGIFADDR
+ # define SIOCGLIFFLAGS SIOCGIFFLAGS
+ # define SIOCGLIFDSTADDR SIOCGIFDSTADDR
diff --git a/net/gnetcat/pkg-descr b/net/gnetcat/pkg-descr
new file mode 100644
index 000000000000..cfe00601e9a8
--- /dev/null
+++ b/net/gnetcat/pkg-descr
@@ -0,0 +1,11 @@
+Netcat is a featured networking utility which reads and writes data across
+network connections, using the TCP/IP protocol. It is designed to be a reliable
+"back-end" tool that can be used directly or easily driven by other programs and
+scripts. At the same time, it is a feature-rich network debugging and
+exploration tool, since it can create almost any kind of connection you
+would need and has several interesting built-in capabilities.
+
+WWW: http://netcat.sourceforge.net
+
+-Liam Foy
+liamfoy@sepulcrum.org
diff --git a/net/gnetcat/pkg-plist b/net/gnetcat/pkg-plist
new file mode 100644
index 000000000000..71e6df54798a
--- /dev/null
+++ b/net/gnetcat/pkg-plist
@@ -0,0 +1,2 @@
+bin/gnetcat
+info/gnetcat.info