aboutsummaryrefslogtreecommitdiff
path: root/net/gnome-netstatus
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2005-03-12 10:39:38 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2005-03-12 10:39:38 +0000
commit190418a078b1eb7ea3c5d38a08bdab3cbd422086 (patch)
treebb336ccecde7052d26d3d8d8c97238744a373aad /net/gnome-netstatus
parent6b0c40606cac591d75b88d05c7276bd16c369035 (diff)
downloadports-190418a078b1eb7ea3c5d38a08bdab3cbd422086.tar.gz
ports-190418a078b1eb7ea3c5d38a08bdab3cbd422086.zip
Notes
Diffstat (limited to 'net/gnome-netstatus')
-rw-r--r--net/gnome-netstatus/Makefile5
-rw-r--r--net/gnome-netstatus/distinfo4
-rw-r--r--net/gnome-netstatus/files/patch-src_netstatus-iface.c11
-rw-r--r--net/gnome-netstatus/files/patch-src_netstatus-sysdeps.c147
-rw-r--r--net/gnome-netstatus/pkg-plist2
5 files changed, 107 insertions, 62 deletions
diff --git a/net/gnome-netstatus/Makefile b/net/gnome-netstatus/Makefile
index ee735aa98d5d..169dbc31877d 100644
--- a/net/gnome-netstatus/Makefile
+++ b/net/gnome-netstatus/Makefile
@@ -6,11 +6,10 @@
#
PORTNAME= gnomenetstatus
-PORTVERSION= 2.8.0
-PORTREVISION= 2
+PORTVERSION= 2.10.0
CATEGORIES= net gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/gnome-netstatus/2.8
+MASTER_SITE_SUBDIR= sources/gnome-netstatus/2.10
DISTNAME= gnome-netstatus-${PORTVERSION}
DIST_SUBDIR= gnome2
diff --git a/net/gnome-netstatus/distinfo b/net/gnome-netstatus/distinfo
index 1ad8a9f94236..48e9fbf2c961 100644
--- a/net/gnome-netstatus/distinfo
+++ b/net/gnome-netstatus/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/gnome-netstatus-2.8.0.tar.bz2) = fadc8a26ff7142e1372740d2edc435b1
-SIZE (gnome2/gnome-netstatus-2.8.0.tar.bz2) = 492599
+MD5 (gnome2/gnome-netstatus-2.10.0.tar.bz2) = b1a044cfbe3299e00d514d966d4766e8
+SIZE (gnome2/gnome-netstatus-2.10.0.tar.bz2) = 510277
diff --git a/net/gnome-netstatus/files/patch-src_netstatus-iface.c b/net/gnome-netstatus/files/patch-src_netstatus-iface.c
index 1ffae4384ecb..64c9ad52f8c9 100644
--- a/net/gnome-netstatus/files/patch-src_netstatus-iface.c
+++ b/net/gnome-netstatus/files/patch-src_netstatus-iface.c
@@ -1,16 +1,15 @@
---- src/netstatus-iface.c.orig Mon Mar 22 17:49:17 2004
-+++ src/netstatus-iface.c Mon Mar 22 17:50:12 2004
-@@ -32,6 +32,8 @@
+--- src/netstatus-iface.c.orig Tue Nov 30 18:35:23 2004
++++ src/netstatus-iface.c Tue Nov 30 18:35:43 2004
+@@ -33,6 +33,7 @@
#include <libgnome/gnome-i18n.h>
+#include <sys/types.h>
-+#include <sys/socket.h>
#include <sys/ioctl.h>
#ifdef HAVE_SYS_SOCKIO_H
#include <sys/sockio.h>
-@@ -39,6 +41,7 @@
- #include <sys/param.h>
+@@ -41,6 +42,7 @@
+ #include <sys/socket.h>
#include <net/if.h>
#include <net/if_arp.h>
+#include <netinet/in.h>
diff --git a/net/gnome-netstatus/files/patch-src_netstatus-sysdeps.c b/net/gnome-netstatus/files/patch-src_netstatus-sysdeps.c
index a13a23161769..03e1d89c1d96 100644
--- a/net/gnome-netstatus/files/patch-src_netstatus-sysdeps.c
+++ b/net/gnome-netstatus/files/patch-src_netstatus-sysdeps.c
@@ -1,5 +1,5 @@
---- src/netstatus-sysdeps.c.orig Fri Jul 30 04:19:31 2004
-+++ src/netstatus-sysdeps.c Tue Sep 21 00:27:19 2004
+--- src/netstatus-sysdeps.c.orig Fri Jul 30 04:21:30 2004
++++ src/netstatus-sysdeps.c Thu Mar 3 03:04:41 2005
@@ -35,6 +35,16 @@
#include <glib.h>
#include <libgnome/gnome-i18n.h>
@@ -17,7 +17,7 @@
static inline gboolean
parse_stats (char *buf,
int prx_idx,
-@@ -384,6 +394,163 @@
+@@ -384,6 +394,173 @@
}
}
@@ -37,16 +37,18 @@
+
+ s = socket (AF_INET, SOCK_DGRAM, 0);
+
-+ if (s == -1) {
-+ *error = g_strdup_printf (_("Could not connect to interface, '%s'"), iface);
-+ return FALSE;
-+ }
++ if (s == -1)
++ {
++ *error = g_strdup_printf (_("Could not connect to interface, '%s'"), iface);
++ return FALSE;
++ }
+
-+ if (ioctl (s, req_type, &ifr) == -1) {
-+ *error = g_strdup_printf (_("Could not send ioctl to interface, '%s'"), iface);
-+ close (s);
-+ return FALSE;
-+ }
++ if (ioctl (s, req_type, &ifr) == -1)
++ {
++ *error = g_strdup_printf (_("Could not send ioctl to interface, '%s'"), iface);
++ close (s);
++ return FALSE;
++ }
+
+ close (s);
+ return TRUE;
@@ -110,35 +112,39 @@
+ level = (int) (wreq.wi_val[1]);
+
+#ifdef WI_RID_READ_APS
-+ if (signal_strength <= 0) {
-+ /* we fail to get signal strength by usual means, try another way */
-+ static time_t last_scan;
-+ static long int cached;
-+ time_t now = time (NULL);
-+
-+ /* XXX: this is long operation, and we will scan station not often then one in 5 secs */
-+ if (now > last_scan + 5) {
-+ struct wi_apinfo *w;
-+ int nstations;
-+
-+ bzero ((char *)&wreq, sizeof(wreq));
-+ wreq.wi_len = WI_MAX_DATALEN;
-+ wreq.wi_type = WI_RID_READ_APS;
-+
-+ if (!wireless_getval (iface, (gpointer) &wreq, SIOCGWAVELAN, &error))
-+ return error;
-+ nstations = *(int *)wreq.wi_val;
-+ if (nstations > 0) {
-+ w = (struct wi_apinfo *)(((char *)&wreq.wi_val) + sizeof(int));
-+ signal_strength = (long int)w->signal;
-+ }
-+
-+ cached = signal_strength;
-+ last_scan = now;
-+ } else {
-+ signal_strength = cached;
-+ }
-+ }
++ if (signal_strength <= 0)
++ {
++ /* we fail to get signal strength by usual means, try another way */
++ static time_t last_scan;
++ static long int cached;
++ time_t now = time (NULL);
++
++ /* XXX: this is long operation, and we will scan station not often then one in 5 secs */
++ if (now > last_scan + 5)
++ {
++ struct wi_apinfo *w;
++ int nstations;
++
++ bzero ((char *)&wreq, sizeof(wreq));
++ wreq.wi_len = WI_MAX_DATALEN;
++ wreq.wi_type = WI_RID_READ_APS;
++ if (!wireless_getval (iface, (gpointer) &wreq, SIOCGWAVELAN, &error))
++ return error;
++ nstations = *(int *)wreq.wi_val;
++ if (nstations > 0)
++ {
++ w = (struct wi_apinfo *)(((char *)&wreq.wi_val) + sizeof(int));
++ signal_strength = (long int)w->signal;
++ }
++
++ cached = signal_strength;
++ last_scan = now;
++ }
++ else
++ {
++ signal_strength = cached;
++ }
++ }
+#endif
+
+ memcpy (signal_strength, &level, sizeof (signal_strength));
@@ -163,17 +169,21 @@
+ *signal_strength = 0;
+
+ if (g_strncasecmp (iface, "an", 2) && g_strncasecmp (iface, "wi", 2) &&
-+ g_strncasecmp (iface, "ath", 3) && g_strncasecmp (iface, "ndis", 4))
++ g_strncasecmp (iface, "ath", 3) && g_strncasecmp (iface, "ndis", 4) &&
++ g_strncasecmp (iface, "ipw", 3) && g_strncasecmp (iface, "iwi", 3) &&
++ g_strncasecmp (iface, "acx", 3))
+ return error_message;
+
-+ if (g_strncasecmp (iface, "an", 2) == 0) {
-+ error_message = get_an_data (iface, signal_strength);
-+ *is_wireless = TRUE;
-+ }
-+ else {
-+ error_message = get_wi_data (iface, signal_strength);
-+ *is_wireless = TRUE;
-+ }
++ if (g_strncasecmp (iface, "an", 2) == 0)
++ {
++ error_message = get_an_data (iface, signal_strength);
++ *is_wireless = TRUE;
++ }
++ else
++ {
++ error_message = get_wi_data (iface, signal_strength);
++ *is_wireless = TRUE;
++ }
+
+ return error_message;
+}
@@ -181,7 +191,42 @@
char *
netstatus_sysdeps_read_iface_statistics (const char *iface,
gulong *in_packets,
-@@ -485,23 +652,6 @@
+@@ -413,11 +590,11 @@
+ if (!g_shell_parse_argv (command_line, NULL, &argv, &error))
+ {
+ error_message = g_strdup_printf (_("Could not parse command line '%s': %s"),
+- command_line,
+- error->message);
++ command_line,
++ error->message);
+ g_error_free (error);
+ g_free (command_line);
+-
++
+ return error_message;
+ }
+ g_free (command_line);
+@@ -456,8 +633,8 @@
+ g_io_channel_read_line (channel, &buf, NULL, NULL, NULL);
+
+ if (!parse_stats (buf,
+- prx_idx, ptx_idx, in_packets, out_packets,
+- brx_idx, btx_idx, in_bytes, out_bytes))
++ prx_idx, ptx_idx, in_packets, out_packets,
++ brx_idx, btx_idx, in_bytes, out_bytes))
+ {
+ error_message = g_strdup_printf (_("Could not parse interface statistics from '%s'. "
+ "prx_idx = %d; ptx_idx = %d; brx_idx = %d; btx_idx = %d;"),
+@@ -477,7 +654,7 @@
+ }
+ else
+ {
+- error_message = g_strdup_printf ("Error running /usr/bin/netstat for '%s': %s",
++ error_message = g_strdup_printf ("Error running /usr/bin/netstat for '%s': %s",
+ iface, error->message);
+ g_error_free (error);
+ }
+@@ -485,23 +662,6 @@
g_strfreev (argv);
return error_message;
diff --git a/net/gnome-netstatus/pkg-plist b/net/gnome-netstatus/pkg-plist
index b4258eef7f23..bf881c64c294 100644
--- a/net/gnome-netstatus/pkg-plist
+++ b/net/gnome-netstatus/pkg-plist
@@ -130,6 +130,7 @@ share/locale/eu/LC_MESSAGES/gnome-netstatus.mo
share/locale/fi/LC_MESSAGES/gnome-netstatus.mo
share/locale/fr/LC_MESSAGES/gnome-netstatus.mo
share/locale/ga/LC_MESSAGES/gnome-netstatus.mo
+share/locale/gl/LC_MESSAGES/gnome-netstatus.mo
share/locale/gu/LC_MESSAGES/gnome-netstatus.mo
share/locale/hi/LC_MESSAGES/gnome-netstatus.mo
share/locale/hr/LC_MESSAGES/gnome-netstatus.mo
@@ -142,6 +143,7 @@ share/locale/lt/LC_MESSAGES/gnome-netstatus.mo
share/locale/mn/LC_MESSAGES/gnome-netstatus.mo
share/locale/ms/LC_MESSAGES/gnome-netstatus.mo
share/locale/nb/LC_MESSAGES/gnome-netstatus.mo
+share/locale/ne/LC_MESSAGES/gnome-netstatus.mo
share/locale/nl/LC_MESSAGES/gnome-netstatus.mo
share/locale/nn/LC_MESSAGES/gnome-netstatus.mo
share/locale/no/LC_MESSAGES/gnome-netstatus.mo