aboutsummaryrefslogtreecommitdiff
path: root/net/gnome-nettool
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-12-28 02:42:23 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-12-28 02:42:23 +0000
commit2bb1a3a5ea92c70b572f35d9b99c8580272e4be8 (patch)
tree7c3cbddcbe2aacd0337944de874eac6bca556f7d /net/gnome-nettool
parentbe0b06963978769558bed7f9f9ca300bbd089f4f (diff)
Notes
Diffstat (limited to 'net/gnome-nettool')
-rw-r--r--net/gnome-nettool/Makefile1
-rw-r--r--net/gnome-nettool/files/patch-src_nettool.c33
2 files changed, 32 insertions, 2 deletions
diff --git a/net/gnome-nettool/Makefile b/net/gnome-nettool/Makefile
index 9d7922446abc..fd1c3489b785 100644
--- a/net/gnome-nettool/Makefile
+++ b/net/gnome-nettool/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gnomenettool
PORTVERSION= 1.0.0
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= net gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
diff --git a/net/gnome-nettool/files/patch-src_nettool.c b/net/gnome-nettool/files/patch-src_nettool.c
index 3319e36a70ae..51f11e3f1e96 100644
--- a/net/gnome-nettool/files/patch-src_nettool.c
+++ b/net/gnome-nettool/files/patch-src_nettool.c
@@ -1,5 +1,5 @@
---- src/nettool.c.orig Sun Jul 4 15:52:03 2004
-+++ src/nettool.c Sun Jul 4 15:53:11 2004
+--- src/nettool.c.orig Wed Dec 22 07:07:36 2004
++++ src/nettool.c Mon Dec 27 21:22:28 2004
@@ -21,6 +21,7 @@
#include <gnome.h>
#include <sys/types.h>
@@ -8,3 +8,32 @@
#include <signal.h>
#include <errno.h>
#include <sys/wait.h>
+@@ -361,6 +362,10 @@
+ len, NULL);
+ }
+
++ g_free (text);
++
++ return TRUE;
++
+ } else if (status == G_IO_STATUS_AGAIN) {
+ char buf[1];
+
+@@ -372,12 +377,14 @@
+ }
+ g_string_append_c (netinfo->command_output, buf[0]);
+ }
++
++ g_free (text);
++
++ return TRUE;
+ } else if (status == G_IO_STATUS_EOF) {
+- }
++ }
+
+ g_free (text);
+-
+- return TRUE;
+ }
+
+ /* The condition is not G_IO_HUP | G_IO_ERR | G_IO_NVAL, so