aboutsummaryrefslogtreecommitdiff
path: root/net/gnomeicu2/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-04-05 04:18:55 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-04-05 04:18:55 +0000
commit62b072f4e89c12699016484fb47b32edde2934ee (patch)
tree987168f50d353988633c37e8b67cec6765ce7871 /net/gnomeicu2/Makefile
parent7e249e103b9024b5d95bcdfdf636810aac7b2559 (diff)
Update to 0.99.5.
Notes
Notes: svn path=/head/; revision=106198
Diffstat (limited to 'net/gnomeicu2/Makefile')
-rw-r--r--net/gnomeicu2/Makefile15
1 files changed, 10 insertions, 5 deletions
diff --git a/net/gnomeicu2/Makefile b/net/gnomeicu2/Makefile
index 61b457400d90..eb02207c5707 100644
--- a/net/gnomeicu2/Makefile
+++ b/net/gnomeicu2/Makefile
@@ -16,13 +16,12 @@ DISTNAME= gnomeicu-${PORTVERSION}
MAINTAINER= gnome@FreeBSD.org
COMMENT= GNOME2 ICQ client
-LIB_DEPENDS+= gnet-glib2.7:${PORTSDIR}/net/gnet-glib2 \
- gdbm.3:${PORTSDIR}/databases/gdbm
+LIB_DEPENDS= gdbm.3:${PORTSDIR}/databases/gdbm
USE_BZIP2= yes
USE_X_PREFIX= yes
-USE_GNOME= gnomeprefix gnomehack libglade2 gnomepanel libxml2
-USE_GMAKE= yes
+USE_GNOME= gnomeprefix gnomehack libglade2 gnomepanel lthack libxml2
+USE_GMAKE= yes
USE_LIBTOOL_VER=13
USE_REINPLACE= yes
.if defined(WITH_DANTE)
@@ -47,8 +46,14 @@ CONFIGURE_ENV= CPPFLAGS="${SOCKSFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib" LIBS="-liconv ${SOCKSLIBS} -lintl" \
CFLAGS="${CFLAGS}"
+.ifndef(WITHOUT_GTKSPELL)
+LIB_DEPENDS+= gtkspell.0:${PORTSDIR}/textproc/gtkspell2
+CONFIGURE_ARGS+=--enable-gtkspell
+.else
+CONFIGURE_ARGS+=--disable-gtkspell
+.endif
+
post-patch:
- @${REINPLACE_CMD} -e 's|gnet|gnet-glib2|g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|GNOME_PARAM_GNOME_DATADIR|GNOME_PARAM_APP_DATADIR|g' \
${WRKSRC}/src/gnomeicu.c