aboutsummaryrefslogtreecommitdiff
path: root/net/gnomeicu
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-12-18 22:34:52 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-12-18 22:34:52 +0000
commit33b28e4a9b4aaf1f00980710737af6241e9aa869 (patch)
treea03ecaab004fd744e5a47d3233d134aa856eaf0a /net/gnomeicu
parent478a33a0c62fbf0d55d72d2e75303b892802a3e2 (diff)
downloadports-33b28e4a9b4aaf1f00980710737af6241e9aa869.tar.gz
ports-33b28e4a9b4aaf1f00980710737af6241e9aa869.zip
Notes
Diffstat (limited to 'net/gnomeicu')
-rw-r--r--net/gnomeicu/gnomeicu/Makefile2
-rw-r--r--net/gnomeicu/gnomeicu/files/patch-src_history.c14
2 files changed, 15 insertions, 1 deletions
diff --git a/net/gnomeicu/gnomeicu/Makefile b/net/gnomeicu/gnomeicu/Makefile
index 56785171bc9b..19d47230ffc3 100644
--- a/net/gnomeicu/gnomeicu/Makefile
+++ b/net/gnomeicu/gnomeicu/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gnomeicu2
PORTVERSION= 0.99.5
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= gnomeicu
diff --git a/net/gnomeicu/gnomeicu/files/patch-src_history.c b/net/gnomeicu/gnomeicu/files/patch-src_history.c
new file mode 100644
index 000000000000..b529bd13bda2
--- /dev/null
+++ b/net/gnomeicu/gnomeicu/files/patch-src_history.c
@@ -0,0 +1,14 @@
+--- src/history.c.orig Mon Nov 29 20:48:25 2004
++++ src/history.c Mon Nov 29 20:21:37 2004
+@@ -214,6 +214,11 @@
+ char direction;
+ time_t time;
+
++ if (! (ptr+4)) {
++ g_free (hp->buffer);
++ g_free (hp);
++ return FALSE;
++ }
+ /* read header info */
+ sscanf (ptr+4, "%c %d", &direction, (int *)&time);
+