aboutsummaryrefslogtreecommitdiff
path: root/net/gnomenettool
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-01-03 08:29:37 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-01-03 08:29:37 +0000
commitb3fb0c72c03546e312c443de99d9246c106afc93 (patch)
tree617da6819b2e2b01ee03cbb1249d6127c25bc6d0 /net/gnomenettool
parent21079947e1a8facdc0508d5408f6137b0fa370d9 (diff)
downloadports-b3fb0c72c03546e312c443de99d9246c106afc93.tar.gz
ports-b3fb0c72c03546e312c443de99d9246c106afc93.zip
Notes
Diffstat (limited to 'net/gnomenettool')
-rw-r--r--net/gnomenettool/Makefile33
-rw-r--r--net/gnomenettool/distinfo1
-rw-r--r--net/gnomenettool/files/patch-configure10
-rw-r--r--net/gnomenettool/files/patch-gnome-netinfo::info.c63
-rw-r--r--net/gnomenettool/files/patch-gnome-netinfo_callbacks.c10
-rw-r--r--net/gnomenettool/files/patch-gnome-netinfo_netinfo.c41
-rw-r--r--net/gnomenettool/files/patch-gnome-netinfo_netstat.c136
-rw-r--r--net/gnomenettool/files/patch-gnome-netinfo_netstat.h14
-rw-r--r--net/gnomenettool/files/patch-gnome-netinfo_ping.c11
-rw-r--r--net/gnomenettool/files/patch-gnome-netinfo_ping.h11
-rw-r--r--net/gnomenettool/files/patch-gnome-netinfo_util-mii.c15
-rw-r--r--net/gnomenettool/files/patch-network-utilities_gnome-remote-shell.c12
-rw-r--r--net/gnomenettool/pkg-descr10
-rw-r--r--net/gnomenettool/pkg-plist56
14 files changed, 423 insertions, 0 deletions
diff --git a/net/gnomenettool/Makefile b/net/gnomenettool/Makefile
new file mode 100644
index 000000000000..7f8211b76b0f
--- /dev/null
+++ b/net/gnomenettool/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: gnomenetwork
+# Date Created: 03 June 2003
+# Whom: Adam Weinberger <adamw@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnomenetwork
+PORTVERSION= 1.99.5
+PORTREVISION= 1
+CATEGORIES= net gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/gnome-network/1.99
+DISTNAME= gnome-network-${PORTVERSION}
+DIST_SUBDIR= gnome2
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= A library for writing networked servers & clients
+
+USE_X_PREFIX= yes
+USE_BZIP2= yes
+USE_GNOME= gnomehack gnomeprefix libgnomeui
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+CONFIGURE_ARGS= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+post-patch:
+ ${FIND} ${WRKSRC} -name "intltool-merge.in" | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|mkdir $$lang or|mkdir $$lang, 0777 or| ; \
+ s|^push @INC, "/.*|push @INC, "${LOCALBASE}/share/intltool";|'
+
+.include <bsd.port.mk>
diff --git a/net/gnomenettool/distinfo b/net/gnomenettool/distinfo
new file mode 100644
index 000000000000..5a96d35bb570
--- /dev/null
+++ b/net/gnomenettool/distinfo
@@ -0,0 +1 @@
+MD5 (gnome2/gnome-network-1.99.5.tar.bz2) = 77532442a106d06ed2fe015f87d9b522
diff --git a/net/gnomenettool/files/patch-configure b/net/gnomenettool/files/patch-configure
new file mode 100644
index 000000000000..f195f07b43c6
--- /dev/null
+++ b/net/gnomenettool/files/patch-configure
@@ -0,0 +1,10 @@
+--- configure.orig Wed Dec 11 18:31:51 2002
++++ configure Thu Dec 12 12:07:17 2002
+@@ -7414,6 +7414,7 @@
+
+ # This can be used to rebuild libtool when needed
+ LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
++$ac_aux_dir/ltconfig $LIBTOOL_DEPS
+
+ # Always use our own libtool.
+ LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/net/gnomenettool/files/patch-gnome-netinfo::info.c b/net/gnomenettool/files/patch-gnome-netinfo::info.c
new file mode 100644
index 000000000000..54c795546c31
--- /dev/null
+++ b/net/gnomenettool/files/patch-gnome-netinfo::info.c
@@ -0,0 +1,63 @@
+--- gnome-netinfo/info.c.orig Mon Nov 24 18:29:43 2003
++++ gnome-netinfo/info.c Wed Dec 17 22:27:46 2003
+@@ -27,6 +27,7 @@
+ #endif
+
+
++#include <netinet/in.h>
+ #include <sys/socket.h> /* basic socket definitions */
+ #include <arpa/inet.h> /* inet(3) functions */
+ #include <sys/un.h> /* for Unix domain sockets */
+@@ -173,7 +174,7 @@
+ for (ptr = buf; ptr < buf + ifc.ifc_len;) {
+ ifr = (struct ifreq *) ptr;
+ len = sizeof (struct sockaddr);
+-#ifdef HAVE_SOCKADDR_SA_LEN
++#if defined(HAVE_SOCKADDR_SA_LEN) || defined(__FreeBSD__)
+ if (ifr->ifr_addr.sa_len > len)
+ len = ifr->ifr_addr.sa_len; /* length > 16 */
+ #endif
+@@ -182,8 +183,12 @@
+ if (strcmp (ifr->ifr_name, nic) != 0) {
+ continue;
+ }
++
++ memset (&data, 0, sizeof(data));
+
++#ifdef __linux__
+ data = mii_get_basic (nic);
++#endif
+
+ switch (ifr->ifr_addr.sa_family) {
+ case AF_INET:
+@@ -306,7 +311,6 @@
+ break;
+ }
+ }
+- g_free (ifr);
+ }
+
+ static GList *
+@@ -321,6 +325,8 @@
+
+ sockfd = socket (AF_INET, SOCK_DGRAM, 0);
+
++ memset (&ifc, 0, sizeof (struct ifconf));
++ memset (&buf, 0, sizeof (buf));
+ ifc.ifc_len = sizeof (buf);
+ ifc.ifc_req = (struct ifreq *) buf;
+
+@@ -331,9 +337,11 @@
+ len = sizeof (struct sockaddr);
+
+ iface = g_strdup (ifr->ifr_name);
+- items = g_list_append (items, iface);
++ if (g_list_find_custom (items, iface, (GCompareFunc) g_ascii_strcasecmp) == NULL) {
++ items = g_list_append (items, iface);
++ }
+
+-#ifdef HAVE_SOCKADDR_SA_LEN
++#if defined(HAVE_SOCKADDR_SA_LEN) || defined(__FreeBSD__)
+ if (ifr->ifr_addr.sa_len > len)
+ len = ifr->ifr_addr.sa_len; /* length > 16 */
+ #endif
diff --git a/net/gnomenettool/files/patch-gnome-netinfo_callbacks.c b/net/gnomenettool/files/patch-gnome-netinfo_callbacks.c
new file mode 100644
index 000000000000..32d818c6f24a
--- /dev/null
+++ b/net/gnomenettool/files/patch-gnome-netinfo_callbacks.c
@@ -0,0 +1,10 @@
+--- gnome-netinfo/callbacks.c.orig Sat Dec 6 23:20:05 2003
++++ gnome-netinfo/callbacks.c Sat Dec 6 23:20:14 2003
+@@ -27,6 +27,7 @@
+ #include <sys/wait.h>
+ #include <unistd.h>
+ #include <sys/types.h>
++#include <signal.h>
+
+ #include "callbacks.h"
+ #include "traceroute.h"
diff --git a/net/gnomenettool/files/patch-gnome-netinfo_netinfo.c b/net/gnomenettool/files/patch-gnome-netinfo_netinfo.c
new file mode 100644
index 000000000000..4048c43b48ab
--- /dev/null
+++ b/net/gnomenettool/files/patch-gnome-netinfo_netinfo.c
@@ -0,0 +1,41 @@
+--- gnome-netinfo/netinfo.c.orig Mon Nov 24 18:29:43 2003
++++ gnome-netinfo/netinfo.c Sun Dec 7 01:00:52 2003
+@@ -20,6 +20,7 @@
+
+ #include <gnome.h>
+ #include <sys/types.h>
++#include <sys/socket.h>
+ #include <signal.h>
+ #include <errno.h>
+ #include <sys/wait.h>
+@@ -253,14 +254,16 @@
+ if (condition & G_IO_IN) {
+ g_io_channel_read_line (channel, &text, &len, NULL, NULL);
+
+- if (netinfo->process_line != NULL) {
+- (netinfo->process_line) ((gpointer) netinfo, text,
+- len, NULL);
+- }
++ if (text != NULL) {
++ if (netinfo->process_line != NULL) {
++ (netinfo->process_line) ((gpointer) netinfo, text,
++ len, NULL);
++ }
+
+- g_free (text);
++ g_free (text);
+
+- return TRUE;
++ return TRUE;
++ }
+ }
+
+ /* The condition is not G_IO_HUP | G_IO_ERR | G_IO_NVAL, so
+@@ -285,6 +288,7 @@
+ }
+ return FALSE;
+ }
++
+
+ void
+ netinfo_stop_process_command (Netinfo * netinfo)
diff --git a/net/gnomenettool/files/patch-gnome-netinfo_netstat.c b/net/gnomenettool/files/patch-gnome-netinfo_netstat.c
new file mode 100644
index 000000000000..4f0a7240ba9c
--- /dev/null
+++ b/net/gnomenettool/files/patch-gnome-netinfo_netstat.c
@@ -0,0 +1,136 @@
+--- gnome-netinfo/netstat.c.orig Mon Nov 24 18:29:43 2003
++++ gnome-netinfo/netstat.c Sun Dec 7 01:34:51 2003
+@@ -113,7 +113,11 @@
+ }
+ if (gtk_toggle_button_get_active (GTK_TOGGLE_BUTTON (netinfo->protocol))) {
+ /* Only works for Solaris */
++#ifdef __FreeBSD__
++ option = g_strdup ("-a -f inet -ln");
++#else
+ option = g_strdup ("-A inet -ln");
++#endif
+ }
+ if (gtk_toggle_button_get_active (GTK_TOGGLE_BUTTON (netinfo->multicast))) {
+ /* It works for Solaris and Linux */
+@@ -266,7 +270,11 @@
+ g_return_if_fail (line != NULL);
+
+ count = strip_protocol_line (line, &data);
++#ifdef __FreeBSD__
++ if (count == 5 || count == 6 || count == 9 || count == 10) {
++#else
+ if (count == 7 || count == 8) {
++#endif
+ #ifdef DEBUG
+ g_print ("%s\t%s:%s\t%s\n", data.protocol,
+ data.ip_src, data.port_src, data.state);
+@@ -331,11 +339,42 @@
+ strip_protocol_line (gchar * line, netstat_protocol_data *data)
+ {
+ gint count = 0;
++#ifdef __FreeBSD__
++ gint a1, a2, a3, a4;
++ gchar s9[30];
++#else
+ gchar s6[30], s7[30];
++#endif
+ gint n2, n3;
+
+ line = g_strdelimit (line, ":", ' ');
+
++#ifdef __FreeBSD__
++ count = sscanf (line, NETSTAT_PROTOCOL_FORMAT,
++ data->protocol, &n2, &n3,
++ &a1, &a2, &a3, &a4, data->port_src,
++ s9, data->state);
++ g_snprintf (data->ip_src, 30, "%d.%d.%d.%d", a1, a2, a3, a4);
++
++ if (count == 9) {
++ bzero (&(data)->state, 30);
++ }
++
++ if (count == 3) {
++ /* Handle the *.* entries. */
++ gchar s5[30];
++ count = sscanf (line, ALT_NETSTAT_PROTOCOL_FORMAT,
++ data->protocol, &n2, &n3,
++ data->port_src, s5,
++ data->state);
++ g_snprintf (data->ip_src, 30, "*");
++
++ if (count == 5) {
++ bzero (&(data)->state, 30);
++ }
++ }
++
++#else
+ count = sscanf (line, NETSTAT_PROTOCOL_FORMAT,
+ data->protocol, &n2, &n3,
+ data->ip_src, data->port_src,
+@@ -344,6 +383,7 @@
+ if (count == 7) {
+ bzero (&(data)->state, 30);
+ }
++#endif
+
+ return count;
+ }
+@@ -405,7 +445,11 @@
+ g_return_if_fail (line != NULL);
+
+ count = strip_route_line (line, &data);
++#ifdef __FreeBSD__
++ if (count == 6) {
++#else
+ if (count == 8) {
++#endif
+ #ifdef DEBUG
+ g_print ("%s\t%s:%s\t%d\t%s\n", data.destination,
+ data.gateway, data.netmask, data.metric,
+@@ -474,11 +518,19 @@
+ gchar flags[30];
+ gint ref, use;
+
++#ifdef __FreeBSD__
++ count = sscanf (line, NETSTAT_ROUTE_FORMAT,
++ data->destination,
++ data->gateway, flags,
++ &ref, &use, data->iface);
++#else
++
+ count = sscanf (line, NETSTAT_ROUTE_FORMAT,
+ data->destination,
+ data->gateway, data->netmask,
+ flags, &(data)->metric, &ref, &use,
+ data->iface);
++#endif
+
+ return count;
+ }
+@@ -493,7 +545,11 @@
+ renderer = gtk_cell_renderer_text_new ();
+ column =
+ gtk_tree_view_column_new_with_attributes
++#ifdef __FreeBSD__
++ (_("Destination/Prefix"), renderer, "text", 0, NULL);
++#else
+ (_("Destination"), renderer, "text", 0, NULL);
++#endif
+ gtk_tree_view_append_column (widget, column);
+
+ renderer = gtk_cell_renderer_text_new ();
+@@ -503,12 +559,14 @@
+ gtk_tree_view_column_set_alignment (column, 0.5);
+ gtk_tree_view_append_column (widget, column);
+
++#ifndef __FreeBSD__
+ renderer = gtk_cell_renderer_text_new ();
+ column =
+ gtk_tree_view_column_new_with_attributes
+ (_("Netmask"), renderer, "text", 2, NULL);
+
+ gtk_tree_view_append_column (widget, column);
++#endif
+
+ renderer = gtk_cell_renderer_text_new ();
+ column =
diff --git a/net/gnomenettool/files/patch-gnome-netinfo_netstat.h b/net/gnomenettool/files/patch-gnome-netinfo_netstat.h
new file mode 100644
index 000000000000..6e00ba018f0b
--- /dev/null
+++ b/net/gnomenettool/files/patch-gnome-netinfo_netstat.h
@@ -0,0 +1,14 @@
+--- gnome-netinfo/netstat.h.orig Sun Jul 20 22:31:57 2003
++++ gnome-netinfo/netstat.h Sun Dec 7 01:32:10 2003
+@@ -28,6 +28,11 @@
+ # define NETSTAT_PROTOCOL_FORMAT "%s %d %d %s %s %s %s %s"
+ # define NETSTAT_ROUTE_FORMAT "%s %s %s %s %d %d %d %s"
+ # define NETSTAT_MULTICAST_FORMAT "%s %d %s"
++#elif defined(__FreeBSD__)
++# define NETSTAT_PROTOCOL_FORMAT "%s %d %d %d.%d.%d.%d.%s %s %s"
++# define ALT_NETSTAT_PROTOCOL_FORMAT "%s %d %d *.%s %s %s"
++# define NETSTAT_ROUTE_FORMAT "%s %s %s %d %d %s"
++# define NETSTAT_MULTICAST_FORMAT "%s %d %s"
+
+ #endif
+
diff --git a/net/gnomenettool/files/patch-gnome-netinfo_ping.c b/net/gnomenettool/files/patch-gnome-netinfo_ping.c
new file mode 100644
index 000000000000..40f2b83fa6b1
--- /dev/null
+++ b/net/gnomenettool/files/patch-gnome-netinfo_ping.c
@@ -0,0 +1,11 @@
+--- gnome-netinfo/ping.c.orig Sat Dec 6 23:08:52 2003
++++ gnome-netinfo/ping.c Sat Dec 6 23:17:35 2003
+@@ -330,6 +330,8 @@
+
+ if (netinfo_get_ip_version (netinfo) == IPV4)
+ line = g_strdelimit (line, ":", ' ');
++ else
++ line = g_strdelimit (line, ",", ' ');
+
+ #ifdef PING_PARAMS_5
+ count = sscanf (line, PING_FORMAT,
diff --git a/net/gnomenettool/files/patch-gnome-netinfo_ping.h b/net/gnomenettool/files/patch-gnome-netinfo_ping.h
new file mode 100644
index 000000000000..debf4603d263
--- /dev/null
+++ b/net/gnomenettool/files/patch-gnome-netinfo_ping.h
@@ -0,0 +1,11 @@
+--- gnome-netinfo/ping.h.orig Sat Dec 6 23:11:01 2003
++++ gnome-netinfo/ping.h Sat Dec 6 23:17:53 2003
+@@ -25,7 +25,7 @@
+
+ /* The ping usage and output is different between Unix flavours */
+ /* FIXME: Add BSD support */
+-#if defined(__linux__) || defined(__OSF__)
++#if defined(__linux__) || defined(__OSF__) || defined(__FreeBSD__)
+ # define PING_PROGRAM_FORMAT "%s ping -c %d -n %s"
+ # define PING_PROGRAM_FORMAT_6 "%s ping6 -c %d -n %s"
+ # define PING_FORMAT "%d bytes from %s icmp_seq=%d ttl=%d time=%s %s"
diff --git a/net/gnomenettool/files/patch-gnome-netinfo_util-mii.c b/net/gnomenettool/files/patch-gnome-netinfo_util-mii.c
new file mode 100644
index 000000000000..9d38a3d3daa6
--- /dev/null
+++ b/net/gnomenettool/files/patch-gnome-netinfo_util-mii.c
@@ -0,0 +1,15 @@
+--- gnome-netinfo/util-mii.c.orig Sat Dec 6 23:30:50 2003
++++ gnome-netinfo/util-mii.c Sat Dec 6 23:38:14 2003
+@@ -39,6 +39,7 @@
+ * http://www.national.com/pf/DP/DP83840.html
+ */
+
++#ifdef __linux__
+ #include <glib.h>
+
+ #include <errno.h>
+@@ -237,3 +238,4 @@
+ close (sock);
+ return data;
+ }
++#endif
diff --git a/net/gnomenettool/files/patch-network-utilities_gnome-remote-shell.c b/net/gnomenettool/files/patch-network-utilities_gnome-remote-shell.c
new file mode 100644
index 000000000000..0ac22218e1ab
--- /dev/null
+++ b/net/gnomenettool/files/patch-network-utilities_gnome-remote-shell.c
@@ -0,0 +1,12 @@
+--- network-utilities/gnome-remote-shell.c.orig Mon Sep 1 01:56:21 2003
++++ network-utilities/gnome-remote-shell.c Mon Sep 1 01:58:11 2003
+@@ -23,6 +23,9 @@
+ #endif
+
+ #include <netdb.h>
++#include <sys/types.h>
++#include <sys/socket.h>
++#include <netinet/in.h>
+ #include <gconf/gconf-client.h>
+ #include <gtk/gtkdialog.h>
+ #include <gtk/gtkentry.h>
diff --git a/net/gnomenettool/pkg-descr b/net/gnomenettool/pkg-descr
new file mode 100644
index 000000000000..1362640b6f11
--- /dev/null
+++ b/net/gnomenettool/pkg-descr
@@ -0,0 +1,10 @@
+gnome-network is a set of network oriented user tools. It includes the
+following tools:
+
+ * gnome-remote-shell: a remote shell (Telnet/SSH) client.
+ * gnome-remote-desktop: a remote desktop (X11/VNC) client.
+ * gnome-netinfo: a network information tool, for getting info on
+ network cards, DNS, etc.
+ * gnome-backup: a backup client tool.
+
+WWW: http://www.gnome.org/
diff --git a/net/gnomenettool/pkg-plist b/net/gnomenettool/pkg-plist
new file mode 100644
index 000000000000..5c7e7394dfcc
--- /dev/null
+++ b/net/gnomenettool/pkg-plist
@@ -0,0 +1,56 @@
+bin/gnome-remote-shell
+bin/gnome-remote-desktop
+bin/gnome-netinfo
+share/gnome/application-registry/gnome-remote-desktop.applications
+share/gnome/applications/gnome-network-utilities.desktop
+share/gnome/applications/gnome-netinfo.desktop
+share/gnome/apps/Internet/gnome-remote-desktop.desktop
+share/gnome/gnome-network/dialogs/gnome-netinfo.glade
+share/gnome/gnome-network/dialogs/gnome-remote-shell.glade
+share/gnome/mime-info/gnome-remote-desktop.keys
+share/gnome/mime-info/gnome-remote-desktop.mime
+share/gnome/pixmaps/gnome-netinfo.png
+share/gnome/pixmaps/gnome-network/colors.png
+share/gnome/pixmaps/gnome-network/computer.png
+share/gnome/pixmaps/gnome-network/gnome-remote-desktop.png
+share/gnome/pixmaps/gnome-network/keyboard.png
+share/gnome/pixmaps/gnome-network/perform.png
+share/gnome/pixmaps/gnome-network/program.png
+share/gnome/pixmaps/gnome-network/size.png
+share/gnome/pixmaps/gnome-network/sound.png
+share/gnome/pixmaps/gnome-remote-desktop.png
+share/gnome/pixmaps/gnome-remote-shell.png
+share/locale/az/LC_MESSAGES/gnome-network.mo
+share/locale/ca/LC_MESSAGES/gnome-network.mo
+share/locale/cs/LC_MESSAGES/gnome-network.mo
+share/locale/da/LC_MESSAGES/gnome-network.mo
+share/locale/de/LC_MESSAGES/gnome-network.mo
+share/locale/el/LC_MESSAGES/gnome-network.mo
+share/locale/es/LC_MESSAGES/gnome-network.mo
+share/locale/fr/LC_MESSAGES/gnome-network.mo
+share/locale/ga/LC_MESSAGES/gnome-network.mo
+share/locale/gl/LC_MESSAGES/gnome-network.mo
+share/locale/he/LC_MESSAGES/gnome-network.mo
+share/locale/hu/LC_MESSAGES/gnome-network.mo
+share/locale/it/LC_MESSAGES/gnome-network.mo
+share/locale/ja/LC_MESSAGES/gnome-network.mo
+share/locale/ko/LC_MESSAGES/gnome-network.mo
+share/locale/ms/LC_MESSAGES/gnome-network.mo
+share/locale/nl/LC_MESSAGES/gnome-network.mo
+share/locale/no/LC_MESSAGES/gnome-network.mo
+share/locale/pl/LC_MESSAGES/gnome-network.mo
+share/locale/pt/LC_MESSAGES/gnome-network.mo
+share/locale/pt_BR/LC_MESSAGES/gnome-network.mo
+share/locale/ru/LC_MESSAGES/gnome-network.mo
+share/locale/sr/LC_MESSAGES/gnome-network.mo
+share/locale/sr@Latn/LC_MESSAGES/gnome-network.mo
+share/locale/sv/LC_MESSAGES/gnome-network.mo
+share/locale/tr/LC_MESSAGES/gnome-network.mo
+share/locale/uk/LC_MESSAGES/gnome-network.mo
+share/locale/vi/LC_MESSAGES/gnome-network.mo
+share/locale/wa/LC_MESSAGES/gnome-network.mo
+share/locale/zh_CN/LC_MESSAGES/gnome-network.mo
+share/locale/zh_TW/LC_MESSAGES/gnome-network.mo
+@dirrm share/gnome/pixmaps/gnome-network
+@dirrm share/gnome/gnome-network/dialogs
+@dirrm share/gnome/gnome-network