aboutsummaryrefslogtreecommitdiff
path: root/net/gnu-dico/Makefile
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2010-10-12 07:07:33 +0000
committerWen Heping <wen@FreeBSD.org>2010-10-12 07:07:33 +0000
commit2686b99c3ee13cee1c7b3e2f6824f7f42dd1663e (patch)
tree0e0688b16f6bd8e621c34d7f9e2cfb317576a294 /net/gnu-dico/Makefile
parent515bbcdf9a553c1cb446c53d960beb0b3998490e (diff)
Notes
Diffstat (limited to 'net/gnu-dico/Makefile')
-rw-r--r--net/gnu-dico/Makefile16
1 files changed, 13 insertions, 3 deletions
diff --git a/net/gnu-dico/Makefile b/net/gnu-dico/Makefile
index c3e2eef661c1..355fc497a823 100644
--- a/net/gnu-dico/Makefile
+++ b/net/gnu-dico/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= dico
-PORTVERSION= 2.0
+PORTVERSION= 2.1
CATEGORIES= net textproc
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,6 +15,7 @@ PKGNAMEPREFIX= gnu-
MAINTAINER= goran.tal@gmail.com
COMMENT= Flexible modular implementation of DICT server
+USE_XZ= yes
USE_LDCONFIG= yes
USE_GMAKE= yes
USE_AUTOTOOLS= libltdl:22 libtool:22
@@ -26,7 +27,8 @@ CONFIGURE_ARGS= --localstatedir=/var
OPTIONS= PYTHON "With PYTHON support" on \
GUILE "With GUILE support" on \
- GSASL "With GSASL support" off
+ GSASL "With GSASL support" off \
+ LDAP "With LDAP support" off
.include <bsd.port.options.mk>
@@ -53,6 +55,14 @@ CONFIGURE_ARGS+=--with-gsasl
CONFIGURE_ARGS+=--without-gsasl
.endif
+.if defined(WITH_LDAP)
+USE_OPENLDAP= yes
+PLIST_SUB+= LDAP=""
+.else
+CONFIGURE_ARGS+=--without-ldap
+PLIST_SUB+= LDAP="@comment "
+.endif
+
.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
@@ -70,7 +80,7 @@ USE_RC_SUBR= dicod.sh
post-patch:
@${REINPLACE_CMD} 's/ENODATA/EIO/' ${WRKSRC}/lib/utf8.c
@${REINPLACE_CMD} 's/@bindir@/@sbindir@/' ${WRKSRC}/dicod/Makefile.in
- @${REINPLACE_CMD} 's/(bindir)\//(bindir)\/g/' ${WRKSRC}/dico/Makefile.in
+ @${REINPLACE_CMD} 's/(bindir)..dir/&\/gdico/' ${WRKSRC}/dico/Makefile.in
@${REINPLACE_CMD} '/INSTALL.*charset/d' ${WRKSRC}/gnu/Makefile.in
post-install: