aboutsummaryrefslogtreecommitdiff
path: root/net/gnu-radius/Makefile
diff options
context:
space:
mode:
authorKelly Yancey <kbyanc@FreeBSD.org>2002-03-08 03:11:04 +0000
committerKelly Yancey <kbyanc@FreeBSD.org>2002-03-08 03:11:04 +0000
commit367ac6ed3b07692011412661d8fa5b030f8b8c25 (patch)
tree62e62d3925d126491c082c08445145804a9c137d /net/gnu-radius/Makefile
parent6c0ad600bd4146920bed1e86f2cbe0de436bac52 (diff)
downloadports-367ac6ed3b07692011412661d8fa5b030f8b8c25.tar.gz
ports-367ac6ed3b07692011412661d8fa5b030f8b8c25.zip
Notes
Diffstat (limited to 'net/gnu-radius/Makefile')
-rw-r--r--net/gnu-radius/Makefile48
1 files changed, 48 insertions, 0 deletions
diff --git a/net/gnu-radius/Makefile b/net/gnu-radius/Makefile
new file mode 100644
index 000000000000..da8c3ed333f7
--- /dev/null
+++ b/net/gnu-radius/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: gnu-radius
+# Date created: 13 Jul 2001
+# Whom: lance@evitel.net
+#
+# $FreeBSD$
+
+PORTNAME= gnu-radius
+PORTVERSION= 0.96
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_GNU}
+MASTER_SITE_SUBDIR= radius
+
+MAINTAINER= lance@evitel.net
+
+#MAKEFILE= Makefile
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-include-path="${PREFIX}"
+
+MAN1= radgrep.1 radlast.1 raduse.1 radwho.1
+MAN8= builddbm.8 radctl.8 radiusd.8 radping.8 radzap.8
+MANCOMPRESSED= no
+
+SCRIPTS_ENV= WRKDIRPREFIX="${WRKDIRPREFIX}" \
+ CURDIR="${.CURDIR}"
+
+STARTUP_FILE= ${PREFIX}/etc/rc.d/gnu-radius.sh
+
+.if !defined(BATCH)
+post-fetch:
+ @${SETENV} ${SCRIPTS_ENV} ${SH} ${SCRIPTDIR}/configure
+.endif
+
+.if exists(${WRKDIRPREFIX}${.CURDIR}/Makefile.inc)
+.include "${WRKDIRPREFIX}${.CURDIR}/Makefile.inc"
+.endif
+
+post-install:
+ @${SED} -e "s=!!PREFIX!!=${PREFIX}=g" ${FILESDIR}/gnu-radius.sh.tmpl \
+ > ${PREFIX}/etc/rc.d/gnu-radius.sh
+ @${CHMOD} 550 ${PREFIX}/etc/rc.d/gnu-radius.sh
+ @${CHOWN} root:wheel ${PREFIX}/etc/rc.d/gnu-radius.sh
+
+post-clean:
+ @${RM} -f ${WRKDIRPREFIX}${.CURDIR}/Makefile.inc
+
+.include <bsd.port.mk>