aboutsummaryrefslogtreecommitdiff
path: root/net/gnu-radius
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2008-12-08 15:48:47 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2008-12-08 15:48:47 +0000
commita692101e8df963cb5a8dafa0bf95a69f41aa7f06 (patch)
tree45d01f8ec52059f4991ef1cda1170dd6c5a64b3a /net/gnu-radius
parent2723ae937b4ebda64d9692b78509312606eb0778 (diff)
downloadports-a692101e8df963cb5a8dafa0bf95a69f41aa7f06.tar.gz
ports-a692101e8df963cb5a8dafa0bf95a69f41aa7f06.zip
Notes
Diffstat (limited to 'net/gnu-radius')
-rw-r--r--net/gnu-radius/Makefile50
-rw-r--r--net/gnu-radius/distinfo6
-rw-r--r--net/gnu-radius/files/extrapatch-emacs91
-rw-r--r--net/gnu-radius/files/patch-configure9
-rw-r--r--net/gnu-radius/files/patch-dbm8
-rw-r--r--net/gnu-radius/pkg-plist71
6 files changed, 66 insertions, 169 deletions
diff --git a/net/gnu-radius/Makefile b/net/gnu-radius/Makefile
index 0ef0516177a2..20051d686401 100644
--- a/net/gnu-radius/Makefile
+++ b/net/gnu-radius/Makefile
@@ -5,8 +5,7 @@
# $FreeBSD$
PORTNAME= gnu-radius
-PORTVERSION= 1.5
-PORTREVISION= 1
+PORTVERSION= 1.6
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= radius
@@ -43,9 +42,8 @@ OPTIONS= CLIENT "Enable build client" off \
MYSQL "Enable MySQL support" on \
POSTGRESQL "Enable PostgreSQL support" off \
SNMP "Enable SNMP support" off \
- NOTIFY "Enable TTL notification" off \
EMACS "Enable emacs dotfiles install" off \
- NLS "Enable gettext support" on
+ PAM "Enable PAM support" off
CONFIG_FILES= access.deny client.conf clients config dictionary \
hints huntgroups naslist nastypes realms \
@@ -56,24 +54,21 @@ EXAMPLE_FILES= README ascend.rw c3620.rw cisco.rw comos.rw config.syntax \
.include <bsd.port.pre.mk>
.if defined(WITH_SNMP)
-CONFIGURE_ARGS+= --enable-snmp
+CONFIGURE_ARGS+=--enable-snmp
.endif
.if defined(WITH_CLIENT)
-CONFIGURE_ARGS+= --enable-client
-WITH_GUILE= yes
-BUILD_DEPENDS+= guile:${PORTSDIR}/lang/guile
-PLIST_SUB+= GUILE=""
+LIB_DEPENDS+= guile.19:${PORTSDIR}/lang/guile
+CONFIGURE_ARGS+=--enable-client
PLIST_SUB+= CLIENT=""
.else
-CONFIGURE_ARGS+= --without-guile
-PLIST_SUB+= GUILE="@comment "
+CONFIGURE_ARGS+=--without-guile
PLIST_SUB+= CLIENT="@comment "
.endif
.if defined(WITH_MYSQL)
USE_MYSQL= yes
-CONFIGURE_ARGS+= --with-mysql
+CONFIGURE_ARGS+=--with-mysql
PLIST_SUB+= MYSQL=""
.else
PLIST_SUB+= MYSQL="@comment "
@@ -81,52 +76,51 @@ PLIST_SUB+= MYSQL="@comment "
.if defined(WITH_POSTGRESQL)
USE_PGSQL= yes
-CONFIGURE_ARGS+= --with-postgres
-INCLUDE_PATH+= ${LOCALBASE}/include/pgsql/
+CONFIGURE_ARGS+=--with-postgres
PLIST_SUB+= PGSQL=""
.else
PLIST_SUB+= PGSQL="@comment "
.endif
-.if defined(WITH_DBM)
-CONFIGURE_ARGS+= --enable-dbm=ndbm
-PLIST_SUB+= DBM=""
+.if defined(WITH_MYSQL) || defined(WITH_POSTGRESQL)
+PLIST_SUB+= MODULES=""
.else
-PLIST_SUB+= DBM="@comment "
+PLIST_SUB+= MODULES="@comment "
.endif
-.if defined(WITH_NOTIFY)
-CONFIGURE_ARGS+= --enable-notify
+.if defined(WITH_DBM)
+CONFIGURE_ARGS+=--enable-dbm=ndbm
.endif
.if defined(WITH_EMACS)
-USE_EMACS= yes
.include "${PORTSDIR}/Mk/bsd.emacs.mk"
-CONFIGURE_ARGS+= --with-lispdir=${PREFIX}/${EMACS_SITE_LISPDIR}
+USE_EMACS= yes
+CONFIGURE_ARGS+=--with-lispdir=${PREFIX}/${EMACS_SITE_LISPDIR}
PLIST_SUB+= EMACS=""
.else
-CONFIGURE_ARGS+= --without-lispdir
+CONFIGURE_ARGS+=--without-lispdir
PLIST_SUB+= EMACS="@comment "
.endif
.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+= --disable-nl
+CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
.else
USE_GETTEXT= yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
PLIST_SUB+= NLS=""
.endif
+.if defined(WITH_PAM)
+CONFIGURE_ARGS+=--enable-pam
+.endif
+
post-patch:
${REINPLACE_CMD} -e 's|extern unsigned scheme_gc_interval;||g' \
${WRKSRC}/include/radiusd.h
post-install:
${INSTALL_SCRIPT} ${WRKDIR}/radiusd.sh ${PREFIX}/etc/rc.d/radiusd.sh
-.if !defined(NOPORTDOCS)
+.if !defined(NOPORTEXAMPLES)
@${MKDIR} ${EXAMPLESDIR}
. for ex_file in ${EXAMPLE_FILES}
${INSTALL_DATA} ${WRKSRC}/examples/${ex_file} ${EXAMPLESDIR}
diff --git a/net/gnu-radius/distinfo b/net/gnu-radius/distinfo
index 00b828a13a5b..7562f0dc4f7a 100644
--- a/net/gnu-radius/distinfo
+++ b/net/gnu-radius/distinfo
@@ -1,3 +1,3 @@
-MD5 (radius-1.5.tar.gz) = 8a33dedd29cec62fc9ba33f04a54bf81
-SHA256 (radius-1.5.tar.gz) = 74f11ed438452fd7b686c9691a466d2b632a9560a7e9a540d82cf716e22d74f8
-SIZE (radius-1.5.tar.gz) = 2490324
+MD5 (radius-1.6.tar.gz) = fea3fb09e659c50fd74bc9a25890e03c
+SHA256 (radius-1.6.tar.gz) = 0a3ca07901e0b4ef5674cc6f94991b31854c9094d6712abba9aab5104dd62bd9
+SIZE (radius-1.6.tar.gz) = 2640894
diff --git a/net/gnu-radius/files/extrapatch-emacs b/net/gnu-radius/files/extrapatch-emacs
deleted file mode 100644
index 7a06c4d04fb7..000000000000
--- a/net/gnu-radius/files/extrapatch-emacs
+++ /dev/null
@@ -1,91 +0,0 @@
---- configure.orig Mon May 2 20:32:36 2005
-+++ configure Mon May 2 20:33:56 2005
-@@ -9868,49 +9868,49 @@
- ### Check for Emacs site-lisp directory
- # If set to t, that means we are running in a shell under Emacs.
- # If you have an Emacs named "t", then use the full path.
-- test x"$EMACS" = xt && EMACS=
-- for ac_prog in emacs xemacs
--do
-+# test x"$EMACS" = xt && EMACS=
-+# for ac_prog in emacs xemacs
-+#do
- # Extract the first word of "$ac_prog", so it can be a program name with args.
--set dummy $ac_prog; ac_word=$2
--echo "$as_me:$LINENO: checking for $ac_word" >&5
--echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6
--if test "${ac_cv_prog_EMACS+set}" = set; then
-- echo $ECHO_N "(cached) $ECHO_C" >&6
--else
-- if test -n "$EMACS"; then
-- ac_cv_prog_EMACS="$EMACS" # Let the user override the test.
--else
--as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
--for as_dir in $PATH
--do
-- IFS=$as_save_IFS
-- test -z "$as_dir" && as_dir=.
-- for ac_exec_ext in '' $ac_executable_extensions; do
-- if $as_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
-- ac_cv_prog_EMACS="$ac_prog"
-- echo "$as_me:$LINENO: found $as_dir/$ac_word$ac_exec_ext" >&5
-- break 2
-- fi
--done
--done
-+#set dummy $ac_prog; ac_word=$2
-+#echo "$as_me:$LINENO: checking for $ac_word" >&5
-+#echo $ECHO_N "checking for $ac_word... $ECHO_C" >&6
-+#if test "${ac_cv_prog_EMACS+set}" = set; then
-+# echo $ECHO_N "(cached) $ECHO_C" >&6
-+#else
-+# if test -n "$EMACS"; then
-+# ac_cv_prog_EMACS="$EMACS" # Let the user override the test.
-+#else
-+#as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
-+#for as_dir in $PATH
-+#do
-+# IFS=$as_save_IFS
-+# test -z "$as_dir" && as_dir=.
-+# for ac_exec_ext in '' $ac_executable_extensions; do
-+# if $as_executable_p "$as_dir/$ac_word$ac_exec_ext"; then
-+# ac_cv_prog_EMACS="$ac_prog"
-+# echo "$as_me:$LINENO: found $as_dir/$ac_word$ac_exec_ext" >&5
-+# break 2
-+# fi
-+#done
-+#done
-
--fi
--fi
--EMACS=$ac_cv_prog_EMACS
--if test -n "$EMACS"; then
-- echo "$as_me:$LINENO: result: $EMACS" >&5
--echo "${ECHO_T}$EMACS" >&6
--else
-- echo "$as_me:$LINENO: result: no" >&5
--echo "${ECHO_T}no" >&6
--fi
--
-- test -n "$EMACS" && break
--done
--test -n "$EMACS" || EMACS="no"
-+#fi
-+#fi
-+#EMACS=$ac_cv_prog_EMACS
-+#if test -n "$EMACS"; then
-+# echo "$as_me:$LINENO: result: $EMACS" >&5
-+#echo "${ECHO_T}$EMACS" >&6
-+#else
-+# echo "$as_me:$LINENO: result: no" >&5
-+#echo "${ECHO_T}no" >&6
-+#fi
-
-+# test -n "$EMACS" && break
-+#done
-+#test -n "$EMACS" || EMACS="no"
-
-+EMACS="no"
-
-
- # Check whether --with-lispdir or --without-lispdir was given.
diff --git a/net/gnu-radius/files/patch-configure b/net/gnu-radius/files/patch-configure
index aac499a3243c..c41e91ca6b51 100644
--- a/net/gnu-radius/files/patch-configure
+++ b/net/gnu-radius/files/patch-configure
@@ -1,14 +1,5 @@
--- configure.orig Sat Nov 20 21:39:50 2004
+++ configure Wed Jul 27 23:13:31 2005
-@@ -9662,7 +9662,7 @@
- #define USE_SERVER_GUILE 1
- _ACEOF
-
-- RADIUSD_LDADD_LIST="$RADIUSD_LDADD_LIST -L../radscm -lradscm ../radscm/libservscm.a $GUILE_LIBS"
-+ RADIUSD_LDADD_LIST="$RADIUSD_LDADD_LIST -L../radscm/.libs -lradscm ../radscm/libservscm.a $GUILE_LIBS"
- fi
- else
- USE_GUILE=no
@@ -22804,7 +22804,7 @@
echo $ECHO_N "(cached) $ECHO_C" >&6
else
diff --git a/net/gnu-radius/files/patch-dbm b/net/gnu-radius/files/patch-dbm
index 66b842d7b18d..788693e8298c 100644
--- a/net/gnu-radius/files/patch-dbm
+++ b/net/gnu-radius/files/patch-dbm
@@ -1,9 +1,9 @@
---- radiusd/builddbm.c.orig Wed Dec 8 14:22:52 2004
-+++ radiusd/builddbm.c Wed Dec 8 14:23:11 2004
-@@ -57,7 +57,7 @@
+--- radiusd/builddbm.c.orig 2008-12-08 14:22:12.000000000 +0100
++++ radiusd/builddbm.c 2008-12-08 14:22:37.000000000 +0100
+@@ -58,7 +58,7 @@
if (2 + check_len + reply_len > closure->pair_buffer_size) {
- grad_log(L_ERR, "%s:%d: %s",
+ grad_log(GRAD_LOG_ERR, "%s:%d: %s",
- closure->filename, sym->lineno,
+ closure->filename, sym->loc.line,
_("too many attributes"));
diff --git a/net/gnu-radius/pkg-plist b/net/gnu-radius/pkg-plist
index ca7b4772d703..01ec35b9f3f1 100644
--- a/net/gnu-radius/pkg-plist
+++ b/net/gnu-radius/pkg-plist
@@ -65,13 +65,14 @@ lib/libgnuradius.a
lib/libgnuradius.so
lib/libgnuradius.la
lib/libgnuradius.so.0
-%%GUILE%%bin/radsession
-%%GUILE%%lib/libguile-gnuradius-v-1.5.so
-%%GUILE%%lib/libradscm.a
-%%GUILE%%lib/libradscm.la
-%%GUILE%%lib/libradscm.so
-%%GUILE%%lib/libradscm.so.1
-%%GUILE%%lib/libservscm.a
+share/aclocal/radius.m4
+%%CLIENT%%bin/radsession
+%%CLIENT%%lib/libguile-gnuradius-v-%%PORTVERSION%%.so
+%%CLIENT%%lib/libradscm.a
+%%CLIENT%%lib/libradscm.la
+%%CLIENT%%lib/libradscm.so
+%%CLIENT%%lib/libradscm.so.1
+%%CLIENT%%lib/libservscm.a
%%CLIENT%%lib/security/pam_radius.a
%%CLIENT%%lib/security/pam_radius.la
%%CLIENT%%lib/security/pam_radius.so
@@ -81,48 +82,50 @@ lib/libgnuradius.so.0
%%NLS%%share/locale/fr/LC_MESSAGES/radius.mo
%%NLS%%share/locale/pl/LC_MESSAGES/radius.mo
%%NLS%%share/locale/ru/LC_MESSAGES/radius.mo
-%%NLS%%share/locale/rw/LC_MESSAGES/radius.mo
+@comment %%NLS%%share/locale/rw/LC_MESSAGES/radius.mo
%%NLS%%share/locale/uk/LC_MESSAGES/radius.mo
%%NLS%%share/locale/vi/LC_MESSAGES/radius.mo
-%%GUILE%%%%DATADIR%%/%%PORTVERSION%%/scheme/gnuradius.scm
-%%GUILE%%%%DATADIR%%/%%PORTVERSION%%/scheme/ipalloc.scm
-%%GUILE%%%%DATADIR%%/%%PORTVERSION%%/scheme/radiusd.scm
-%%GUILE%%%%DATADIR%%/%%PORTVERSION%%/scheme/ttl.scm
-%%GUILE%%%%DATADIR%%/%%PORTVERSION%%/scheme/guile-procedures.txt
+%%CLIENT%%%%DATADIR%%/%%PORTVERSION%%/scheme/gnuradius.scm
+%%CLIENT%%%%DATADIR%%/%%PORTVERSION%%/scheme/ipalloc.scm
+%%CLIENT%%%%DATADIR%%/%%PORTVERSION%%/scheme/radiusd.scm
+%%CLIENT%%%%DATADIR%%/%%PORTVERSION%%/scheme/ttl.scm
+%%CLIENT%%%%DATADIR%%/%%PORTVERSION%%/scheme/guile-procedures.txt
%%DATADIR%%/%%PORTVERSION%%/rewrite/checknas.rw
%%DATADIR%%/%%PORTVERSION%%/rewrite/log-hook.rw
%%DATADIR%%/%%PORTVERSION%%/rewrite/nas-ip.rw
-%%MYSQL%%%%DATADIR%%/%%PORTVERSION%%/modules/mysql.a
-%%MYSQL%%%%DATADIR%%/%%PORTVERSION%%/modules/mysql.la
-%%MYSQL%%%%DATADIR%%/%%PORTVERSION%%/modules/mysql.so
-%%PGSQL%%%%DATADIR%%/%%PORTVERSION%%/modules/postgres.a
-%%PGSQL%%%%DATADIR%%/%%PORTVERSION%%/modules/postgres.la
-%%PGSQL%%%%DATADIR%%/%%PORTVERSION%%/modules/postgres.so
+%%MYSQL%%lib/radius/%%PORTVERSION%%/modules/mysql.a
+%%MYSQL%%lib/radius/%%PORTVERSION%%/modules/mysql.la
+%%MYSQL%%lib/radius/%%PORTVERSION%%/modules/mysql.so
+%%PGSQL%%lib/radius/%%PORTVERSION%%/modules/postgres.a
+%%PGSQL%%lib/radius/%%PORTVERSION%%/modules/postgres.la
+%%PGSQL%%lib/radius/%%PORTVERSION%%/modules/postgres.so
%%EMACS%%%%EMACS_SITE_LISPDIR%%/radconf-mode.el
%%EMACS%%%%EMACS_SITE_LISPDIR%%/radius-mode.el
%%EMACS%%%%EMACS_SITE_LISPDIR%%/rewrite-mode.el
-%%PORTDOCS%%%%EXAMPLESDIR%%/README
-%%PORTDOCS%%%%EXAMPLESDIR%%/ascend.rw
-%%PORTDOCS%%%%EXAMPLESDIR%%/c3620.rw
-%%PORTDOCS%%%%EXAMPLESDIR%%/cisco.rw
-%%PORTDOCS%%%%EXAMPLESDIR%%/comos.rw
-%%PORTDOCS%%%%EXAMPLESDIR%%/config.syntax
-%%PORTDOCS%%%%EXAMPLESDIR%%/filter.rw
-%%PORTDOCS%%%%EXAMPLESDIR%%/hints-0.96
-%%PORTDOCS%%%%EXAMPLESDIR%%/jetstream.rw
-%%PORTDOCS%%%%EXAMPLESDIR%%/nt.rw
-%%PORTDOCS%%%%EXAMPLESDIR%%/pam.conf
-%%PORTDOCS%%%%EXAMPLESDIR%%/radius.php
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/README
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ascend.rw
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/c3620.rw
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cisco.rw
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/comos.rw
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/config.syntax
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/filter.rw
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hints-0.96
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/jetstream.rw
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/nt.rw
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pam.conf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/radius.php
@dirrm etc/raddb/dict
@dirrmtry etc/raddb
@dirrm include/radius
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
@dirrm %%DATADIR%%/%%PORTVERSION%%/scheme
@dirrm %%DATADIR%%/%%PORTVERSION%%/rewrite
-@dirrm %%DATADIR%%/%%PORTVERSION%%/modules
@dirrm %%DATADIR%%/%%PORTVERSION%%
@dirrm %%DATADIR%%
-@dirrmtry lib/security
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
+%%MODULES%%@dirrm lib/radius/%%PORTVERSION%%/modules
+%%MODULES%%@dirrm lib/radius/%%PORTVERSION%%
+%%MODULES%%@dirrm lib/radius
+@dirrm lib/security
@unexec rm -f %B/run/radiusd.pid
@unexec rm -rf %B/log/radius 2>&1 >/dev/null || true
@unexec echo "Leaving /var/run/radutmp, /var/log/radwtmp and /var/log/radstat alone."