aboutsummaryrefslogtreecommitdiff
path: root/net/go-amqp
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2015-01-25 22:32:44 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2015-01-25 22:32:44 +0000
commitd9641eb28a9575d9935cd3752c111ae4c2313795 (patch)
treef2e90eda0e9cb84ae29cd051eb5e5a9973f71ec9 /net/go-amqp
parentc95f2d2f741b7149e2d72a7a629bb62372db2dc4 (diff)
downloadports-d9641eb28a9575d9935cd3752c111ae4c2313795.tar.gz
ports-d9641eb28a9575d9935cd3752c111ae4c2313795.zip
Notes
Diffstat (limited to 'net/go-amqp')
-rw-r--r--net/go-amqp/Makefile24
-rw-r--r--net/go-amqp/distinfo2
-rw-r--r--net/go-amqp/pkg-descr3
-rw-r--r--net/go-amqp/pkg-plist30
4 files changed, 59 insertions, 0 deletions
diff --git a/net/go-amqp/Makefile b/net/go-amqp/Makefile
new file mode 100644
index 000000000000..88fa4ee154e4
--- /dev/null
+++ b/net/go-amqp/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= amqp
+PORTVERSION= 0.0.0.20140916
+CATEGORIES= net
+MASTER_SITES= GH GHC
+PKGNAMEPREFIX= go-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Go library for AMQP client with RabbitMQ extensions
+
+LICENSE= BSD2CLAUSE
+
+USE_GITHUB= yes
+GH_ACCOUNT= streadway
+GH_PROJECT= ${PORTNAME}
+GH_TAGNAME= ${GH_COMMIT}
+GH_COMMIT= 7d6d180
+
+GO_PKGNAME= github.com/${GH_ACCOUNT}/${GH_PROJECT}
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/lang/go/files/bsd.go.mk"
+.include <bsd.port.post.mk>
diff --git a/net/go-amqp/distinfo b/net/go-amqp/distinfo
new file mode 100644
index 000000000000..52fbf51a0834
--- /dev/null
+++ b/net/go-amqp/distinfo
@@ -0,0 +1,2 @@
+SHA256 (amqp-0.0.0.20140916.tar.gz) = 29dbd44b1cd66a2d28a6515319842a4256a41b354680435584c6ef9155183614
+SIZE (amqp-0.0.0.20140916.tar.gz) = 76086
diff --git a/net/go-amqp/pkg-descr b/net/go-amqp/pkg-descr
new file mode 100644
index 000000000000..b14e2b0c9be5
--- /dev/null
+++ b/net/go-amqp/pkg-descr
@@ -0,0 +1,3 @@
+AMQP client with RabbitMQ extensions in Go.
+
+WWW: https://github.com/streadway/amqp
diff --git a/net/go-amqp/pkg-plist b/net/go-amqp/pkg-plist
new file mode 100644
index 000000000000..faa04e5adbbe
--- /dev/null
+++ b/net/go-amqp/pkg-plist
@@ -0,0 +1,30 @@
+%%GO_LIBDIR%%/%%GO_PKGNAME%%.a
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/LICENSE
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/README.md
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/auth.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/certs.sh
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/channel.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/client_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/connection.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/consumers.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/delivery.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/doc.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/examples/pubsub/pubsub.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/examples/simple-consumer/consumer.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/examples/simple-producer/producer.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/examples_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/gen.sh
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/integration_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/read.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/reconnect_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/registry.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/return.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/shared_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/spec/amqp0-9-1.stripped.extended.xml
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/spec/gen.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/spec091.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/tls_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/types.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/uri.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/uri_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/write.go