aboutsummaryrefslogtreecommitdiff
path: root/net/go-cs
diff options
context:
space:
mode:
authorRichard Gallamore <ultima@FreeBSD.org>2017-07-07 01:03:51 +0000
committerRichard Gallamore <ultima@FreeBSD.org>2017-07-07 01:03:51 +0000
commit45219604c9f30d722d56a5e05e6f257e0374c938 (patch)
tree5495849794a968f0c86512bf295098c054b001d4 /net/go-cs
parentb23b4e69f0d9b894ee51be0efe2d2c1a7a96b7b1 (diff)
downloadports-45219604c9f30d722d56a5e05e6f257e0374c938.tar.gz
ports-45219604c9f30d722d56a5e05e6f257e0374c938.zip
Notes
Diffstat (limited to 'net/go-cs')
-rw-r--r--net/go-cs/Makefile14
-rw-r--r--net/go-cs/distinfo6
-rw-r--r--net/go-cs/pkg-descr5
3 files changed, 9 insertions, 16 deletions
diff --git a/net/go-cs/Makefile b/net/go-cs/Makefile
index ceeaa9e76eaa..3afc290e18a3 100644
--- a/net/go-cs/Makefile
+++ b/net/go-cs/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= go-cs
-PORTVERSION= 0.6
+PORTVERSION= 0.7
DISTVERSIONPREFIX= v
CATEGORIES= net
@@ -12,21 +12,15 @@ COMMENT= Concurrent ssh client
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ${GO_CMD}:lang/go
-
+USES= go
USE_GITHUB= yes
GH_ACCOUNT= akosela
PLIST_FILES= bin/cs man/man1/cs.1.gz
-GO_CMD= ${LOCALBASE}/bin/go
-GO_ARGS= build -ldflags "${STRIP}"
-
-do-build:
- (cd ${WRKSRC}/cs && ${GO_CMD} ${GO_ARGS} cs.go)
+GO_TARGET= ${GO_PKGNAME}/cs
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/cs/cs ${STAGEDIR}${PREFIX}/bin
+post-install:
${INSTALL_MAN} ${WRKSRC}/cs.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
.include <bsd.port.mk>
diff --git a/net/go-cs/distinfo b/net/go-cs/distinfo
index 24ff4dafee54..9cde6280821e 100644
--- a/net/go-cs/distinfo
+++ b/net/go-cs/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1476221383
-SHA256 (akosela-go-cs-v0.6_GH0.tar.gz) = f5bd4e3d2b7853d77bfa209b69e56f6d79058f25e8e56a2d8a468834b3e6d9c9
-SIZE (akosela-go-cs-v0.6_GH0.tar.gz) = 6296
+TIMESTAMP = 1499319273
+SHA256 (akosela-go-cs-v0.7_GH0.tar.gz) = bd7371fc89ac6a362af8b79ac53cc572ec9de38abb8c1ef1b9db65c400ef006a
+SIZE (akosela-go-cs-v0.7_GH0.tar.gz) = 8173
diff --git a/net/go-cs/pkg-descr b/net/go-cs/pkg-descr
index 94ddf2eee298..0348b69311d5 100644
--- a/net/go-cs/pkg-descr
+++ b/net/go-cs/pkg-descr
@@ -1,5 +1,4 @@
-cs is a program for concurrently executing ssh(1) or scp(1) on a number
-of hosts. It is intended to automate running remote commands or copying
-files between hosts on a network.
+cs is a program for concurrently executing local or remote commands on
+multiple hosts. It is using OpenSSH for running remote commands.
WWW: https://github.com/akosela/go-cs