aboutsummaryrefslogtreecommitdiff
path: root/net/go-geoip
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2015-08-23 07:12:09 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2015-08-23 07:12:09 +0000
commit605c6e20c1a80308f4dbdc1fcfdeee8897538574 (patch)
tree24096f1b1fc777b9df5e79ac4a073bbd8f9b2a4c /net/go-geoip
parent2b0c2692089b5f33e907d1573f3bb4cd71424626 (diff)
downloadports-605c6e20c1a80308f4dbdc1fcfdeee8897538574.tar.gz
ports-605c6e20c1a80308f4dbdc1fcfdeee8897538574.zip
Notes
Diffstat (limited to 'net/go-geoip')
-rw-r--r--net/go-geoip/Makefile29
-rw-r--r--net/go-geoip/distinfo2
-rw-r--r--net/go-geoip/pkg-descr7
-rw-r--r--net/go-geoip/pkg-plist8
4 files changed, 46 insertions, 0 deletions
diff --git a/net/go-geoip/Makefile b/net/go-geoip/Makefile
new file mode 100644
index 000000000000..e4d2f54c3cca
--- /dev/null
+++ b/net/go-geoip/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= geoip
+PORTVERSION= 0.0.0.20131016
+CATEGORIES= net
+MASTER_SITES= GH GHC
+PKGNAMEPREFIX= go-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Go library to wrap the libgeoip C library
+
+LICENSE= MIT
+
+LIB_DEPENDS= libGeoIP.so:${PORTSDIR}/net/GeoIP
+
+USES= compiler
+USE_GITHUB= yes
+GH_ACCOUNT= abh
+GH_PROJECT= ${PORTNAME}
+GH_TAGNAME= da13074
+
+GO_PKGNAME= github.com/${GH_ACCOUNT}/${GH_PROJECT}
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/lang/go/files/bsd.go.mk"
+.if ${COMPILER_TYPE} == clang && ${CC} == cc
+CC= clang
+.endif
+.include <bsd.port.post.mk>
diff --git a/net/go-geoip/distinfo b/net/go-geoip/distinfo
new file mode 100644
index 000000000000..80f458b470ea
--- /dev/null
+++ b/net/go-geoip/distinfo
@@ -0,0 +1,2 @@
+SHA256 (geoip-0.0.0.20131016_GH0.tar.gz) = 90607958d4301d0ea7a51828290cbe9c8ec5914dc8b1d5150c27894e4ea315d5
+SIZE (geoip-0.0.0.20131016_GH0.tar.gz) = 5758
diff --git a/net/go-geoip/pkg-descr b/net/go-geoip/pkg-descr
new file mode 100644
index 000000000000..ef538a5c47d6
--- /dev/null
+++ b/net/go-geoip/pkg-descr
@@ -0,0 +1,7 @@
+This package wraps the libgeoip C library for access from Go
+(golang).
+
+You can download the free GeoLite Country database or you can
+subscribe to updates.
+
+WWW: https://github.com/abh/geoip
diff --git a/net/go-geoip/pkg-plist b/net/go-geoip/pkg-plist
new file mode 100644
index 000000000000..5b745eef32e9
--- /dev/null
+++ b/net/go-geoip/pkg-plist
@@ -0,0 +1,8 @@
+%%GO_LIBDIR%%/%%GO_PKGNAME%%.a
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/LICENSE
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/README.md
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/const.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/db/download
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/ex/geoip-demo.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/geoip.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/geoip_test.go