aboutsummaryrefslogtreecommitdiff
path: root/net/go-httppath
diff options
context:
space:
mode:
authorCarlo Strub <cs@FreeBSD.org>2016-07-08 21:45:49 +0000
committerCarlo Strub <cs@FreeBSD.org>2016-07-08 21:45:49 +0000
commit79354079016eec1cb6bb584e8417a8c2e63c5b27 (patch)
tree60103a4c7ca9276d218b5bbf36e5570739c957d1 /net/go-httppath
parentb4742975614be5b488b0fdb036be37c0a85c1de5 (diff)
Notes
Diffstat (limited to 'net/go-httppath')
-rw-r--r--net/go-httppath/Makefile19
-rw-r--r--net/go-httppath/distinfo3
-rw-r--r--net/go-httppath/pkg-descr4
-rw-r--r--net/go-httppath/pkg-plist5
4 files changed, 31 insertions, 0 deletions
diff --git a/net/go-httppath/Makefile b/net/go-httppath/Makefile
new file mode 100644
index 000000000000..e9e9dce20c26
--- /dev/null
+++ b/net/go-httppath/Makefile
@@ -0,0 +1,19 @@
+# $FreeBSD$
+
+PORTNAME= httppath
+PORTVERSION= 20140515
+CATEGORIES= net
+PKGNAMEPREFIX= go-
+
+MAINTAINER= cs@FreeBSD.org
+COMMENT= Utilities for HTTP Path manipulation
+
+LICENSE= MIT
+
+USE_GITHUB= yes
+GH_ACCOUNT= dimfeld
+GH_TAGNAME= c8e499c3ef3c3e272ed8bdcc1ccf39f73c88debc
+USES= go
+GO_PKGNAME= github.com/${GH_ACCOUNT}/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/net/go-httppath/distinfo b/net/go-httppath/distinfo
new file mode 100644
index 000000000000..ad1f18934e9a
--- /dev/null
+++ b/net/go-httppath/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1468014225
+SHA256 (dimfeld-httppath-20140515-c8e499c3ef3c3e272ed8bdcc1ccf39f73c88debc_GH0.tar.gz) = ff0e0e788a10c600ca6a327f827497ea2f72d6f70711dec44d04404e124fc4fa
+SIZE (dimfeld-httppath-20140515-c8e499c3ef3c3e272ed8bdcc1ccf39f73c88debc_GH0.tar.gz) = 3128
diff --git a/net/go-httppath/pkg-descr b/net/go-httppath/pkg-descr
new file mode 100644
index 000000000000..434caa136ec6
--- /dev/null
+++ b/net/go-httppath/pkg-descr
@@ -0,0 +1,4 @@
+Utilities for HTTP Path manipulation. Currently, this just contains the
+CleanPath function, renamed to Clean, from Julien Schmidt's httprouter.
+
+WWW: https://github.com/dimfeld/httppath
diff --git a/net/go-httppath/pkg-plist b/net/go-httppath/pkg-plist
new file mode 100644
index 000000000000..4eb7378395de
--- /dev/null
+++ b/net/go-httppath/pkg-plist
@@ -0,0 +1,5 @@
+%%GO_LIBDIR%%/%%GO_PKGNAME%%.a
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/LICENSE
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/README.md
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/path.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/path_test.go