aboutsummaryrefslogtreecommitdiff
path: root/net/go-nats
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2016-09-27 09:01:23 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2016-09-27 09:01:23 +0000
commit70381e7766091ba93286cbf0460973529a9ffe15 (patch)
tree01907b8287b4ac99b46c13f497ddd5347d565905 /net/go-nats
parent9d2a60235b1d9d982b33621d8dc668f46f382f33 (diff)
downloadports-70381e7766091ba93286cbf0460973529a9ffe15.tar.gz
ports-70381e7766091ba93286cbf0460973529a9ffe15.zip
Notes
Diffstat (limited to 'net/go-nats')
-rw-r--r--net/go-nats/Makefile23
-rw-r--r--net/go-nats/distinfo3
-rw-r--r--net/go-nats/pkg-descr3
-rw-r--r--net/go-nats/pkg-plist44
4 files changed, 73 insertions, 0 deletions
diff --git a/net/go-nats/Makefile b/net/go-nats/Makefile
new file mode 100644
index 000000000000..7fb8dcacdbda
--- /dev/null
+++ b/net/go-nats/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= nats
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.2.0
+CATEGORIES= net
+PKGNAMEPREFIX= go-
+
+MAINTAINER= olgeni@FreeBSD.org
+COMMENT= Go client for NATS
+
+LICENSE= MIT
+
+BUILD_DEPENDS= go-nuid>=0:devel/go-nuid
+RUN_DEPENDS= go-nuid>=0:devel/go-nuid
+
+USES= go
+USE_GITHUB= yes
+GH_ACCOUNT= nats-io
+
+GO_PKGNAME= github.com/${GH_ACCOUNT}/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/net/go-nats/distinfo b/net/go-nats/distinfo
new file mode 100644
index 000000000000..3343d34aec7d
--- /dev/null
+++ b/net/go-nats/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1474724119
+SHA256 (nats-io-nats-v1.2.0_GH0.tar.gz) = 9d29cbc61872e2bb0413fc18d4667a9cf4e1cd6d4fda07a358a7dae32ee0228e
+SIZE (nats-io-nats-v1.2.0_GH0.tar.gz) = 71203
diff --git a/net/go-nats/pkg-descr b/net/go-nats/pkg-descr
new file mode 100644
index 000000000000..4ec627374a93
--- /dev/null
+++ b/net/go-nats/pkg-descr
@@ -0,0 +1,3 @@
+Golang client for NATS, the cloud native messaging system.
+
+WWW: https://github.com/nats-io/nats
diff --git a/net/go-nats/pkg-plist b/net/go-nats/pkg-plist
new file mode 100644
index 000000000000..88d3fa360bc6
--- /dev/null
+++ b/net/go-nats/pkg-plist
@@ -0,0 +1,44 @@
+%%GO_LIBDIR%%/%%GO_PKGNAME%%.a
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/LICENSE
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/README.md
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/TODO.md
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/enc.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/enc_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/encoders/builtin/default_enc.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/encoders/builtin/enc_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/encoders/builtin/gob_enc.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/encoders/builtin/gob_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/encoders/builtin/json_enc.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/encoders/builtin/json_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/encoders/protobuf/protobuf_enc.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/encoders/protobuf/protobuf_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/encoders/protobuf/testdata/pbtest.pb.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/encoders/protobuf/testdata/pbtest.proto
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/example_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/examples/nats-bench.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/examples/nats-pub.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/examples/nats-qsub.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/examples/nats-req.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/examples/nats-rply.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/examples/nats-sub.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nats.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/nats_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/netchan.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/parser.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/scripts/cov.sh
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/test/auth_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/test/basic_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/test/bench_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/test/cluster_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/test/configs/certs/ca.pem
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/test/configs/certs/client-cert.pem
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/test/configs/certs/client-key.pem
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/test/configs/certs/key.pem
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/test/configs/certs/server.pem
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/test/configs/tls.conf
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/test/configs/tlsverify.conf
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/test/conn_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/test/netchan_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/test/reconnect_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/test/sub_test.go
+%%GO_SRCDIR%%/%%GO_PKGNAME%%/test/test.go