aboutsummaryrefslogtreecommitdiff
path: root/net/grdc
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-04-23 17:30:12 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-04-23 17:30:12 +0000
commit6abfdf6db901e077e8cac90aa7229a861b65f737 (patch)
treee7e2260c47cd4c95b23c8f6dd565458b565a91fa /net/grdc
parentd426ccb2599e41034bfd46fca004ce88d01c6613 (diff)
downloadports-6abfdf6db901e077e8cac90aa7229a861b65f737.tar.gz
ports-6abfdf6db901e077e8cac90aa7229a861b65f737.zip
Notes
Diffstat (limited to 'net/grdc')
-rw-r--r--net/grdc/Makefile48
-rw-r--r--net/grdc/distinfo3
-rw-r--r--net/grdc/pkg-descr17
-rw-r--r--net/grdc/pkg-plist12
4 files changed, 80 insertions, 0 deletions
diff --git a/net/grdc/Makefile b/net/grdc/Makefile
new file mode 100644
index 000000000000..97f7c0740646
--- /dev/null
+++ b/net/grdc/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: grdc
+# Date created: 12 April 2009
+# Whom: Alexander Logvinov <ports@logvinov.com>
+#
+# $FreeBSD$
+
+PORTNAME= grdc
+PORTVERSION= 0.5.0
+CATEGORIES= net gnome
+MASTER_SITES= SF
+
+MAINTAINER= ports@logvinov.com
+COMMENT= GTK+/GNOME remote desktop client
+
+RUN_DEPENDS= rdesktop:${PORTSDIR}/net/rdesktop
+
+OPTIONS= VNC "Build with VNC protocol support" off \
+ SSH "Build with SSH tunneling support" off \
+ GCRYPT "Build with libgcrypt support (only with SSH)" off
+
+MAKE_JOBS_SAFE= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_GETTEXT= yes
+USE_GNOME= gnomehack gnomeprefix glib20 gtk20
+CFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+CONFIGURE_ENV= CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_VNC)
+LIB_DEPENDS+= vncclient.0:${PORTSDIR}/net/libvncserver
+.endif
+
+.if defined(WITH_SSH)
+LIB_DEPENDS+= ssh.2:${PORTSDIR}/security/libssh
+.if defined(WITH_GCRYPT)
+LIB_DEPENDS+= gcrypt.16:${PORTSDIR}/security/libgcrypt
+.endif
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|Exec=grdc|Exec=${PREFIX}/bin/grdc|' \
+ ${WRKSRC}/src/grdc.desktop.in
+
+.include <bsd.port.post.mk>
diff --git a/net/grdc/distinfo b/net/grdc/distinfo
new file mode 100644
index 000000000000..961bdf4f87dc
--- /dev/null
+++ b/net/grdc/distinfo
@@ -0,0 +1,3 @@
+MD5 (grdc-0.5.0.tar.gz) = 6209476d9779db461220d1687db9ae30
+SHA256 (grdc-0.5.0.tar.gz) = 1b8f3b59d9a9e10673a37d5994018a26e2b24c1e4cae8e58153f2178877c5eb2
+SIZE (grdc-0.5.0.tar.gz) = 196929
diff --git a/net/grdc/pkg-descr b/net/grdc/pkg-descr
new file mode 100644
index 000000000000..8203f27fe0e7
--- /dev/null
+++ b/net/grdc/pkg-descr
@@ -0,0 +1,17 @@
+Grdc is a remote desktop client based on GTK+ and GNOME.
+
+The Grdc main program:
+
+ * A pure GTK+ 2.0 application!
+ * Maintain a list of remote desktop files for most frequently used servers
+ * Make quick connections by directly putting in the server name
+ * Remote desktops with higher resolutions are scrollable/scalable in both
+ window and fullscreen mode
+ * Viewport fullscreen mode: remote desktop automatically scrolls when the
+ mouse moves over the screen edge.
+ * Floating toolbar in fullscreen mode, allows you to switch between modes,
+ toggle keyboard grabbing, minimize, etc.
+ * RDP protocol is supported by rdesktop; VNC protocol is supported by
+ libvncclient; SSH tunneling is supported by libssh.
+
+WWW: http://grdc.sourceforge.net/
diff --git a/net/grdc/pkg-plist b/net/grdc/pkg-plist
new file mode 100644
index 000000000000..eec7657ac6be
--- /dev/null
+++ b/net/grdc/pkg-plist
@@ -0,0 +1,12 @@
+bin/grdc
+share/applications/grdc.desktop
+share/locale/es/LC_MESSAGES/grdc.mo
+share/locale/pl/LC_MESSAGES/grdc.mo
+share/locale/zh_CN/LC_MESSAGES/grdc.mo
+share/pixmaps/grdc-rdp-ssh.png
+share/pixmaps/grdc-rdp.png
+share/pixmaps/grdc-vnc-ssh.png
+share/pixmaps/grdc-vnc.png
+share/pixmaps/grdc.png
+@dirrmtry share/applications
+@dirrmtry share/pixmaps